Zoeken in Support

Vermijd ondersteuningsscams. We zullen u nooit vragen een telefoonnummer te bellen, er een sms naar te sturen of persoonlijke gegevens te delen. Meld verdachte activiteit met de optie ‘Misbruik melden’.

Learn More

Create desktop shortcuts with Firefox

  • 8 antwoorden
  • 1 heeft dit probleem
  • 106 weergaven
  • Laatste antwoord van FredMcD

more options

I used to create desktop shortcuts to websites by dragging the padlock thumbnail to the left of the URL to the desktop. (see first image)

Now it does not create a shortcut but instead creates a file on the desktop with a .URL extension.(see 2nd image) Double clicking on the file will take me to the website, but as a file and not a shortcut, I cannot modify the name displayed or change the icon displayed.

Am I looking at something new in version 96 or have I inadvertantly changed something in the settings?

Gekoppelde schermafbeeldingen

Gekozen oplossing

Solved the problem.

The Web Document tab was missing from the file properties window due apparently to some problem with the .url file association.

This was resolved by using the information from option 2 shown in: https://www.tenforums.com/tutorials/8703-restore-default-file-type-associations-windows-10-a.html

I was unaware that two forms of shortcut existed - .url and .lnk

The tenforums link contains a list of default file extension and protocol associations available to download and use to reset the associations, icon, and registry entries of the downloaded file type or protocol back to default.

Thank you for your efforts.

Dit antwoord in context lezen 👍 0

Alle antwoorden (8)

more options

Instead of the padlock, grab the icon next to it.

Behulpzaam?

more options

The icon left of the padlock looks like a shield. Can not pick it up by clicking and dragging.

Copying the .url file to a folder and then right clicking allows me to copy and then paste shortcut on desktop. But that’s pretty cumbersome.

On my wife’s laptop, dragging the padlock to the desktop creates a shortcut.

I can’t figure out if the problem is in Windows or Firefox.

Behulpzaam?

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Behulpzaam?

more options

A .url file is a shortcut to a URL (a .lnk file is a shortcut to a local file). Normally, Windows hides that file extension when creating a URL shortcut.

Your .url shortcut opens a locally saved file -- the address of the page in Firefox's address bar starts with file:/// instead of http:// or https://? That's very strange. I don't think that is a Firefox feature, but I'm not sure what is causing it.

Behulpzaam?

more options

FredMcD

Problem still exists when starting in Troubleshoot(Safe) mode.

Here's an example: The url currently shows: https://support.mozilla.org/en-US/questions/1365536 If I click and drag the padlock icon, it creates a file on the desktop that displays: "Create desktop shortcuts with Firefox Firefox Support Forum Mozilla Support.URL"

It does not have the tiny arrow on the lower left side of the icon that indicates shortcut. In File Explorer it shows up in Desktop as Type URL File.

If I move that file off the Desktop to a Document Folder, then Copy it and use Paste Shortcut to put it on to the Desktop, I get a true shortcut.

The URL version properties show in the first image. The Shortcut version properties show in the second.

As you can see the first one does not provide for renaming or changing the icon. The second does.

I try to keep my Desktop as simple as possible by keeping only shortcuts there and not actual files. I do that by keeping the actual files in a folder named Shortcuts and pasting the shortcut to the desktop.

That way, if I delete the shortcut, I can always get back to it by creating another shortcut.

What I don't understand is why everything works properly on my wife's laptop and not my desktop - same versions of Windows 10 and Firefox.

Problem still shows in safe mode and after removing and re-installing Firefox. To me that suggests something in Windows but I have no idea where. If even done the DISM and SFC steps and everything shows no corruption. Arrrrrrrgh.

Behulpzaam?

more options

Behulpzaam?

more options

Gekozen oplossing

Solved the problem.

The Web Document tab was missing from the file properties window due apparently to some problem with the .url file association.

This was resolved by using the information from option 2 shown in: https://www.tenforums.com/tutorials/8703-restore-default-file-type-associations-windows-10-a.html

I was unaware that two forms of shortcut existed - .url and .lnk

The tenforums link contains a list of default file extension and protocol associations available to download and use to reset the associations, icon, and registry entries of the downloaded file type or protocol back to default.

Thank you for your efforts.

Behulpzaam?

more options

That was very good work. Well Done.

Behulpzaam?

Een vraag stellen

U moet zich aanmelden bij uw account om op berichten te antwoorden. Stel een nieuwe vraag als u nog geen account hebt.