Zoeken in Support

Why would Firefox make me get a security code for every login on websites

  • 9 antwoorden
  • 2 hebben dit probleem
  • 3 weergaven
  • Laatste antwoord van myprettypenny

more options

My bank site, amazon & other sites with secure login require verification every time I want to log in ONLY on Firefox. IE does not do this BUT I support and prefer to use Firefox. I have refreshed Firefox, I completely removed Firefox and downloaded and installed fresh, I have run Ccleaner, Cleared my data and after entering my login and security code it will STILL demand a code even though I have not even closed the browser when trying to log in a second time. I have been trying to fix this for 3 days now! Nothing works.

Gekoppelde schermafbeeldingen

Gekozen oplossing

If it works when you disable your extensions then it is likely that one of them is causing this issue.

If it works in Safe Mode and in normal mode with extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

You may need to close and restart Firefox via one of these after each change:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
Dit antwoord in context lezen 👍 1

Alle antwoorden (9)

more options

Looks like you are talking about Two Factor Authorization. (2FA) That is a website option. Open your profile on that site.

Behulpzaam?

more options

Maybe you lose the cookies that websites use to recognize you.

A detail like a website remembering you (log you in automatically) is stored in a cookie.

You can use these steps to make a website recognize and remember you:

  • you can create an allow exception to keep cookies for specific websites, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Permissions"

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Cookies
  • do not clear the Site Preferences
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data
  • clearing "Cookies" will remove all selected cookies including cookies with an allow exception you may want to keep

Behulpzaam?

more options

cor-el said

Maybe you lose the cookies that websites use to recognize you. A detail like a website remembering you (log you in automatically) is stored in a cookie. You can use these steps to make a website recognize and remember you:
  • you can create an allow exception to keep cookies for specific websites, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Permissions"
In case you use "Clear history when Firefox closes" or otherwise clear history.
  • do not clear the Cookies
  • do not clear the Site Preferences
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data
  • clearing "Cookies" will remove all selected cookies including cookies with an allow exception you may want to keep

Been there / Done that, didn't help. I know about cookies, history and clearing data, those suggestions do not apply in this case. I am using the same settings that have worked for at least 12 years on Firefox & only Firefox is doing this. It all started with the last Microsoft update. My settings on TD's website are set appropriately as you can see from the screen shot. I have been on computers since the Apple 2C came out and before the days of the internet, this is the first time a settings problem (?) could not be fixed by me, in house. I am at a total loss! (TD is also investigating the problem from their end. It has caused Amazon to lock my account for to many failed logins & their CS was useless!

Bewerkt door myprettypenny op

Behulpzaam?

more options

FredMcD said

Looks like you are talking about Two Factor Authorization. (2FA) That is a website option. Open your profile on that site.

I am indeed! (Talking about 2FA) The website's settings are correct as you can see in the TD screen shot. For what ever reason, it seems like Firefox is not holding the data/cookies in spite of my settings all being set correctly.

Behulpzaam?

more options

P.S. Did I mention it does this even without my closing Firefox! I don't even need to close to for Firefox to lose the site data!

Behulpzaam?

more options

You aren't using containers or Private Browsing mode ?

Does it make a difference if you create a cookie allow exception for involved domains?

This can also be caused by an extension that deals with cookies.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check in the Web Console what content is blocked.

Behulpzaam?

more options

OK, I think I fixed the problem, though I have no idea what it was! I simply disabled ad block, HTTPs everywhere and privacy badger, turned off tracking protections for the concerned websites. This has not made me happy because these items never caused issues before and I still suspect the last MS update made changes that negatively impacted those protections.. I do not know which of the items I disabled was the responsible culprit. It does seem the cure is one that puts me more at risk online!

Yesterday I ordered a new PC to load a Linux OS into. I can stand the add-ons being disabled for a week until I get the new machine but I have definitely had enough with Microsoft messing me around after "updating" my PC. This last round was the last straw for me! For one thing, I had to do a forced reboot 4 times, 3 times all I got was a dead, black screen. (Scared the heck out of me!) I think Linux will not be as aggressive as MS when it comes to messing with settings and not telling me what was done or changed.

Many thanks for your time, thoughts and suggestions.

Behulpzaam?

more options

Gekozen oplossing

If it works when you disable your extensions then it is likely that one of them is causing this issue.

If it works in Safe Mode and in normal mode with extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

You may need to close and restart Firefox via one of these after each change:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

Behulpzaam?

more options

cor-el said

If it works when you disable your extensions then it is likely that one of them is causing this issue. If it works in Safe Mode and in normal mode with extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears. You may need to close and restart Firefox via one of these after each change:
  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

I did just as you suggested. It appears it was ADBLOCK and tracking protection causing the issue, but again, these protections have been turned on for 12 years! It has only caused interference over the past few days. (After my last MS update) The system is still OK with Privacy Badger. Also, I did know about exiting Firefox to confirm changes.

Behulpzaam?

Een vraag stellen

U moet zich aanmelden bij uw account om op berichten te antwoorden. Stel een nieuwe vraag als u nog geen account hebt.