X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Black artifacts when resizing browser window

Geplaatst

The latest Firefox update ( 39 ) shows black artifacts on browser window and toolbar when resizing window. They dissapear when I resize the window or scroll.

The image uploader on this page does not seem to work, gets stuck on uploading...so this is the link to the image https://drive.google.com/open?id=0B9GV3PS3m5ioQjhjZGRuX0w4czQ

  • Hardware acceleration ( disabled )
  • I've done a clean install and restored my previous profile ( issue still present )
The latest Firefox update ( 39 ) shows black artifacts on browser window and toolbar when resizing window. They dissapear when I resize the window or scroll. The image uploader on this page does not seem to work, gets stuck on uploading...so this is the link to the image https://drive.google.com/open?id=0B9GV3PS3m5ioQjhjZGRuX0w4czQ * Hardware acceleration ( disabled ) * I've done a clean install and restored my previous profile ( issue still present )

Gekozen oplossing

Since zooming, which forces a repaint, fixes the display at least temporarily, you could try disabling OMTC, a feature introduced in Firefox 33. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste layers and pause while the list is filtered

(3) Double-click the layers.offmainthreadcomposition.enabled preference to switch it from true to false

Any difference?

Note: I read in a bug report a while back that this change causes problems with the HTML5 player on YouTube, if hardware acceleration is disabled, so you might also need to force Flash on YouTube if you keep this setting. You can use an add-on for that: https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/

Dit antwoord in context lezen 5

Aanvullende systeemdetails

Geïnstalleerde plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 15.007.20033
  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • Provides information about the default web browser
  • Version 5.41.0.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0

Toepassing

  • Firefox 39.0
  • Useragent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:39.0) Gecko/20100101 Firefox/39.0
  • Ondersteunings-URL: https://support.mozilla.org/1/firefox/39.0/Darwin/en-US/

Extensies

  • 1Password 4.4.0 (onepassword4@agilebits.com)
  • Spanish (Venezuela) spell check dictionary 1.1.17 (es-ve@dictionaries.addons.mozilla.org)
  • uBlock Origin 0.9.9.3 (uBlock0@raymondhill.net)
  • Video DownloadHelper 5.3.1.1-signed ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Inactief)
  • Wappalyzer 3.0.16 (wappalyzer@crunchlabz.com) (Inactief)
  • Web Developer 1.2.5.1-signed ({c45c406e-ab73-11d8-be73-000a95be3b12}) (Inactief)

Javascript

  • incrementalGCEnabled: True

Grafisch

  • adapterDescription:
  • adapterDeviceID: 0x a26
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • webglRenderer: Intel Inc. -- Intel HD Graphics 5000 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Aangepaste voorkeuren

Div

  • User JS: nee
  • Toegankelijkheid: nee
FredMcD
  • Top 10 Contributor
4245 oplossingen 59390 antwoorden

check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting''' --------------------------- Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there?

Nuttig antwoord

Thanks for the reply @FredMcD, I followed your recommendations however none of these helped.

  • My graphic drivers are up to date, issue still present
  • Hardware acceleration is turned off, issue still present
  • I've disabled WebGL, issue still present
  • Flash is disabled (Ask to Activate) and protected mode is not available for OSX. Furthermore, this issue happens on pages with no Flash at all.
  • Flash hardware acceleration is disabled, issue still present
  • Started Firefox in Safe Mode, issue still present
  • Completely uninstalled Firefox and performed a clean install, issue still present
Thanks for the reply @FredMcD, I followed your recommendations however none of these helped. * My graphic drivers are up to date, '''issue still present''' * Hardware acceleration is turned off, '''issue still present''' * I've disabled WebGL, '''issue still present''' * Flash is disabled (Ask to Activate) and protected mode is not available for OSX. Furthermore, this issue happens on pages with no Flash at all. * Flash hardware acceleration is disabled, '''issue still present''' * Started Firefox in Safe Mode, '''issue still present''' * Completely uninstalled Firefox and performed a clean install, '''issue still present'''
FredMcD
  • Top 10 Contributor
4245 oplossingen 59390 antwoorden

sebasll said

  • Started Firefox in Safe Mode, issue still present

This means the problem may be outside Firefox.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac:<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.


Use this link to check that your plugins are up-to-date. If any are listed as unknown or research, do not worry about them.


https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently

https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues?redirectlocale=en-US&redirectslug=Video+or+audio+does+not+play

https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

''sebasll [[#answer-751645|said]]'' <blockquote> * Started Firefox in Safe Mode, '''issue still present''' </blockquote> This means the problem may be outside Firefox. Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac:<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins.''' Make sure the ones you want to use are set to '''Ask''' or '''Allow.''' -------------- Go to the web page. Once the page is loading, mouse to the address bar and '''Left''' click the icon. A window for displaying site information should come up. Select '''More Information.''' Now select '''Permissions.''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow.''' -------------------------- '''[https://www.mozilla.org/en-US/plugincheck/ Use this link to check that your plugins are up-to-date.]''' If any are listed as unknown or research, do not worry about them. -------------------------- '''https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently''' https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues?redirectlocale=en-US&redirectslug=Video+or+audio+does+not+play https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

Vraageigenaar

Thanks, but not sure how my plugin permissions are related to the artifacts that I'm seeing on all websites. None of the plugins are related to display rendering.

All my plugins except for the default Firefox OpenH264 plugin are set to Ask to Activate. Once set here, I shouldn't have to do this on a page per page basis, unless I want different rules for that particular page. Nevertheless I did test it and Issue is still present.

All plugins are up to date as well.

Thanks, but not sure how my plugin permissions are related to the artifacts that I'm seeing on '''all''' websites. None of the plugins are related to display rendering. All my plugins except for the default Firefox OpenH264 plugin are set to '''Ask to Activate'''. Once set here, I shouldn't have to do this on a page per page basis, unless I want different rules for that particular page. Nevertheless I did test it and '''Issue is still present'''. All plugins are up to date as well.
FredMcD
  • Top 10 Contributor
4245 oplossingen 59390 antwoorden

Is the issue with one site, or several?

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Is the issue with one site, or several? Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]''' -------------------- Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.
jscher2000
  • Top 10 Contributor
8684 oplossingen 70998 antwoorden

Gekozen oplossing

Since zooming, which forces a repaint, fixes the display at least temporarily, you could try disabling OMTC, a feature introduced in Firefox 33. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste layers and pause while the list is filtered

(3) Double-click the layers.offmainthreadcomposition.enabled preference to switch it from true to false

Any difference?

Note: I read in a bug report a while back that this change causes problems with the HTML5 player on YouTube, if hardware acceleration is disabled, so you might also need to force Flash on YouTube if you keep this setting. You can use an add-on for that: https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/

Since zooming, which forces a repaint, fixes the display at least temporarily, you could try disabling OMTC, a feature introduced in Firefox 33. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''layers''' and pause while the list is filtered (3) Double-click the '''layers.offmainthreadcomposition.enabled''' preference to switch it from true to false Any difference? Note: I read in a bug report a while back that this change causes problems with the HTML5 player on YouTube, if hardware acceleration is disabled, so you might also need to force Flash on YouTube if you keep this setting. You can use an add-on for that: https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/

Vraageigenaar

OMG, jscher2000, thank you so much. That totally fixed the issue that I was having. Odly though it only started happening when I updated from Frirefox versoion 38 to 39. It also seemed to affect the browsers UI components (toolbar, titlebar, etc.) It was driving me nuts.

Firefox should really look into this issue.

As far as YouTube, I only use the HTML5 player, so I have no concerns there. Even if I did, I much rather have a properly working browser.

Anyhow, thanks again jscher2000

OMG, [http://example.com jscher2000], thank you so much. That totally fixed the issue that I was having. Odly though it only started happening when I updated from Frirefox versoion 38 to 39. It also seemed to affect the browsers UI components (toolbar, titlebar, etc.) It was driving me nuts. Firefox should really look into this issue. As far as YouTube, I only use the HTML5 player, so I have no concerns there. Even if I did, I much rather have a properly working browser. Anyhow, thanks again [http://example.com jscher2000]

Bewerkt door sebasll op