X
Tik hier voor de mobiele versie van de website.

Ondersteuningsforum

Deze conversatie is gearchiveerd. Stel een nieuwe vraag als u hulp nodig hebt.

Why does Firefox cause my system audio to function improperly?

Geplaatst

Recently (since yesterday to be precise), I've had strange audio issues. What happens is audio works fine, but after a while it won't play all of the sounds it's trying to. This happens on a system wide level, as in clicking the global audio volume mixer won't always play a sound when clicked. I don't mean it plays and shows the sound playing yet no sound is heard; it straight up doesn't play the sound. Audio won't play on YouTube videos unless paused and played a few times, and Windows Media Player says there are problems playing files while this is going on. The problem continues to worsen over time, eventually making nearly all attempted audio plays to fail.

Opening FL Studios (which I have set to use specific, sound recording audio codecs) and closing it resets the problem and audio will work as normal. I found out today that closing Firefox fixes the problem immediately as well. This leads me to strongly believe that Firefox is the culprit.

I should note that I only remember experiencing this issue while working on a game that uses Audio elements (and potentially quite a few, albeit they are usually copies). I usually have the global volume for the game turned off when working, if that helps.

Recently (since yesterday to be precise), I've had strange audio issues. What happens is audio works fine, but after a while it won't play all of the sounds it's trying to. This happens on a system wide level, as in clicking the global audio volume mixer won't always play a sound when clicked. I don't mean it plays and shows the sound playing yet no sound is heard; it straight up doesn't play the sound. Audio won't play on YouTube videos unless paused and played a few times, and Windows Media Player says there are problems playing files while this is going on. The problem continues to worsen over time, eventually making nearly all attempted audio plays to fail. Opening FL Studios (which I have set to use specific, sound recording audio codecs) and closing it resets the problem and audio will work as normal. I found out today that closing Firefox fixes the problem immediately as well. This leads me to strongly believe that Firefox is the culprit. I should note that I only remember experiencing this issue while working on a game that uses Audio elements (and potentially quite a few, albeit they are usually copies). I usually have the global volume for the game turned off when working, if that helps.

Aanvullende systeemdetails

Geïnstalleerde plug-ins

  • Wacom Dynamic Link Library
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Creative Cloud Desktop Plugin.v_2_0_0_0
  • Battlelog Game Launcher (2.4.0)
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NPWLPG
  • Shockwave Flash 15.0 r0

Toepassing

  • Useragent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

Meer informatie

cobatts 0 oplossingen 4 antwoorden

Nuttig antwoord

I've had the same problem happening to me since the update to FF 34. It seems to happen once Firefox hits a certain amount of RAM usage; around 1600MB, I think. I made sure it wasn't caused by an extension by stress testing the browser in safemode until it reached that memory threshold and the issue still occurred.

I've had the same problem happening to me since the update to FF 34. It seems to happen once Firefox hits a certain amount of RAM usage; around 1600MB, I think. I made sure it wasn't caused by an extension by stress testing the browser in safemode until it reached that memory threshold and the issue still occurred.
tigros 0 oplossingen 7 antwoorden

Nuttig antwoord

Should we downgrade or is a solution in the works? That's a pretty nasty bug, no system audio! Let us know if you need more info. Uninstalling Adobe flash didn't help.

Should we downgrade or is a solution in the works? That's a pretty nasty bug, no system audio! Let us know if you need more info. Uninstalling Adobe flash didn't help.

Bewerkt door tigros op

cobatts 0 oplossingen 4 antwoorden

I've been going back and forth between 33.1.1 and 34.0.5 and still can't find a fix. The problem seems less dependent on RAM usage than I previously thought and has happened as early as ~800MB.

I've been going back and forth between 33.1.1 and 34.0.5 and still can't find a fix. The problem seems less dependent on RAM usage than I previously thought and has happened as early as ~800MB.
FredMcD
  • Top 10 Contributor
4257 oplossingen 59608 antwoorden

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.


If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

A post was flagged as '''Solved Problem.''' Please remove that flag. If you don’t, others that can help may not read this post. ------------------------- If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''
tigros 0 oplossingen 7 antwoorden

I've gone back to v33.1.1 a few days ago and haven't seen the problem, I've also reinstalled Flash, so I don't think the above answer is quite it.

I've gone back to v33.1.1 a few days ago and haven't seen the problem, I've also reinstalled Flash, so I don't think the above answer is quite it.
cobatts 0 oplossingen 4 antwoorden

I see that my first post was tagged as the solution. How do I change that?

I tried updating my graphics drivers, disabled protected mode, and turned off HW acceleration, so I don't think the problem is directly related to Flash either.

I see that my first post was tagged as the solution. How do I change that? I tried updating my graphics drivers, disabled protected mode, and turned off HW acceleration, so I don't think the problem is directly related to Flash either.
FredMcD
  • Top 10 Contributor
4257 oplossingen 59608 antwoorden

cobatts said

I see that my first post was tagged as the solution. How do I change that?

Go to the message that is flagged. To its right will be a button; Not Solution.

I don't think the problem is directly related to Flash

Start your Computer in safe mode. Then start Firefox. Try Safe web sites.

Starting The Computer In Safe Mode;
Free Online Encyclopedia

''cobatts [[#answer-673610|said]]'' <blockquote> I see that my first post was tagged as the solution. How do I change that? </blockquote> Go to the message that is flagged. To its right will be a button; '''Not Solution.''' <blockquote> I don't think the problem is directly related to Flash </blockquote> Start your '''Computer''' in safe mode. Then start Firefox. Try '''Safe''' web sites. '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''
cobatts 0 oplossingen 4 antwoorden

The button you're talking about doesn't seem to be there. See attached image

My audio driver doesn't work at all in safe mode.

The button you're talking about doesn't seem to be there. See attached image My audio driver doesn't work at all in safe mode.
tigros 0 oplossingen 7 antwoorden

not 100% sure but you can try disabling Lame MP3 Codec if you have it, you can use this tool: http://www.nirsoft.net/utils/installedcodec.zip right click and disable.

I had disabled it for another reason but dawned on me today that maybe fixes firefox too.

I updated firefox to latest and so far so good!

not 100% sure but you can try disabling Lame MP3 Codec if you have it, you can use this tool: http://www.nirsoft.net/utils/installedcodec.zip right click and disable. I had disabled it for another reason but dawned on me today that maybe fixes firefox too. I updated firefox to latest and so far so good!

Bewerkt door tigros op

tigros 0 oplossingen 7 antwoorden

sorry spoke too soon, no sound system wide reoccurred, seems to take a couple hours. Gone back to 33.1.1.

I've got a pretty old ASUS Xonar D2 sound card if that helps.

sorry spoke too soon, no sound system wide reoccurred, seems to take a couple hours. Gone back to 33.1.1. I've got a pretty old ASUS Xonar D2 sound card if that helps.
gilbav 0 oplossingen 3 antwoorden

This problem could be related to sound in firefox stops after a while.

This problem could be related to [https://support.mozilla.org/en-US/questions/1035594 sound in firefox stops after a while.]

Bewerkt door gilbav op

FredMcD
  • Top 10 Contributor
4257 oplossingen 59608 antwoorden

tigros said

I've got a pretty old ASUS Xonar D2 sound card if that helps.

Check for updates and / or a new sound card.

Try this if you can;

Start Firefox in Safe Mode {web Link} by holding down the <Shift (Mac Options) > key, and then starting Firefox.

Then load both pages. Is the problem still there?

''tigros [[#answer-673906|said]]'' <blockquote> I've got a pretty old ASUS Xonar D2 sound card if that helps. </blockquote> Check for updates and / or a new sound card. Try this if you can; Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift ''(Mac Options)'' >''' key, and then starting Firefox. Then load both pages. Is the problem still there?
tigros 0 oplossingen 7 antwoorden

Seems to be ok now with v35.0.1, not sure if because disabled Dragon naturally speaking v13 plugin, which I did because it helps make those Disqus comments work. So if you have trouble with Disqus now you know what to do.

Seems to be ok now with v35.0.1, not sure if because disabled Dragon naturally speaking v13 plugin, which I did because it helps make those Disqus comments work. So if you have trouble with Disqus now you know what to do.

Bewerkt door tigros op

FredMcD
  • Top 10 Contributor
4257 oplossingen 59608 antwoorden

After a time with no issues, re-enable the program. If the problem comes back, shut it down and contact its support site.

After a time with no issues, re-enable the program. If the problem comes back, shut it down and contact its support site.