FIREFOX 75 UPDATE: How to change internet address bar dropdown to display most visited sites?

How to change the browser.urlbar.maxRichResults in about:config to display more recently viewed websites in the drop-down list in the address bar after Firefox 75 update?… (read more)

How to change the browser.urlbar.maxRichResults in about:config to display more recently viewed websites in the drop-down list in the address bar after Firefox 75 update? I only see 6 results when I had it set to about 20 before.

I have gone to browser.urlbar.openViewOnFocus and changed that setting to False thinking that would help but all that has done is eliminated the entire drop-down list altogether when the address bar is clicked.

I checked my browsing privacy options in the settings menu within Firefox and it appears everything remains exactly as before, prior to update. Maybe there is some special combo of settings and about:config options that can bring the drop-down menu back that I enjoyed so much prior to update version 75.

Any recommendations?

Asked by Lucardy 3 months ago

Last reply by Lucardy 5 days ago

Svg path d doesn't work

<svg><g><path fill="red" d="M-17169009 -11080329L16366781 -11080329L16366781 22493289L-17169009 22493289z"></path></g></svg> It works … (read more)

<svg><g><path fill="red" d="M-17169009 -11080329L16366781 -11080329L16366781 22493289L-17169009 22493289z"></path></g></svg>

It works in Chrome 83.0.4103.116, but doesn't work in Firefox 78.0.1. Could you fix it in Firefox?

Asked by A.Repnin 1 week ago

Last reply by A.Repnin 6 days ago

Unable to print full page in certain websites

I used to take print to study contents offline and I almost always use Mozilla as a browser. Recently I noticed that I was unable to print a full page in a simple website… (read more)

I used to take print to study contents offline and I almost always use Mozilla as a browser. Recently I noticed that I was unable to print a full page in a simple website. Understandable that firefox team has been busy working upon the print bugs, but the page and the website I am referring to is Purely HTML and CSS; and for some reason firefox cuts out the rest of the pages from print except for the first.(i.e) to say it prints only the top part of the page..

Though I work with Ubuntu I have crosschecked with Win8.1 and TOR version of firefox which had the same shortcoming, with the website I was referring to. However other browsers such as the Safari and Chrome seem to do fine with this regard. Kindly check for yourselves and let me know if I am going wrong somewhere. Also please Avoid recommending any add ons to accomplish the task at hand.

The thing is the website I was referring to is of very simple make and may help the team to shoot the bug if any, with an easier test case such as this.

With love and Thanks

Asked by Rudran 1 week ago

Last reply by Rudran 5 days ago

Firefox 78.0.1 does not remove closed pages from memory - lags and high RAM usage

After updating from 77 (I think it was 77.0.2?) to 78.0.1 I started noticing terrible firefox performance after a few minutes of browsing. My standard browsing habit cons… (read more)

After updating from 77 (I think it was 77.0.2?) to 78.0.1 I started noticing terrible firefox performance after a few minutes of browsing. My standard browsing habit consists of launching browser with 1 pinned tab and 1 home page (so 2 tabs only), then opening 5-10 tabs from my bookmarks, checking pages then closing them and leaving only 1 pinned page open. In firefox 78.0.1 after doing this (opening and then closing multiple tabs "to the right" using new context menu added in 78) my ram usage does not drop. It goes from 2.4GB (system only usage) to 5.0GB and does not drop after closing tabs. However when I open 10-20 tabs again RAM usage does not rise (maybe slightly, like 5.3GB). So it looks like firefox has multiple tabs stored in ram and opening new tabs just rewrites that memory instead of allocating new one. I have 8GB of ram so 3GB of usage from 1 open tab is crazy. I think it was 500-900MB before. I also have terrible lags because of this - browser hangs up every few seconds for few seconds. I had trouble writing this post with 2 tabs open because of 3.3GB ram usage! Restarting browser helps - ram uasge rises from 2.4GB to 3.2GB only (800MB for 2 tabs) but every new opened and closed tab seems to stay in memory. For example if I open 10 more tabs except for 2 that always open so I have 12 tabs I have 3.6GB memory usage. After I close them it slowly drops to 3.5GB instead of returning to 3.2GB. It does not matter how I close tabs - using right click context menu (close other tabs, close tabs to the right), using X on tabs, or using add-on to close all tabs except for pinned ones. They always remain in memory somehow. PLS fix this ASAP.

P.S. I also tried checking about:performance menu but there is nothing interesting here. It says that 2 opened tabs and addons use 100MB of memory which is not true because browser at this moment uses 1060MB.

Update 1: I also tested safe mode. 3,4GB of PC RAM usage on firefox safe mode start. Opened few tabs, ram usage goes to 4.2GB. After closing all tabs except for 1 ram usage start to SLOWLY decrease but it stops at 3,7GB. Ram usage drop was really slow like 10-30 seconds. It should be instant after closing tabs.

Asked by Piterk 1 week ago

Last reply by Piterk 5 days ago

Downloads almost always fail: '.part could not be saved, because the source file could not be read.'

Error message: E:\Users\Sarah\AppData\Local\Temp\xxxxx.xxx.part could not be saved, because the source file could not be read. Try again later, or contact the server admi… (read more)

Error message: E:\Users\Sarah\AppData\Local\Temp\xxxxx.xxx.part could not be saved, because the source file could not be read. Try again later, or contact the server administrator.

I do want to mention upfront that this issue is also affecting Chrome and IE. It's not solely a Firefox issue, but I'm hoping someone here can help me anyways.

  • This happens for any filetype, from any source.
  • It started happening about a month ago.
  • Prior to that, I installed a new motherboard, RAM and processor. I'm fairly certain there was a period between these events in which it worked fine, but I am mentioning it just in case it's relevant.
  • If it's a small file and I try repeatedly, it sometimes will eventually download.
  • Even if a large file successfully starts downloading, it will eventually fail. It usually fails immediately though.
  • I sometimes have success downloading the same file in Chrome, but it also often fails. IE as well.

I have tried the following:

  • Used Refresh Firefox
  • Cleared download history
  • Changed download location
  • Reset browser.download values
  • Disabled firewalls and antivirus/spyware
  • Reinstalled Firefox using Run as Admin (first uninstalled previous version and deleted all program files that I could find, including profiles)
  • Cleared cookies and cache
  • Ran in safe mode
  • Verified Temp folder filepath was valid
  • Verified the PART file was created in that path -- it exists until I hit OK on the error message, then it disappears
  • Ran Firefox as admin

I think these are outdated methods I only found on non-official sources, but will mention them just in case:

  • I found some sources that said to delete Compreg.dat; I could not find this file in the place listed, nor could I find it with a search of the entire drive
  • Verified places.sqlite was not set to read-only
  • Removed read-only from entire profile folder and subfolders

In Options > Security: 'Block dangerous & deceptive content': true, 'Block dangerous downloads': false

Internet speed test: 58.96 Mbps download; 148.04 Mbps upload. No connection loss.

This problem is absolutely maddening. I'll be so grateful if anyone can help me out!! :( Thank you in advance, I know this was a long read!

(Edited for readability)

Asked by wormmulch 5 days ago

Last reply by wormmulch 3 days ago

I Have Really Messed Things Up and need HELP

I bought a new computer. I read about how to transfer over your profile. On my old computer I located the folder, and went up one level as it said. I had 2 files there, n… (read more)

I bought a new computer. I read about how to transfer over your profile. On my old computer I located the folder, and went up one level as it said. I had 2 files there, not 1 .I saved these files. I installed firefox on my new computer and followed the same steps to locate the folder. It also had 2 files, with different names. I STUPIDLY deleted these two files and put in the two I had copied from my old compter. Turned offirefox and turned it back on. It would notopen because it said it couldnot locate my profile folder. I uninstalled Firefox, and reinstalled it. I still get the same error.

Your Firefox profile cannot be loaded. It may be missing or inaccessible. I thought uninstalling and reinstalling it would solve the first part of the program but as of now, I have no Firefox.

Any suggestions from anyone.

Asked by smokininkman1 6 days ago

Last reply by smokininkman1 1 day ago

Cannot connect to sky sports

Hi Hope somebody can shed a little light on a problem that has just started, I cannot now sign into sky sports using Firefox. I get this message below. Secure Connection … (read more)

Hi Hope somebody can shed a little light on a problem that has just started, I cannot now sign into sky sports using Firefox. I get this message below. Secure Connection Failed An error occurred during a connection to wig.sky.com. Peer using unsupported version of security protocol. Error code: SSL_ERROR_UNSUPPORTED_VERSION

I have tried with both my laptop and desktop same issue. This has only just started; all was ok around a week or so ago. If I connect to Sky Sport using M/S Edge I do not have any problems. Using Windows 10 Many thanks Gary

Asked by gary.baker7 4 days ago

Last reply by gary.baker7 4 days ago

HTML tags not showing correctly on the firefox browser.

Hello Firefox, this is the HTML tags. Show the image That i attached and see what is the difference. <title>Quiz1</title> <style&g… (read more)

Hello Firefox, this is the HTML tags. Show the image That i attached and see what is the difference.


<title>Quiz1</title> <style> body{ background-color: yellow; font-family: simsun; font-size: 200%;} ol{ color: red; font-family: Verdana; font-size: 100%; background-color: skyblue; } ul{ color: gray; font-family: 'Courier New'; font-size: 100%; background-color: pink; } dl{ color: orange; font-family: Arial; font-size: 150%; background-color: black; } li{ margin-left: 10px; } </style>

University


  1. AABU
    • Since
      1. Math
      2. Physics
    • IT
  2. JU
  3. -Jordan University
  4. HU
  5. YU

Asked by sami.zeklab 5 days ago

Last reply by sami.zeklab 4 days ago

Browser change

Hi. I enjoy using Firefox and support Mozilla, but I am fast starting to lose patience. I do not use Google and try to avoid anything to do with it. I set Duckduckgo a… (read more)

Hi. I enjoy using Firefox and support Mozilla, but I am fast starting to lose patience. I do not use Google and try to avoid anything to do with it. I set Duckduckgo as my browser and remove Google from the list of search engines. Every time Firefox updates, I find that my settings are changed without my knowledge and my search engine defaults to b***** Google! Then I have to waste time changing settings again. Can I stop this from happening or do I just have to move away from Firefox? Thanks a lot. Des

Asked by Des 4 days ago

Last reply by Des 3 days ago

Firefox crashes regularly for different reasons

Hi, my firefox started to crash regularly for a few months. I have seen it crash while on idle, while changing tabs, while opening ne tabs... i.e. no repetable pattern. M… (read more)

Hi, my firefox started to crash regularly for a few months. I have seen it crash while on idle, while changing tabs, while opening ne tabs... i.e. no repetable pattern. Morever, I couldn't figure out the reason since all the crash reports turned different reasons for each crush. It has now become hourly crashes which really started to affect my workflow. Could you please help?

Latest crush reports: Report ID Date Submitted bp-4c03cc23-f6bf-4abd-a5b0-3a1ff0200708 08/07/2020, 13:27 bp-74dbd9b4-40b9-47b5-9387-f6d8e0200708 08/07/2020, 13:27 bp-d1cbf208-6c0d-44f1-95f2-a8aec0200708 08/07/2020, 13:27 bp-813c83c1-c29a-4103-84b5-5e68d0200708 08/07/2020, 13:27 bp-29f78130-e294-4fcd-8720-5b8010200708 08/07/2020, 13:27 bp-2e6980b2-b53e-473a-b9e3-9e1ee0200708 08/07/2020, 13:27 bp-363a7969-8b98-43ea-a26b-f32350200708 08/07/2020, 13:27 bp-df78d49e-6209-4a7e-96c9-533e90200708 08/07/2020, 13:27 bp-4d388808-7043-440e-b7a3-d29b60200708 08/07/2020, 13:26 bp-aa3c3296-6b5d-4300-a441-4a6890200708 08/07/2020, 13:26 bp-007af789-587d-45df-87f8-da78c0200708 08/07/2020, 13:26 bp-0f5a3710-3098-4d73-ace8-c1df10200708 08/07/2020, 13:26 bp-fc10b542-d37d-4ca9-8a54-0acf50200708 08/07/2020, 13:26 bp-2eb3fafe-370e-4145-bda4-acc120200702 02/07/2020, 10:30

Asked by u.yilmaz91 6 days ago

Last reply by u.yilmaz91 2 days ago

Some sites in drop down Bookmark Menu require two attemps to access.

Hi, Certain sites saved to Bookmark Menu require two tries to access. First mouse click>nothing. Second try> brings up site. It is not the mouse & I've tried i… (read more)

Hi,

 Certain sites saved to Bookmark Menu require two tries to access. First mouse click>nothing. Second try> brings up site. It is not the mouse & I've tried in Safe Mode. This happens every day. Any help appreciated.

Thanks

Asked by ar3142 6 days ago

Last reply by ar3142 4 days ago

After the July 3 update, my facebook page is now in mobile view instead of pc view

I am a facebook marketplace seller and I use my selling page every single day. After the update on July 3, my selling page is now showing in mobile format instead of PC. … (read more)

I am a facebook marketplace seller and I use my selling page every single day. After the update on July 3, my selling page is now showing in mobile format instead of PC. I just realized that my home page on facebook has been in mobile view for some time now. I am in the classic view on facebook I have not updated the page to the new style. The mobile view on facebook selling page is absolutely terrible and not user friendly. I have cleared my firefox cache, I have cleared all logins and autofill items. At one time when I right clicked the page and the view page info came up, it said android. now it does not anymore. I have tried everything I could think of to change the page back to PC view. I am not on the m.facebook.com page, either. It seems that all the other pages are normal, this just pertains to facebook.

Asked by blairville4 5 days ago

Last reply by blairville4 4 days ago

Why doesn't the dialog for Autoplay fully render in Preferences?

In Firefox 78.0.2, the dialog for Autoplay looks ghostly. All other dialogs (e.g., Location, Camera, Microphone, Virtual Reality, etc) are raised and display as expected.… (read more)

In Firefox 78.0.2, the dialog for Autoplay looks ghostly. All other dialogs (e.g., Location, Camera, Microphone, Virtual Reality, etc) are raised and display as expected. It seems that the dialog for Autoplay does not raise to the front. It is rendering behind other elements.

It's faux modal window...a "fauxdal".

Steps to reproduce:

  1. Open the "Privacy & Security" section of the Preferences (about:preferences#privacy)
  2. Click on "Settings..." button for Autoplay

Screencaps uploaded; one showing normal, expected modal display (for Location Permissions), the other showing the "fauxdal" condition. In the latter, the screencap was marked up to draw attention to the ghostly window corners and title. Notice the I-beam cursor in both images, as it was positioned over the Search field.

Asked by Who Is...More Fool? 5 days ago

Last reply by Who Is...More Fool? 4 days ago

Recently used sites no longer appear in the address bar?

I am on 78.0.1 (64-bit) in Windows 10. Suddenly my most used sites no longer appear in the address bar when I enter it. I have no idea why this is happening. What can I … (read more)

I am on 78.0.1 (64-bit) in Windows 10. Suddenly my most used sites no longer appear in the address bar when I enter it. I have no idea why this is happening.

What can I do to get that functionality back?

Asked by bill0287 1 week ago

Last reply by bill0287 6 days ago

Files containing Japanese characters are garbled in Firefox 68.6.0esr

After upgrading to Firefox 68.6.0esr, when we open a Japanese file with [File]->[Open], it becomes garbled and unreadable. Before upgrading, we could read the Japanes… (read more)

After upgrading to Firefox 68.6.0esr, when we open a Japanese file with [File]->[Open], it becomes garbled and unreadable. Before upgrading, we could read the Japanese file. This file is a plain text file and the character code is ISO-2022-JP. The character code is not specified in the file. I tried to change the character code with Text Encoding menu of Firefox, but the menu is grayed out and we cannot select it. It seems that files with character codes UTF and EUC can be displayed without problems. Is there a way to correctly display a Japanese file in which no character code is specified?

Regards,


Regards,

Asked by HAYASHI Tomoko 6 days ago

Last reply by HAYASHI Tomoko 6 days ago

How to really stop autoplaying videos

I can't stop autoplaying videos in FF77. I disabled them in the options, and also set media.autoplay.blocking_policy = 2 and the videos still play automatically after re… (read more)

I can't stop autoplaying videos in FF77. I disabled them in the options, and also set

media.autoplay.blocking_policy = 2

and the videos still play automatically after restarting FF.

Asked by useruser 1 week ago

Last reply by useruser 5 days ago

Firefox CSP Parsing Error

Firefox is saying there is an inline script (seen in first attached image) which for one is not inline, and secondly starts in the middle of a seemingly arbitrary variabl… (read more)

Firefox is saying there is an inline script (seen in first attached image) which for one is not inline, and secondly starts in the middle of a seemingly arbitrary variable (seen in the third image).

Chrome is able to accept this script, and has no such error (seen in the second image).

I'm quite sure this is not normal behavior, and I want to make sure my site is fully compatible with Firefox.

Asked by Obscenity 3 days ago

Last reply by Obscenity 2 days ago