Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Installing Marketplace apps in Linux doesn't work

  • 6 replies
  • 10 have this problem
  • 510 views
  • Last reply by Ed

more options

I am using Firefox 21 on Ubuntu 13.04. When I go to the firefox marketplace and click to install an app I get the notification in the top left asking me to confirm that I want to install, I confirm but then nothing happens. I don't see the notification that the app has been installed and I can't find the app anywhere.

Should the marketplace apps work on Linux?

Any help would be great.

All Replies (6)

more options

Search in Ubuntu unity.

Goto Market Place > open the installed Apps

  • Under the screenshot of the App, you can see the Installed place.

see my attached image

more options

Hi, thanks for the reply. I've attached my screenshot.

I don't see the 'Installed!' message from your image. My shot was taken immediately after clicking the 'Install' button on the web page and then confirming with the 'Install' button on the confirmation popup.

more options

It happen to all the apps or only for twitter?

more options

It is the same for all. I've tested:

  • Twitter
  • Soundcloud
  • MTV App

I have also tried with FF in safe mode and get the same result.

Modified by Ed

more options

I have the same problem in FF21. Screenshot taken after clicking "Free", then "Install" in popup. Also, note the error in developer console. This happens to every app in marketplace. Some apps from https://apps.mozillalabs.com/appdir/ are installing correctly, thought.

Strangely, but I have had this app installed before, in FF19. It's desktop file was in ~/.local/share/applications and resources were somewhere in ~/.http;**** Sadly, clicking "Install" (in hope for updates) had removed this app.

more options

Thanks for the confirmation snark.real.

Since we are now seeing '5 have this problem' I've logged a bug. Here:

https://bugzilla.mozilla.org/show_bug.cgi?id=879176

If you get time it might be useful to add your developer console error screenshot to the bug.

Modified by Ed