X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Updated to Ver.8.0.1 Firefox recognizes it as such under the About menu but when I try to install a AddOn, (Which supports Ver. 8.0.1), the AddOn recognizes the Ver. as 3.5.7

Posted

Updated Firefox to Ver.8.0.1 ,Firefox recognizes it as such under the Help/About menu. When I tried to install a AddOn, (Which supports Ver. 8.0.1), the AddOn recognizes the Firefox Ver. as 3.5.7 Furthermore I just noticed on this page down below where it says you have made an educated guess about my browser and O/S. This page also recognizes the Firefox Ver. as 3.5.7 So I go to the help/About menu and it says I'm running Ver.8.0.1 Am I missing something?

Updated Firefox to Ver.8.0.1 ,Firefox recognizes it as such under the Help/About menu. When I tried to install a AddOn, (Which supports Ver. 8.0.1), the AddOn recognizes the Firefox Ver. as 3.5.7 Furthermore I just noticed on this page down below where it says you have made an educated guess about my browser and O/S. This page also recognizes the Firefox Ver. as 3.5.7 So I go to the help/About menu and it says I'm running Ver.8.0.1 Am I missing something?

Chosen solution

Any useragent Preferences that are bold and user set, just right-click each and select Reset. Then go to "File->Exit" and start Firefox again.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • DivX Plus Web Player version 2.1.3.529
  • Google Update
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape 8.3.1
  • DivX VOD Helper Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Yahoo Application State Plugin version 1.0.0.7
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • Unity Player 2.6.0f7
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

More Information

Swarnava Sengupta
  • Locale Leader
493 solutions 3273 answers
You may need to reset user agent as outlined below * https://support.mozilla.com/en-US/kb/websites%20or%20add-ons%20incorrectly%20report%20incompatible%20browser#w_reset-your-user-agent

Question owner

Hello and Thank You for the reply. I did part of your solution but decided to ask you before I continued. I only had 2 of 5 user agents you spoke of. Not sure if this is part of the problem. I've listed them down below.

Preference Name/ Status/ Type / Value

-general.useragent.compatMode.firefox/ Default/ boolean/ false -general.useragent.extra.microsoftdotnet/ userset/ string/ (.NET - CLR 3.5.30729) -general.useragent.extra.searchtoolbar/ userset/ string/ Search- Toolbar/1.2 -general.useragent.locale/ default/ string/ en-US

-general.useragent.override/ userset/ string/ Mozilla/5.0-

(Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7)Gecko/20091221Firefox/3.5.7
Hello and Thank You for the reply. I did part of your solution but decided to ask you before I continued. I only had 2 of 5 user agents you spoke of. Not sure if this is part of the problem. I've listed them down below. Preference Name/ Status/ Type / Value -general.useragent.compatMode.firefox/ Default/ boolean/ false -general.useragent.extra.microsoftdotnet/ userset/ string/ (.NET - CLR 3.5.30729) -general.useragent.extra.searchtoolbar/ userset/ string/ Search- Toolbar/1.2 -general.useragent.locale/ default/ string/ en-US -general.useragent.override/ userset/ string/ Mozilla/5.0- (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7)Gecko/20091221Firefox/3.5.7
James
  • Moderator
1603 solutions 11348 answers

Chosen Solution

Any useragent Preferences that are bold and user set, just right-click each and select Reset. Then go to "File->Exit" and start Firefox again.

Any '''useragent''' Preferences that are '''bold''' and '''user se'''t, just right-click each and select '''Rese'''t. Then go to "File->Exit" and start Firefox again.