Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can the "Firefox first-time run after update" (aka. "What's New" and "Add-on compatibility check") be disabled?

  • 6 replies
  • 3 have this problem
  • 2 views
  • Last reply by John99

more options

We plan to deploy a Firefox update on our campus. The issue I have is this: after the update, the "Add-on Compatibility checker" pops up, then the "What's new" page shows up on the first start after the update. The issue here: we use Deep Freeze to prevent the kiddos from doing any software-based mischief on the machines. But if we push the update out at night, during the maintenance windows, they will be frozen back in pre-first-time-run mode. Thus, each time a student boots the PC up after that, they will get both the compatibility popup and the "What's new" page.

Is there a way I can disable that during the upgrade, so the students will not have to click those 2 items away? I would like for Firefox to just silently disable any incompatible add-ons and not to display the "What's new" page. I found ways to do that, but they involve editing omni.jar and such. I would rather have an official, documented way of doing this.

Thanks!!

Chosen solution

Well, ultimately nothing worked, except making all the settings I wanted to set part of mozilla.cfg. When I added your suggestion, along with another I found on the web to disable add-on compatibility check, I finally have a Firefox that loads straight to the home page, even after the upgrade.

Here's what my mozilla.cfg file contains (for 6.0.2):

// Disable any auto-updates.
lockPref("app.update.enabled", false);
lockPref("extensions.update.enabled", false);
lockPref("browser.search.update", false);
lockPref("browser.startup.homepage_override.mstone", "ignore");
lockPref("extensions.checkCompatibility.6.0", false);

Of course, I have to do the byteshift-13 to it, but copying the resulting file to Core\ and the firefox.js file to Core\Defaults\Pref\ does the trick.

Thanks for the help!!

Read this answer in context 👍 0

All Replies (6)

more options

I do not know the answer, but suspect modifying with config.js & prefs.js may help. See for instance: thread /questions/863144

My answer will also bump your question and you may get a complete answer from someone else; otherwise try mozallazine, your question may be more appropriate there.


P.S.
You may be interested in keeping your eye on the developments of the network installer mentioned in relation to Firefox 9 (Fx 9 is currently the on the nightly release channel) https://wiki.mozilla.org/Features/Firefox/Network_Installer

Modified by John99

more options

I have just stumbled across the answer:

Create a file user.js in the \defaults\profile folder (you need to create that folder) in the Firefox program folder (C:\Program Files\Mozilla Firefox\) or copy that file to an existing profile folder to set the pref browser.startup.homepage_override.mstone to ignore.

user_pref("browser.startup.homepage_override.mstone", "ignore");

   http://kb.mozillazine.org/browser.startup.homepage_override.mstone 
   http://kb.mozillazine.org/Profile_folder_-_Firefox 

courtesy cor-el /questions/864995#answer-234771

more options

I will try that asap. I tried setting "browser.startup.homepage_override.mstone" in firefox.js, not user.js, and it did not work. Putting it in user.js might do the trick.

Many thanks for your answer. I will report back after trying that.

more options

Just as a further comment note there may well be a Network installer available for Firefox 9 see https://wiki.mozilla.org/Features/Firefox/Network_Installer

more options

Chosen Solution

Well, ultimately nothing worked, except making all the settings I wanted to set part of mozilla.cfg. When I added your suggestion, along with another I found on the web to disable add-on compatibility check, I finally have a Firefox that loads straight to the home page, even after the upgrade.

Here's what my mozilla.cfg file contains (for 6.0.2):

// Disable any auto-updates.
lockPref("app.update.enabled", false);
lockPref("extensions.update.enabled", false);
lockPref("browser.search.update", false);
lockPref("browser.startup.homepage_override.mstone", "ignore");
lockPref("extensions.checkCompatibility.6.0", false);

Of course, I have to do the byteshift-13 to it, but copying the resulting file to Core\ and the firefox.js file to Core\Defaults\Pref\ does the trick.

Thanks for the help!!

Modified by cor-el

more options

Glad you sorted it out. A shortcoming of this forum is that you are unable to mark your own solution as solving a problem.