Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Whats wrong with my browser??

  • 6 replies
  • 3 have this problem
  • 90 views
  • Last reply by DAmores

more options

Hi, well for some reason alot of the menus inside of firefox are invisible. Such as the drop down menu when you right click, also the firefox menu on the upper left is completely invisible, I have noticed some details are missing as well, like on the "clear history box," Recently I tried to change my appearence persona back to default, I was able to get the text on the right click drop down menu back, but it is "boxless" as in nothing containing the options, and the firefox menu is still invisible. Note this doesnt happen while I am on my actual desktop, and it also does not happen on Internet Explorer.. Please help!

All Replies (6)

more options

Try to disable hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.

more options

Hi cor el, that option was already unchecked when I found it, also my graphics display driver is fully updated..

Let me try and give more detail though, so when I right click, the menu does pop up, but the only thing I can see is the text, the menu has no backround to it, so that it is laid right over the website I am viewing. I also noticed the same thing is happening with my bookmarks menu, though the options on the very top of the menu are just completely invisible as well. When I click on the firefox menu in the upper left corner, the menu pops up, this menu Does have a backround, and even the symbols on it are visible, such as the private browsing icon, the addons icon, and the print icon are all there. Its just the text is just completely missing.

I have attached some images showing exactly what happens!

Please any help would be appreciated!!!

more options

Try to disable transparency in Windows or try a different Windows theme.

Right click in a free space on your desktop.
Left click on Personalization.
There are four options in Windows 7 at the bottom of the screen, choose "Window Color and Appearance".
Select a border color
Uncheck: "Enable transparency"

more options

Darn, thought that was gonna work.. Still the same :\ Thanks for the help so far though.. This sucks

more options

Helpppppppppppp! Theres gotta be something I can do

more options

It was fixed with the update.. Thanks !