X
Tap here to go to the mobile version of the site.

Support Forum

I have Mac OS X 10.4.11 and I'm trying to upgrade to Firefox 4.0.1 or higher. When I attempt this, I get a message from FireFox that it can't upgrade my version of Mac. I think Mac 10.4 or higher is all that is needed. Help! ... Thanks you in Advance!!!

Posted

I'm trying to upgrade to a higher version of Firefox.

This will allow me to then upgrade my Yahoo mail. I've tried to upgrade Firefox several times over the last week and have received a message that my version of Mac (OS X 10.4.11) can't be upgraded by Firefox. I'd like to upgrade to the newest version of Firefox or at least version 4 to then be able to upgrade Yahoo mail.

Please help!! ... and Thanks is Advance for your help!!! Tony

I'm trying to upgrade to a higher version of Firefox. This will allow me to then upgrade my Yahoo mail. I've tried to upgrade Firefox several times over the last week and have received a message that my version of Mac (OS X 10.4.11) can't be upgraded by Firefox. I'd like to upgrade to the newest version of Firefox or at least version 4 to then be able to upgrade Yahoo mail. Please help!! ... and Thanks is Advance for your help!!! Tony

Chosen solution

Firefox 4 requires at least OS X 10.5 and an Intel Mac. The latest version that runs on OS X 10.4.11 is Firefox 3.6, you can get it from http://www.mozilla.com/en-US/firefox/all-older.html

Read this answer in context 4

Additional System Details

This happened

Just once or twice

This started when...

I've tried several times over the last week to move to a higher vesrion of Firefox.

Installed Plug-ins

  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Test Your JVM.
  • Netscape Navigator Default Plug-in
  • WebEx General Plugin Container Version 169
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 9.0 r246
  • Verified Download Plugin

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

More Information

TonyE
  • Moderator
1044 solutions 8863 answers

Chosen Solution

Firefox 4 requires at least OS X 10.5 and an Intel Mac. The latest version that runs on OS X 10.4.11 is Firefox 3.6, you can get it from http://www.mozilla.com/en-US/firefox/all-older.html

Firefox 4 requires at least OS X 10.5 and an Intel Mac. The latest version that runs on OS X 10.4.11 is Firefox 3.6, you can get it from http://www.mozilla.com/en-US/firefox/all-older.html

Question owner

Tony E. this was very helpful! It has provided a short term fix for me. I realize now I need to update my OS X version in the next few months. Thanks again! Tony W.

Tony E. this was very helpful! It has provided a short term fix for me. I realize now I need to update my OS X version in the next few months. Thanks again! Tony W.

Modified by amwpsw00