Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

4.0 doesn't work with Mac OS X 10.4.11 --> how can I downgrade?

more options

After upgrading to 4.0, I get the following error when trying to open Firefox: "You cannot use the application "Firefox" with this version of Mac OS X."

I am running Mac OS X 10.4.11 on an older laptop.

How can I revert to 3.6.*? I can't find any website to provide this version...

All Replies (2)

more options

Similar problem - I run Mac OS X 10.4.11 on an iMac and on trying to open Firefox after updating to version 4 this morning get message 'application Firefox cannot be launched -10661'

more options