Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do you stop the welcome to firefox 4 screen from coming up every time I open firefox? I get two tabs, one the welcome window, then my home page. How do you stop the bloody welcome screen?

  • 5 replies
  • 82 have this problem
  • 3 views
  • Last reply by cor-el

more options

How do you stop the welcome to firefox 4 screen from coming up every time I open firefox? I get two tabs, one the welcome window, then my home page. How do you stop the bloody welcome screen?

All Replies (5)

more options

When Firefox opens, delete the Welcome tab, then go to: Tools > General and set the Home Page.

more options

Its not my home page, Like I said, I hae my home page also come up in a different tab (google) I also get the welcome to FF4 on a seperate tab. My home page is set to google. But I dont want the welcome screen to pop up

more options

See these articles for some suggestions:

more options

OMG, by refreshing this page, text in post was erased, not good,

Again, When Starting Firefox 8, the Welcome tab keeps returning or coming back, even after changing URL homepage to other URL, Why does it keep re-appearing, and how does one stop it from popping up and primary first tab, along with new URL tab, Do users have to revert to Firefox 7 in order to stop nuisance, as FF 7 did not keep coming back, but recall Firefox 6 did same thing,

more options

@bbf12

Please start a new thread for your problem or question and provide troubleshooting information like your operating system and installed extensions and installed plugins.


Did you check for problems with the prefs.js file (and possible user.js file) and delete that file?

See:

(locking)