Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox video stream problems in youtube and twich unsupported MP4/H.264 while having installed media feature pack

  • 7 replies
  • 0 have this problem
  • 13 views
  • Last reply by hello_there

more options

So I have a following problem

FF 124.0.1 Windows 10 N edition Installed media feature pack

When trying to play twitch video it shows error 4000 and when trying to play stream from youtube it shows that your browser can't play this video.

Problem is that FF was able to do it like 6 moths-year ago (not really watching stream videos)

was trying to reinstal media feature pack, firefox, chcecknig nighgtly build but without sucess and have no clue what can do more

So I have a following problem FF 124.0.1 Windows 10 N edition Installed media feature pack When trying to play twitch video it shows error 4000 and when trying to play stream from youtube it shows that your browser can't play this video. Problem is that FF was able to do it like 6 moths-year ago (not really watching stream videos) was trying to reinstal media feature pack, firefox, chcecknig nighgtly build but without sucess and have no clue what can do more

Chosen solution

Ok I manage to solve it sfc show two corrupted dll files What I did in the end was as follow:

sfc /scannow DISM /Online /Cleanup-image /StartComponentCleanup DISM /Online /Cleanup-image /RestoreHealth reboot sfc /scannow uninstalled media feature pack reboot sfc /scannow reboot sfc /scannow installed media feature pack reboot

and it works

Read this answer in context 👍 0

All Replies (7)

more options

Laptop, Desktop, or DIY? If not DIY, what make and model? What graphics card and driver version? Did you ever check in Windows update under the optional update section?

Helpful?

more options

Have you tried Firefox in Troubleshoot Mode?

Helpful?

more options

Desktop, DIY

GPU RX6400 driver version [23.20.17.03-231016a-398307C-AIB] AMD driver version for windows [31.0.22017.3004]

Windows 10 professiona N 64 bit 22H2

I have tired Firefox in troubleshoot mode I have checked update under optional updates, there is none and everything is up to date

Helpful?

more options

You can check the codec support in the "Help -> More Troubleshooting Information" (about:support) page, you may have to play a video to initialize this section.

Helpful?

more options

Under HEVC and AAC I have "not supported" on both sides

H264 is "supported" on both sides

Helpful?

more options

Does youtube work with the h264ify extension installed?

Try installing or updating the "VP9 Video Extensions" and "AV1 Video Extension" from the Microsoft Store then reboot.

Try running the System File Checker tool:

sfc /scannow

Helpful?

more options

Chosen Solution

Ok I manage to solve it sfc show two corrupted dll files What I did in the end was as follow:

sfc /scannow DISM /Online /Cleanup-image /StartComponentCleanup DISM /Online /Cleanup-image /RestoreHealth reboot sfc /scannow uninstalled media feature pack reboot sfc /scannow reboot sfc /scannow installed media feature pack reboot

and it works

Modified by hello_there

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.