Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox in my laptop is Sloooow at home, but fast at work.

  • 1 reply
  • 0 have this problem
  • 15 views
  • Last reply by marc.bria

more options

I am writing to you because the subject is driving me crazy and I don't know what to do anymore.

TL;DR; version?

The same laptop, with the same firefox (113.0.1 snap) at work works fine... and at home it has an exhasperating lag.

Any ideas?

It happens to me with all the computers at home (with ubuntu, linux mint...) but (and here comes what kills me) if I browse with Chromium, everything flies.

I've tried by wifi against an access point that acts as a repeater, direct against the router and wired to the router and the result is always the same: Firefox slow as the bad guy's horse... and Chrome light as a cloud.

I have disabled all plugins, browsed in anonymous mode, reset firefox... and no way... every time it loads a page it takes 5 to 20 seconds of blank page.

I am a firefox user since its tender beginnings, but this lag is going to give me an ulcer and I am militant, but health comes first.

Thanks in advance for your help.

I am writing to you because the subject is driving me crazy and I don't know what to do anymore. TL;DR; version? The same laptop, with the same firefox (113.0.1 snap) at work works fine... and at home it has an exhasperating lag. Any ideas? It happens to me with all the computers at home (with ubuntu, linux mint...) but (and here comes what kills me) if I browse with Chromium, everything flies. I've tried by wifi against an access point that acts as a repeater, direct against the router and wired to the router and the result is always the same: Firefox slow as the bad guy's horse... and Chrome light as a cloud. I have disabled all plugins, browsed in anonymous mode, reset firefox... and no way... every time it loads a page it takes 5 to 20 seconds of blank page. I am a firefox user since its tender beginnings, but this lag is going to give me an ulcer and I am militant, but health comes first. Thanks in advance for your help.

All Replies (1)

more options

Missed to explain that testing connections, at home is 300Mbps and at work 500Mbps... both with pings under 30ms that don't explain the 5-20 seconds of white screen lag and the general slowness.

And DNS are 1.1.1.1, 1.0.0.1 from Cloudflare... but also tested with openDNS or Google and the result is the same.