Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Forced restart of Firefox with update, upsetting me and my workflow.

  • 2 replies
  • 1 has this problem
  • 27 views
  • Last reply by R3D FOX

more options

Dear Community,

To be completely honest, I was redirected to this form for this issue after it was posting in the discussion forum too many times about this.

The problem: Firefox has the behavior to download an update and force me to restart my browser

The issue: Next to the fact this is a very obtrusive behavior (or simply...not polite) it is in fact messing up my workflow and mood.

Why important? (at least according to me): First workflow: Using a lot of active connections / 2FA logins in combination with a secure setup where my browser doesn't remember a lot after restarting for security reasons, I need to perform multiple logins again while working with online services. It messes up my worflow, negatively affecting productivity. Also, it generates awkward situations when being in an online meeting, sharing a screen and this happens... unwillingly, unknowingly and just untimely. Updates are irregular and often (which is a great thing it itself!)

And that brings me to the point of mood. Less important -yes- my mood to anyone really I know. It is just a big frustration. I have been using FF since the Netscape days, always advocating for this browser, showing others, helping other to use and see the benefits... And this feels (note it is emotion) like a bad pay back for all those years. Several occassions I just used Safari and it just seems easier. But..I want FF, for its belief, how it was setup and its security and privacy.

I know there are more people that experience this issue.

Please let me know. // Is this issue known to you? // Does it have any priority? Is there a solution being generated? // I have tried things, nothing worked. Willing to try, but please don't come with the right 'settings' ... believe me I have tried. The only options seems to be to completely disable the updating process in the about:config page... but that seems unwise. What do I miss?

Please advice, so I don't get to see the page as in the attachment.

Best Regards,

Matt -the Netherlands-

Dear Community, To be completely honest, I was redirected to this form for this issue after it was posting in the discussion forum too many times about this. The problem: Firefox has the behavior to download an update and force me to restart my browser The issue: Next to the fact this is a very obtrusive behavior (or simply...not polite) it is in fact messing up my workflow and mood. Why important? (at least according to me): First workflow: Using a lot of active connections / 2FA logins in combination with a secure setup where my browser doesn't remember a lot after restarting for security reasons, I need to perform multiple logins again while working with online services. It messes up my worflow, negatively affecting productivity. Also, it generates awkward situations when being in an online meeting, sharing a screen and this happens... unwillingly, unknowingly and just untimely. Updates are irregular and often (which is a great thing it itself!) And that brings me to the point of mood. Less important -yes- my mood to anyone really I know. It is just a big frustration. I have been using FF since the Netscape days, always advocating for this browser, showing others, helping other to use and see the benefits... And this feels (note it is emotion) like a bad pay back for all those years. Several occassions I just used Safari and it just seems easier. But..I want FF, for its belief, how it was setup and its security and privacy. I know there are more people that experience this issue. Please let me know. // Is this issue known to you? // Does it have any priority? Is there a solution being generated? // I have tried things, nothing worked. Willing to try, but please don't come with the right 'settings' ... believe me I have tried. The only options seems to be to completely disable the updating process in the about:config page... but that seems unwise. What do I miss? Please advice, so I don't get to see the page as in the attachment. Best Regards, Matt -the Netherlands-
Attached screenshots

All Replies (2)

more options

Dear Dropa, thanks so much for your quick reply. The logging out, yes that is true. However, in this case I am FORCED to restart my browser, because FireFox says so. The open tabs will keep working, but as soon as you have to open a new site entirely, it will prompt you it needs a restart. 2FA doesn't work with autofull and save. It requires actions outside of the browser/computer. Bookmarking websites, well yes that is something FF automatically does, I will open the tabs/sites you had open.

Let me be clear: updates are good! They are a necessity. Moreover, I feel much more secure, when updates are presented. BUT: I alone choose when to update! And yes, when you are overdue, force can be used. However, I think that is a last resort, an extreme measure.

It really is about the forced nature of this, that is bugging the heck out of me.

Anyone know about a solution OR if this is on top of some FF developer's list? Let me know.

Thanks again Dropa, much appreciated.

more options

I'm just amazed how such a basic principle is not a priority. Maybe Safari is the better option after so many years after all..