Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to unblock VTT files not being loaded into HTML video pages viewed on local disk?

  • 3 replies
  • 1 has this problem
  • 659 views
  • Last reply by roberto32

more options

I asked this question some time back here: https://support.mozilla.org/en-US/questions/1362859 I'm asking again to reframe the question. The problem is - if my experience is a guide to the rest of the world - VTT files (which are used to caption HTML video) are no longer read/loaded by Firefox when it is viewing the HTML file locally (i.e. file://). On the web they are loaded as expected. Presumably there's a security setting somewhere in Firefox that now refuses to load the VTTs locally. Maybe under Help > More troubleshooting information there is a setting to change to fix that?

I asked this question some time back here: https://support.mozilla.org/en-US/questions/1362859 I'm asking again to reframe the question. The problem is - if my experience is a guide to the rest of the world - VTT files (which are used to caption HTML video) are no longer read/loaded by Firefox when it is viewing the HTML file locally (i.e. file://). On the web they are loaded as expected. Presumably there's a security setting somewhere in Firefox that now refuses to load the VTTs locally. Maybe under Help > More troubleshooting information there is a setting to change to fix that?

Chosen solution

Firefox supports WebVTT and vtt files and there are several media.webvtt.* prefs on the about:config page, but if these files are normally loaded from the server via JavaScript then this might not work locally. You might be able to get this work with links relative to the location of the html file or possibly open the file via a localhost web server.


  • 1499802 - [webvtt] Browser doesn't render WebVTT embedded Styles used by Voice/Class spans
Read this answer in context 👍 2

All Replies (3)

more options

Chosen Solution

Firefox supports WebVTT and vtt files and there are several media.webvtt.* prefs on the about:config page, but if these files are normally loaded from the server via JavaScript then this might not work locally. You might be able to get this work with links relative to the location of the html file or possibly open the file via a localhost web server.


  • 1499802 - [webvtt] Browser doesn't render WebVTT embedded Styles used by Voice/Class spans

Modified by cor-el

more options

cor-el said

Firefox supports WebVTT and vtt files and there are several media.webvtt.* prefs on the about:config page, but if these files are normally loaded from the server via JavaScript then this might not work locally. You might be able to get this work with links relative to the location of the html file or possibly open the file via a localhost web server.
  • 1499802 - [webvtt] Browser doesn't render WebVTT embedded Styles used by Voice/Class spans

Thanks for the tip. I toggled the four media.webvtt.* prefs one at a time and saw nothing changed (no captions appeared but nothing broke) except in the case of media.webvtt.debug.logging where, if changed to "true", the videos don't load. The VTT files not loading off local disk is a recent "feature" of Firefox - until about v99, they did. Made testing/editing my site easy.

Modified by roberto32

more options

cor-el said

Firefox supports WebVTT and vtt files and there are several media.webvtt.* prefs on the about:config page, but if these files are normally loaded from the server via JavaScript then this might not work locally. You might be able to get this work with links relative to the location of the html file or possibly open the file via a localhost web server.
  • 1499802 - [webvtt] Browser doesn't render WebVTT embedded Styles used by Voice/Class spans

Thanks! Took your advice about setting up a local host web server. In my case it's IIS. Needed to add extensions and mime types for VTT and even mp4, but then it worked perfectly.

Modified by roberto32