On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My microsoft "Outlook" account now requires me to sign into and open a new session when I open a new session.

  • 3 replies
  • 1 has this problem
  • 37 views
  • Last reply by FredMcD

more options

After years of NO Problems, all of a sudden I am required to re-sign into Microsoft Outlook to sign in. It use to just open and be on my homepage. Using a Mac, firefox 94.0.2...? This use to come up rarely, now it's every time I awaken and sign into computer.

After years of NO Problems, all of a sudden I am required to re-sign into Microsoft Outlook to sign in. It use to just open and be on my homepage. Using a Mac, firefox 94.0.2...? This use to come up rarely, now it's every time I awaken and sign into computer.

Chosen solution

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

more options

FredMcD "thank you" that seems to have fixed my problem. I appreciate your expert advice!

more options

Glad to help. Safe Surfing.