Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stop automatic updates Linux version 90

  • 2 replies
  • 1 has this problem
  • 61 views
  • Last reply by tlvranas

more options

I have searched and tried every change / setting I can find to disable the automatic updates of Firefox. I am using Firefox because I use to have control over the browser and it was tracking / spying on everything I do like Chrome. Having Firefox automatically update without my permission I see as no different then a virus and spy ware. I am in the middle doing some work and have to stop and loos everything I am doing because you pushed an unneeded unwanted update. This is not acceptable! I do not need some company that thinks they know what I should have on my computer. That is why I don't use Windows. I don't need some corporate suite telling me what is best for my computer.

How do I turn off automatic updates and all / any nag messages.

Chosen solution

Has this Firefox been downloaded using a ubuntu package manager? Try to download from Mozilla's website, it shouldn't behave like that.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Has this Firefox been downloaded using a ubuntu package manager? Try to download from Mozilla's website, it shouldn't behave like that.

Helpful?

more options

that appears to have fixed it.

I downloaded the browser directly from the site removed the installed version of FF from Ubuntu package manager set up system to use the downloaded version verified settings, mine say updates disabled (from changes made previously)

Apologizes to Mozilla. This looks like something that Ubuntu did and the browser update process is working as expected.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.