Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Just updated to 89.0 and I hahte it, can I make it look like previoius?

  • 2 replies
  • 4 have this problem
  • 73 views
  • Last reply by blinx2003

more options

As title, I have everything about the way new firefox looks, is there a way to make it look like the old version?

Chosen solution

Hi blinx2003,

A few possible solutions for you:

1. Re-enable Compact Mode to decrease the tab bar height and remove the "PLAYING" label on the tabs when playing media:

If you are an advanced user, it's still possible to activate it in the Configuration Editor (about:config page).

  1. Type about:config in the address bar and press Return. A warning page may appear. Click Accept the Risk and Continue to go to the about:config page.
  2. Find the browser.compactmode.show preference.
  3. Switch the toggle to true and then close the tab.
  4. Click on the menu button fx89menu to open the menu panel.
  5. Click More Tools menu.
  6. Choose Customize Toolbar.
  7. At the bottom of the panel, click the Density button.
  8. Choose Compact (not supported) from the menu options.
  9. Click Done.

More about that: Compact mode workaround in Firefox

2. Install this theme to use the pre-FF89 colors:

https://addons.mozilla.org/en-US/firefox/addon/photon-colors/

3. As an alternative for steps 1 and 2: there is a community supported workaround, which is to custom style the user interface using a userChrome.css file.

jscher2000 posted the steps in the following thread:

https://support.mozilla.org/questions/1337841

Hope this helps, Best regards, BelFox

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Hi blinx2003,

A few possible solutions for you:

1. Re-enable Compact Mode to decrease the tab bar height and remove the "PLAYING" label on the tabs when playing media:

If you are an advanced user, it's still possible to activate it in the Configuration Editor (about:config page).

  1. Type about:config in the address bar and press Return. A warning page may appear. Click Accept the Risk and Continue to go to the about:config page.
  2. Find the browser.compactmode.show preference.
  3. Switch the toggle to true and then close the tab.
  4. Click on the menu button fx89menu to open the menu panel.
  5. Click More Tools menu.
  6. Choose Customize Toolbar.
  7. At the bottom of the panel, click the Density button.
  8. Choose Compact (not supported) from the menu options.
  9. Click Done.

More about that: Compact mode workaround in Firefox

2. Install this theme to use the pre-FF89 colors:

https://addons.mozilla.org/en-US/firefox/addon/photon-colors/

3. As an alternative for steps 1 and 2: there is a community supported workaround, which is to custom style the user interface using a userChrome.css file.

jscher2000 posted the steps in the following thread:

https://support.mozilla.org/questions/1337841

Hope this helps, Best regards, BelFox

Helpful?

more options

Thanks, that's close, so it'll have to do. The way the tabs look and stuff was the main thing I didn't like, I liked the old square tabs that connected completely to the page you were on rather than floating button-looking things. The colours I was less bothered about as dark mode suits me well enough anyway, less intense on the eyes. But if this is as close as it gets then I'll make do. :)

What is up with so many companies fixing things that aren't broken? I get it, things need updates now and then, but if you gonna completely change the style of something while you're at it, at least leave the option to use the old style in for those that liked it.

Modified by blinx2003

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.