Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox "fork bomb"

  • 14 replies
  • 1 has this problem
  • 34 views
  • Last reply by Mcgiwer

more options

Hello. I had discovered that Firefox itself creates a so called "fork bomb" by creating a big amount of sub-processes under the main one (with I can prove thru the attached screenshoots).

Could anyone have a idea how to limit Firefox from opening so many sub-processess, with (wanting or not) are mostly causing that my system runs out of memory and stop beeing responsible to any of my inputs, with forces me to restart the system (similar thing is done by an DOS attack)

I use the Firefox 88.0.1 on Ubuntu 20.04 (64-bit)

uname: Linux live 5.4.0-53-generic #59-Ubuntu SMP Wed Oct 21 09:38:44 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux lsb_release:

Distributor ID: Ubuntu Description: Ubuntu 20.04.1 LTS Release: 20.04 Codename: focal

Attached screenshots

All Replies (14)

more options

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess

Helpful?

more options

I understand that it does need multiple sub-processess, but if there is only page (for example google search) loaded and all plugins are disabled then so many sub-processess for that is evedentally too much.


There should be (under the main process):

  • one sub-process for each extension, addon, etc.
  • one sub-process for the website
  • one sub-process for each additional content (for example: embed objects)

Helpful?

more options

have you compared the same with ms edge and chrome?

Helpful?

more options

·´¯`·...¸>-)))º> ~dbben said

have you compared the same with ms edge and chrome?

Please read my post with understanding. I had given there a information that I use Ubuntu 20.04 with is an Linux, so using any Windows software and Windows only solutions won't work by me. Additionally, I don't use other browsers since I run my Linux from a USB stick and explaining all things releated to it would get this question off-topic

Modified by Mcgiwer

Helpful?

more options

ok. thanks for the additional information. The reason i had asked is that by coincidence, I analyzed the 3 browsers on last week, but used a different simplier methodology than yours. And what i found is that they all compared similarly with each other in regards to processes and memory usage.

The only real difference i found is the usage of GPU, whereas FF did not invoke the use of the GPU but the others did. I think this is a flaw in FF.

In any case, this is why i my attention was gained with your discovery. I apologize for my stupid question.

btw: if you run FF in safemode, does the process list shorten? I guess i could find this out for myself. But i am in the middle of a project and you are actively analyzing this phenomenon.

Helpful?

more options

Those processes are created under 'root' what would suggest that some kernel interaction is causing them.

Firefox would normally open a few special processes and up to eight content processes, so I do not know where they are coming from.


Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Helpful?

more options

I don't use Linux but there definitely appears to be something wrong with most of the processes in your screenshot.

Perhaps the recently added about:processes page might be useful to associate specific OS processes with Firefox's use of them. If most of the processes are unaccounted for, or appear to be duplicates, you may have a new bug to report on https://bugzilla.mozilla.org/

Helpful?

more options

Modified by Mcgiwer

Helpful?

more options

Are the extra processes accounted for on the about:processes page?

I had a thought, which is that the multiplication of processes in your screenshot might relate to the forthcoming fission feature which will use site-specific processes for web content rather than allowing multiple sites to share a process. More details in this blog post:

https://hacks.mozilla.org/2021/05/introducing-firefox-new-site-isolation-security-architecture/

Your original post information has this indication:

"lockedPreferences": {"fission.autostart.session": true}

If you check the about:studies page, is your Firefox running an experiment related to fission?

Or if you check the about:policies page, is this preference locked there?

Helpful?

more options

I would still assume that this is something that Ubuntu has enabled in their canonical version as there is nothing listed under Normandy in the troubleshooting information. So probably best is to switch to Firefox from the Mozilla server like I suggested above.

Application:

distributionID: canonical
numTotalWindows: 1
numFissionWindows: 1
numRemoteWindows: 1
fissionAutoStart: TRUE
fissionDecisionStatus: enabledByUserPref
remoteAutoStart: TRUE

LockedPreferences:

fission.autostart.session: TRUE

Normandy:

addonStudies: []
prefRollouts: []
prefStudies: []

Helpful?

more options

@jscher2000

All positions in the bug report have been rewroten from the about:processes page and the screenshoots were made from htop

@cor-el

I have already the latest Firefox version installed avaliable from the repositories for my version of Ubuntu (20.04)

Helpful?

more options

jscher2000 said

Are the extra processes accounted for on the about:processes page?

No. The most does not appear in it

If you check the about:studies page, is your Firefox running an experiment related to fission?

It has returned: "You have not participated in any studies"

Or if you check the about:policies page, is this preference locked there?

In the polices, the "Active" session returns: "The Enterprise Policies service is inactive.

Helpful?

more options

Quote: I have already the latest Firefox version installed avaliable from the repositories for my version of Ubuntu (20.04)

My point was not to use the Ubuntu version, but to try the Mozilla version. Ubuntu usually makes a lot of modification to its own version. That might be autoconfig files like these:

  • /etc/firefox/syspref.js
  • /usr/lib/firefox/ubuntumate.cfg

Helpful?

more options

cor-el said

Quote: I have already the latest Firefox version installed avaliable from the repositories for my version of Ubuntu (20.04) My point was not to use the Ubuntu version, but to try the Mozilla version. Ubuntu usually makes a lot of modification to its own version. That might be autoconfig files like these:
  • /etc/firefox/syspref.js
  • /usr/lib/firefox/ubuntumate.cfg

Hello and thanks for the answer. I had looked thru the both mentioned files and bellow are the results:

/etc/firefox/syspref.js

The contents is fully commented out

/usr/lib/firefox/ubuntumate.cfg

File does not exist

Besides of above, when I had downloaded the firefox directly from mozilla and:

  • backed up the orginal user config folder
  • uninstalled the actual version
  • ensured that the permissins are correct
  • updated the alternatives and shortcuts to the extracted firefox

the firefox for some reason does not wanted to work. When attempting to run it thru a console, I got an error of missing libraries. Because of it, I had restored firefox to the state before uninstalling it

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.