Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF "Applications" doesn't apply its own settings in download

more options

My money program uses an importer to download files directly (rather than saving to desktop & manually importing. The institutions' choices always include OFX, QFX, and QIF. The Application list in Options lists OFX -- in two places-- and QFX. Both are assigned to the importer.

No matter what format I choose, I have to browse for the importer (several clicks). To check, I downloaded account information for several accounts held with the same institution, cycling through those 3 formats. Same result each time. "Always do this" is checked and OFX and QFX are assigned to the importer as you can see in the screenshot.

Shouldn't FF be adding QIF when I download activity in that format? I certainly didn't add OFX or QFX manually! And can anyone explain why "Use importer" is broken?

TIA mm

Attached screenshots

All Replies (11)

more options

You'll notice that after OFX there is something in parentheses: that is the Content-Type that the server had sent when you saved that entry. Sometimes the server sends a generic indication and Firefox never saves your choice for that because it's the same thing used for program downloads (.exe files).

I have an add-on you can use to associate file extensions with a new Content-Type that isn't shared by multiple program (like application/csv) so that you can better control the fate of those downloads. If you want to give it a try, you can install it from here:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

To turn the extension on, click its Zzzz button. Then, to create your new association:

(1) Start an OFX or QFX download. Once you get Firefox's download dialog, you can cancel it, the extension has recorded the data from the server by then.

(2) Click the extension button, then Add/Edit Content Types (View Log)

(3) On the log page, find the row with your download -- usually the first row -- and click Add. A form should appear. You can accept the fictitious content type to avoid conflicts with actual content types and click Save Content-Type.

(4) Switch back to your download page and try the download again. Save your preferred action (again!). Now Firefox should show that new handler preference on the Options page and apply it going forward.

In order for Firefox to change the Content-Type, the extension needs to be listening (hammer in color) at the time you click the download link, but you can turn it off when you don't need it.

more options

Thanks for your prompt reply. I'll have to wait a day or two so there'll be something to download. Can't wait to try it!

m

more options

I think I followed your instructions correctly, but when I click on "fictitious" content type, I get a message that says log file is obsolete, and nothing changes, I still have to find the file importer and so on. Am I doing something wrong or?

(yes, icon was green, and I got the menu and chose add/edit content types... and latest (only, in some cases, as I cleared the logs after failures) log.)

I'll keep trying things.

mm

more options

That log entry becomes obsolete once you save a change. You can close the log, test the download again and view the log afterwards to see what Firefox is doing about the download. Is it not applying the change?

more options

No, FF isn't applying the change. The importer file (.exe) is in my money program's X86 directory and Win 10 doesn't like that either-- I have to go to the drive & folder every time, the popup list of files Windows gives me doesn't include the program or that executable.

I'll give it another try tomorrow (or so...).

mm

more options

If you check the Options/Settings/Preferences page, did Firefox record the fictitious content-type in the Applications list after you interacted with the Downloads dialog and checked the box to open the file with the application every time?

more options

I don't see quite what you describe -- perhaps as a guru you have a less dumbed-down interface? See screenshots. The location of the importer in the "Application Details" dropdown is correct.

I just tried downloading an OFX file with SeaMonkey and it's exactly the same (including "use ... importer") in the preferences. The site doesn't seem to matter (didn't check each one I can download OFX (etc) files from). Naturally, I suspect the Monster System that wants to eat the world -- guesses welcome.

more options

I'm going to post two replies.

First, here's a screenshot sequence captured with a test file. I think you've already done all of this.

https://www.jeffersonscher.com/ext/empty.ofx

Step #1: Turn on the extension and try the download

This logs the download to allow editing.

Step #2: Open the log and add the new content-type

Step #3: Try the download again and save your preferred application

Unlike the first try, Firefox now should let you save instructions to the Applications list.

Step #4: Confirm the info was saved on the Settings page (you might need to reload if it was already open) and edit if needed

more options

Second reply:

If Firefox displays the dialog with the correct application rather than opening in that application automatically, it could be caused by a different header.

If the server sends Firefox the following header that invokes forced downloading, Firefox will always show the download dialog:

Content-Disposition: attachment

You can override further down the menu by check the box for "Follow by settings (inline)":

more options

Firefox (or Win10's mysterious parameters) not only doesn't display the correct application, the dropdown list consists of totally irrelevant programs by anybody anywhen, from Word to Audition to RedFox to an assortment of media players to...

But it cheerfully saves the OFX to anywhere I tell it.

The Content-type Fixer is set as in your screenshot.

more options

Windows 7 had an easier system for choosing applications than Windows 10 does. But it's what we have.

The thing is, Firefox should remember and if you switch from "As set by the server" to ""Follow by settings (inline)" should apply your choice every time. I don't know why your Firefox is behaving badly.

It's possible that the file which stores application handling preferences has become corrupted in some manner. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > Help > More Troubleshooting Information
  • (menu bar) Help > More Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, find the Profile Folder row. Click that "Open Folder" button. This should launch a new window listing various files and folders in Windows File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then:

Right-click handlers.json then Rename to something like handlersOLD.json

Start Firefox back up again. It should start building a new list as you download files.