Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox fails to use some local fonts

  • 1 reply
  • 1 has this problem
  • Last reply by Fulan

more options

After installing the Native MathML extension (to get MathML typeset equations on the Wikipedia, as suggested on mediawiki.org), all equations set by MathJax/MathML turned to using STIX instead of Latin Modern. I'd like them to stick to Latin Modern instead.

The only possibly related setting I've found is `font.name-list.serif.x-math` in about:config, whose value is `Latin Modern Math, STIX Two Math, […]`. I tried to manually change the font family specification of some text to see if Firefox could use Latin Modern Math to begin with, but apparently it can't (see first screenshot attached), while it loads STIX allright (second screenshot). Latin Modern is not the first locally installed typeface I haven't been able to use, but it's the first one I have really tried to (I don't remember which one the other typeface was).

My Latin Modern font comes from TeX Live 2019 installed using the TUG installer, not Fedora's package manager. `fc-list | grep -i "latin modern math"` returns `/usr/local/texlive/2019/texmf-dist/fonts/opentype/public/lm-math/latinmodern-math.otf: Latin Modern Math:style=Regular`. I'm running Firefox 87 on Fedora 33.

Attached screenshots

Chosen solution

I had to add the font files' directory to `security.sandbox.content.read_path_whitelist` in about:config. See https://www.reddit.com/r/firefox/comments/mhtw38/fedora_i_cant_use_some_of_my_local_fonts_on/ and https://wiki.mozilla.org/Security/Sandbox#Customization_Settings

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

I had to add the font files' directory to `security.sandbox.content.read_path_whitelist` in about:config. See https://www.reddit.com/r/firefox/comments/mhtw38/fedora_i_cant_use_some_of_my_local_fonts_on/ and https://wiki.mozilla.org/Security/Sandbox#Customization_Settings

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.