Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Put tabs BELOW address bar already!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  • 16 replies
  • 9 have this problem
  • 154 views
  • Last reply by Chris Ilias

more options

Hi

to ALL Firefox admins and programmers.....

I think Im speaking for most people when I say this......

PUT THE DAMN TABS !!!!!BELOW!!!! the address bar already!!

People have been begging you to do this for ******* years!!!

Stop being such a**holes and make it like this BY DEFAULT FOREVER! And add a simple option in the setting that always allows the user to put the tabs above or below....but I know most people want this always BELOW!!!

Fix this issue PLEASE it pisses soooo many people off having the tabs above the address bar. ...Also when I double click on the empty space beside the tabs it just shrink the open window.....change this so double clicking on the empty area OPENS A NEW TAB...

Signed a VERY pissed off user!

All Replies (16)

more options

I think many agree with you and, like many of them, I have used css code to put tabs below the url-bar. It involves creating at least one stylesheet, namely, userChrome.css and setting the following preference in about:config to true: "toolkit.legacyUserProfileCustomizations.stylesheets". You should be able to find how to do that.

more options

See this question:

more options

I have already done the UserChrome tweak...it does work if one can find a working code. The problem is the admins or whoever come in with their updates, and after awhile the user needs to find new, updated code. Its no guarantee...the teak works for some, but not all. Its VERY annoying!

Simple solution....MAKE TABS UNDER THE ADDRESS BAR THE NORMAL/DEFAULT....This is NOT a hard option to add into firefox....there is not excuse for this not being done....get it done guys...please!

more options

The code I posted in that thread and in some others only has basic code to position the tabs at the bottom and is less likely to break unlike some code that includes a lot of extras, so it should work for a large range of Firefox versions with only some modifications to CSS variables. I use it in Firefox versions ranging from 78 ESR to the current Nightly 87 builds.

more options

EDITED . . . HERE IS THE CORRECT ANSWER for Firefox version 9.00 of how to achieve it now edited into my very first question https://support.mozilla.org/en-US/questions/1339095

Modified by Trevor George, Bristol, UK

more options

If you read through the code then you may have noticed that you need to make a change for 89+ You may also have to adjust some CSS variables defined further up.

#TabsToolbar {
  -moz-box-ordinal-group: 1000 !important;
  position: absolute !important;
  display: block !important;
/* bottom: 0 !important; /* 68-88 */
  top: var(--tabbar-top);  /* 89+: top instead of bottom */
  width: 100vw !important;
}

Modified by cor-el

more options

COR-EL . . . 'we would like the whole code not just a snippet and to be told "You may also have to adjust some CSS variables defined further up" as I have no idea how css or variables work, or even how to alter code

more options

cor-el said

If you read through the code then you may have noticed that you need to make a change for 89+ You may also have to adjust some CSS variables defined further up.

COR-EL . . . PLEASE . . . we would like the whole code not just a snippet of the CSS code which you have provided. To be told "You may also have to adjust some CSS variables defined further up" is of no use whatsoever to most people as they have no idea how css or variables work, or even how to alter code.

Please supply the whole CSS code, so we can simply delete the original and copy your new code into a new userChrome.css file.

Thank you from sunny Bristol UK

more options

I've updated the code in that thread, so you can give it another try.

more options

cor-el said

I've updated the code in that thread, so you can give it another try.
Is this what I need? All below the broken line?
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* TABS: bottom - Firefox 65 and later - updated for 89+ */
/* https://searchfox.org/mozilla-release/source/browser/themes/shared/tabs.inc.css */
/* https://developer.mozilla.org/en-US/docs/Tools/Browser_Toolbox */

/* ROOT - VARS */
/* you can adjust the CSS variables until it looks correct */
/* you can use the Browser Toolbox to get the toolbar heights */

*|*:root {
  --tab-toolbar-navbar-overlap: 0px !important;

  --tab-min-height: 25px !important;
  --tab-min-width:  60px !important;

  --tab-caption: -5px; /* caption buttons on tab bar */
  --tab-adjust:   3px; /* adjust tab bar */

  --menubar-height: 0px; /*30px|41px=11px; caption buttons on menubar*/
  --navbar-height:  31px; /*31px*/
  --bookmarkbar-height: 26px;

  --tabbar-top: calc(var(--menubar-height) + var(--navbar-height) + var(--bookmarkbar-height) + var(--tab-adjust)); /*89+*/
}

/* in case you enable extra toolbars in full screen mode */
*|*:root[inFullscreen] {
  --tab-adjust: 3px;
  --menubar-height: 0px; /*30px*/
  --navbar-height:  31px; /*31px*/
  --bookmarkbar-height: 0px; /*26px*/
  --tabbar-top: calc(var(--menubar-height) + var(--navbar-height) + var(--bookmarkbar-height) + var(--tab-adjust)); /*89+*/
}

/* TAB BAR - below nav-bar */
#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10}
#TabsToolbar {-moz-box-ordinal-group:1000}

#TabsToolbar {
  display: block !important;
  position: absolute !important;
/*  bottom: 0 !important; /* 68-88: BOTTOM */
  top: var(--tabbar-top);  /* 89+: TOP */
  width: 100vw !important;
}

#tabbrowser-tabs {
  width: 100vw !important;
}

/* navigator-toolbox - PADDING */
*|*:root:not([chromehidden*="toolbar"]) #navigator-toolbox {
  padding-bottom: calc(var(--tab-min-height) + 1px) !important; /*ADJUST*/
  background-color: var(--toolbar-bgcolor) !important;
}

/* TabsToolbar with menubar and titlebar hidden - rules for Firefox 65-73 */
*|*:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"])
 #toolbar-menubar[autohide="true"] ~ #TabsToolbar{
}

/* TABS: height */
#tabbrowser-tabs,
#tabbrowser-tabs > .tabbrowser-arrowscrollbox,
.tabbrowser-tabs[positionpinnedtabs] > .tabbrowser-tab[pinned] {
  min-height: var(--tab-min-height) !important;
  max-height: var(--tab-min-height) !important;
}

#TabsToolbar {
  height: var(--tab-min-height) !important;
  margin-bottom: 1px !important;
  box-shadow: ThreeDShadow 0 -1px inset, -moz-dialog 0 1px !important; /*OPTIONAL*/
  background-color: var(--toolbar-bgcolor) !important;
  color:            var(--toolbar-color) !important;
  z-index: 1 !important;
}

/* indicators *//*
*|*:root[privatebrowsingmode=temporary] .private-browsing-indicator {
  position: absolute !important;
  display: block !important;
  right: 0px !important;
  bottom: 0px !important;
  width: 14px !important;
  pointer-events: none !important;
}
*/
.private-browsing-indicator {display: none !important;}
.accessibility-indicator    {display: none !important;}

/* Indicators - HIDE *//*
*|*:root:not([accessibilitymode])             .accessibility-indicator    {display: none !important}
*|*:root:not([privatebrowsingmode=temporary]) .private-browsing-indicator {display: none !important}
*/

/* Drag Space */
.titlebar-spacer[type="pre-tabs"],
.titlebar-spacer[type="post-tabs"] {
  width: 20px !important;
}

/* Override vertical shifts when moving a tab */
#navigator-toolbox[movingtab] > #titlebar > #TabsToolbar {
  padding-bottom: unset !important;
}

#navigator-toolbox[movingtab] #tabbrowser-tabs {
  padding-bottom: unset !important;
  margin-bottom: unset !important;
}

#navigator-toolbox[movingtab] > #nav-bar {
  margin-top: unset !important;
}

/* Hide window-controls and caption buttons on Tab Bar */
#TabsToolbar #window-controls {display: none !important;}
#TabsToolbar .titlebar-buttonbox-container {display: none !important;}

Modified by cor-el

more options

This latest code at least should always display a full tab bar if the code is working. If the Tab bar is not in the correct position then this means that the --tabbar-top variable doesn't have the correct value and needs to be adjust to move the Tab in its designated lower position.

If the code isn't working at all then it is likely that something went wrong with creating userChrome.css and you need to check if the file in in the correct location (chrome folder in the profile folder) and that the file doesn't have a hidden .txt file extension, but is a .css file. You can possibly open the file in a Firefox tab.

more options

cor-el said

This latest code at least should always display a full tab bar if the code is working.-top variable doesn't have the correct value and needs to be adjust to move the Tab in its designated lower position.

Hi cor-el . . . I have done everything exactly as requested in this thread and my other thread at - https://support.mozilla.org/en-US/questions/1339095 and the TABS still display ON TOP. It always worked with previous update versions of Firefox, but for some reason Firefox Version 90 will not accept it. Thanks . . . Trevor.

more options

HERE IS THE CORRECT ANSWER for Firefox version 9.00 of how to achieve it now edited into my very first question https://support.mozilla.org/en-US/questions/1339095

Modified by Trevor George, Bristol, UK

more options
more options

I have used FireFox since it first came out, I was one of the first 100. I have used it for years because the programmers had that Linux mentality of here's the program, customize it as you need to. People made add-ons that allowed you make FireFox look and behave that BEST suited your workflow.

Now the programmers have blocked just about everything and have joined the nanny state ranks of "YOU WILL DO AS I SAY!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! YOU WILL BE LESS EFFICIENT!!!!!!!!!!!!!! YOU WILL NOT BE ALLOWED TO BE AN INDIVIDUAL!!!!!!!!!!!!!!!!!! YOU WILL COMPLY!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! - EVEN THOUGH THAT IS NOT WHAT WE PURPORT TO STAND FOR!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"

As a researcher, it now takes me hours to do what I used to do in mintues. FireFox has BROKEN every add-on I used. And every time they FORCE an update on me, WITHOUT my permission, they break everything I've tried to undo or work around.

I have to run FireFox in "Safe Mode" just so I can do anything. What is your problem?

My God, if there were a better alternative, I'd jump this sunk ship in a nanosecond, but they're all like this now! These young people have NO RESPECT for anyone.

FireFox just forced 89 on me and broke EVERYTHING and I lost days worth of work! Thank you! Now I have to learn how to work around all of your roadblocks just so I can get back to work, you !!!!!

What happened to you folks? You used to be for the people, railed against Micro$oft, now you are just like them!

[Profanity removed by moderator. Please read Mozilla Support rules and guidelines, thanks.]

Modified by Chris Ilias

more options

Hi everyone, It doesn't look like the person who posted the original question is going to respond, and others seem to be using this thread for there own issues, so I'm going to lock this thread.

For better help, it would be best to use https://support.mozilla.org/en-US/questions/new where volunteers can get more details about your setup.