Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Dark theme on about:home page will not hold; "protected by browser"?

  • 1 reply
  • 1 has this problem
  • 1 view
  • Last reply by cor-el

more options

For years, the dark theme I used would apply to all pages, including about:newtab and about:home. About a month ago, this stopped happening, and regardless of choosing a theme that turns the background of the about:home page dark, it reverts to a white background the next time the browser is started.

I also use an add-on called Dark Reader, which gives me some control over the background of most websites. This extension is where the information that the about:home page is "protected by browser". I have not tried disabling Dark Reader, yet.

On the Firefox Options page, under the Home tab, under New Windows and Tabs, the options for "New tabs" include only two (2) choices: Firefox Home (default), or Blank Page. The dark background works (i.e., sticks, holds, stays) on the blank page, but does not work for the Firefox Home (default), which is what I have chosen and prefer. I choose only Top Sites on the Firefox Home Content settings, which are displayed below the "New tabs" settings described above.

Any help in restoring the dark (or consistent theme color) to the Firefox Home or about:home page will be greatly appreciated. Thank you!

All Replies (1)

more options

Web extensions can modify about pages and most Mozilla websites also are prohibited to inject CSS and JavaScript files.

To style about pages and other builtin (x)html pages you need to use code in userContent.css.
For the user interface you need to use code in userChrome.css.
I don't know if there are still page in current Firefox releases that need code in userChrome.css, but I doubt that.

GitHub - overdodactyl/ShadowFox: A universal dark theme for Firefox

- - - -

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.