Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some websites don't display letters such as "y" on FF. Why is this?

  • 3 replies
  • 2 have this problem
  • 7 views
  • Last reply by Joseph

more options

Some websites don't display certain letters. Currently, I'm experiencing this problem on thekitchn.com, where the letter "y" isn't displaying. Here's an example sentence, "These steps might seem prett obvious, and for the most part the are, but there’s critical strateg within each of them." I've tried this particular website on Chrome, and have the same problem. However, on Safari all the letters are displayed.

Not all websites behave this way on FF. Out of the seven tabs I have open, only one isn't displaying correctly.

The extensions I have running are: - AdBlock Plus - Facebook Container - Epub Reader - Firefox Colour - Firefox Multi-Account Containers - Privacy Badger - Share Button for Facebook - Side View - SuperStop - To Google Translate - Tree Style Tab

Here are the steps I've taken to test and fix the problem: - To test if the problem is with the website itself, I copied and pasted the words elsewhere, and missing the letter is displayed. - I restarted FF in Safe Mode, but the problem persisted. - I deleted FF from applications, downloaded v.75.0 and installed that. No go.

I'm on a Mac.

Not sure what to do now. Thanks in advance for your help.

Chosen solution

Thank you, cor-el.

The second question (/questions/1278708) helped with finding a solution.

First, I tried tried changing the fonts to "True Type" but there is no option for that in the menu.

Instead, I unchecked "Allow pages to choose their own fonts, instead of your selections above" and refreshed the page. Success!

Here were the steps: --> Open FF preferences --> Scroll down to "Language and Appearance" --> Click on "Advanced" --> Uncheck "Allow pages to choose their own fonts, instead of your selections above." --> Click "OK" --> Refresh webpage

Voila!

Read this answer in context 👍 0

All Replies (3)

more options

It is possible that Firefox isn't able to access the requested font and falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'.

This can happen if you use third-party font managers that store their fonts is a not standard location. Firefox on Mac uses a rather restricted sandbox and blocks access to most of the file system and thus blocks access to the font file if the font isn't in a standard system location.


Related threads:

Helpful?

more options

Chosen Solution

Thank you, cor-el.

The second question (/questions/1278708) helped with finding a solution.

First, I tried tried changing the fonts to "True Type" but there is no option for that in the menu.

Instead, I unchecked "Allow pages to choose their own fonts, instead of your selections above" and refreshed the page. Success!

Here were the steps: --> Open FF preferences --> Scroll down to "Language and Appearance" --> Click on "Advanced" --> Uncheck "Allow pages to choose their own fonts, instead of your selections above." --> Click "OK" --> Refresh webpage

Voila!

Helpful?

more options

I have this problem as well, and "x" is replaced with ". I tried this fix, but no change

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.