Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Disable new URL bar in Version 75

  • 62 replies
  • 25 have this problem
  • 2796 views
  • Last reply by Kiki

more options

Hello all,

this new expanding URL Bar is HORRIBLE. How can i disable this stupid implementation ?

Thanks for your help.

Modified by Airdropper

Chosen solution

Hello Airdropper,

I totally agree with you ....

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

browser.urlbar.openViewOnFocus

and set its value to false

Do the same with these preferences :

browser.urlbar.update1

browser.urlbar.update1.interventions

browser.urlbar.update1.searchTips

Then close and restart Firefox.

(if it's only the Top Sites suggestions that you want to get rid of : setting the value of first preference to "false" will do that)

Read this answer in context 👍 11

All Replies (20)

more options

Fix no longer works since Firefox 77 update. I've found a new way to fix it tho'....: Uninstall Firefox, install Vivaldi.

more options

mckendrick said

Fix no longer works since Firefox 77 update. I've found a new way to fix it tho'....: Uninstall Firefox, install Vivaldi.

I replied to your question 6 hours ago: https://support.mozilla.org/questions/1289655

more options

jscher2000 Please forgive my lack of a reply, earlier. My computer skills appear not to be competent enough to carry out the instructions. I needed to crack on with some work but the incessant dropping down of the 'top sites' and the bulging address bar became too much of a distraction so I had to use a different browser. I'll re-attempt you suggestions tomorrow. Many thanks, McK.

more options

I upgraded to 77 at work (where I don't use FF as primary) and yep it's busted. For home, FF has become an increasingly unstable pile of crap anyway ("gah! your tab crashed" - yeah, you don't say) so I'm giving Brave a shot.

Buh bye.

more options

Left Firefox too on all devices. Switched to Brave and i am happy.

more options

I changed browser.urlbar.openViewOnFocus to true and this at least allows the dropdown list to appear with your top sites.

more options

f*** it, i will use another browser. this expanding bar really sucks. don't understand what the moron had this idea

more options

Hey All, I hear your frustration, but support forum volunteers do not have the ability to change Firefox. We can offer information on settings and workarounds, which I'll summarize again in a moment.

To submit feature change suggestions, you have many choices, depending on your desired style of interaction.

Discussion Sites/Advocacy

Limited Length Comments


Firefox 75+ Bar Redesign ("Megabar")

Enlargement effect

You can override this using style rules in a userChrome.css file. See: https://support.mozilla.org/en-US/questions/1289351#answer-1318441

Auto-opening when the cursor moves into the bar

You can disable this by toggling the browser.urlbar.openViewOnFocus preference to false in about:config. If you haven't used about:config before, see: Configuration Editor for Firefox. For Firefox 78-79, use the new preference browser.urlbar.suggest.topsites instead.

Unwanted items in the top sites list

You can clean up the list on the new tab page: Customize items on your Firefox New Tab page. If you don't use the built-in new tab page, you can turn off the top sites list on that page: Customize your New Tab page to hide or display content.

Show History button missing

You can call up the list by typing a space in the bar.

As a different workaround, I created an add-on for toolbar (outside of the drop-down): https://addons.mozilla.org/firefox/addon/show-history-top-sites-button/ -- you can reply with new feature ideas (unlike Firefox, I can make changes to this extension)

more options

Too late. They had their chance and failed. I am gone.

more options

It is becoming INCREASINGLY annoying to have existing features fully removed and thrust upon me where the interface is concerned. I can see NO useful purpose for this puffing frog address bar which blocks my view of other U.I. items. At the VERY LEAST there should be a way to turn the F'ing thing off. Why force people to use stuff they do not want?

I also am getting close to dumping this browser which I have used for over 10 years, for something else.

more options

MHz Tweaker.... I fully sympathise. I actually found a way to switch back in 75, but 77 has updated it so it's no longer possible without re-writing the code - which I frankly don't have the brains for. However, I've now found a sure-fire fix: 1) Unistall Firefox. 2) Install Vivaldi. Hope this helps.

more options

I noticed that depending on the "Theme" add-on I use the background color of the url bar dropdown is often black. If I change the theme to a lighter color the background is white. Is there a way to permanently change the background color of the URL bar dropdown to be white? Something like...


 #urlbar[breakout][breakout-extend] > #urlbar-background {
   background-color: white !important;
 }

...in the userChrome.css?

more options

Bill said

Is there a way to permanently change the background color of the URL bar dropdown to be white?

Hi Bill, there's a different selector for the drop-down compared with the input area:

.urlbarView {
  background-color: #fff !important;
}


There's still a margin area around that, but hopefully it's not too distracting.

Edit: Oh wait, is the text white? That would give you white on white. I think it may be necessary to install a similar theme to work out how to override the text colors.

Modified by jscher2000

more options

Well, that turned the URL search dropdown crazy. Picture 1 is with one theme (not good) and picture 2 is with a 2nd theme (that works fine) even without the change.

EDIT: When I reverted back to the code I was trying the background of both the URL bar and the dropdown was white. But on some themes the text is right justified as below.

Modified by Bill

more options

Hi Bill, I'm not sure if the theme author declares it to be a dark-background theme or whether Firefox makes a guess based on the image. If you did need to work with a dark background theme, I think you would need to check and flip the text colors (title text to black, url text could be darker) to make it work with the white background. If there's a particular one you want to make work, could you share its link on the Mozilla Add-ons site?

more options

I really hate the big address bar and lack of drop down. Such a bad idea to force on to users.

more options

Hi McChuckles, to give feedback and find workarounds, check out the reply a few posts up from yours: https://support.mozilla.org/en-US/questions/1283831?page=2#answer-1320066

more options

Hi Bill, if you haven't found some already, here is some code to separately manage the color of the drop-down (dark-on-light) compared with the general dark theme (light-on-dark) -- to be added to your existing userChrome.css code:

/* Force black-on-white for address bar drop-down */
.urlbarView {
  /* Eliminate dark background outside */
  margin-left: 0 !important;
  margin-right: 0 !important;
  width: 100% !important;
  /* Preserve bottom border */
  border-bottom: 1px solid 
    var(--toolbar-field-focus-border-color);
}
.urlbarView-body-inner, .search-one-offs {
  /* Pure black, slightly off-white background */
  color: #000 !important;
  background-color: #f8f8f8 !important;
  /* Remove extra line */
  border-top-color: transparent !important;
  /* Adjust distance to edges  */
  padding: 0 6px !important;
}
.urlbarView-body-inner {
  /* Fix width to avoid rows being too long */
  width: calc(100% - 12px) !important;
}


more options

jscher2000 said

You can disable this by toggling the browser.urlbar.openViewOnFocus preference to false in about:config.

This helped for previous update, but for the new version 77.0.1 it does not work. I did this, but the address bar is still big for v77.0.1, it grows in size on focus.

more options

Firefox v. 77 :

This fix will lose the 'top sites' drop-down, but if that's not a big deal for you this fix will stop the expanding Address bar.

browser.urlbar.disableExtendForTests - select 'Boolean' - click '+'

After doing this, it's value should be 'True'

Then look for:

browser.urlbar.openViewOnFocus - value should be 'False' - if 'True' change to 'False'

Restart Firefox

Modified by mckendrick

  1. 1
  2. 2
  3. 3
  4. 4