X
Tap here to go to the mobile version of the site.

Support Forum

Problem with google fonts website https://fonts.google.com/

Posted

I have a problem with google fonts website https://fonts.google.com/ . When i open website i see only a blank page. I have those messages in console Warning: Content Security Policy: Ignore “unsafe-inline” inside script-src or style-src: nonce-source or hash-source specified Error: Content Security Policy: Page settings have registered resource loading on inline ("script-src"). A CSP report has been sent. Warning: Downloading <script> at "https://www.gstatic.com/_/fonts/_/js/k=fonts.app.en_US.YAiafPRTBSY.O/d=1/rs=AE60u5drZ5M7svN7zgvVTMIFAKLFGRvuZw/m=core" is not failed. Warning: Downloading <script> to the address "https://www.google-analytics.com/analytics.js" failed.

There is no problems with google fonts in other browsers

I have a problem with google fonts website https://fonts.google.com/ . When i open website i see only a blank page. I have those messages in console Warning: Content Security Policy: Ignore “unsafe-inline” inside script-src or style-src: nonce-source or hash-source specified Error: Content Security Policy: Page settings have registered resource loading on inline ("script-src"). A CSP report has been sent. Warning: Downloading <script> at "https://www.gstatic.com/_/fonts/_/js/k=fonts.app.en_US.YAiafPRTBSY.O/d=1/rs=AE60u5drZ5M7svN7zgvVTMIFAKLFGRvuZw/m=core" is not failed. Warning: Downloading <script> to the address "https://www.google-analytics.com/analytics.js" failed. There is no problems with google fonts in other browsers
Attached screenshots
Quote
jscher2000
  • Top 10 Contributor
8692 solutions 71041 answers

Hi Kate, today Google Fonts is making my fan run like crazy; something might have changed in their scripts...

Do individual font pages load any better, or same blank page? For example:

https://fonts.google.com/specimen/Roboto

Files from gstatic.com are essential for a lot of Google sites. Is it possible one of your extensions might be blocking them? Of you haven't already, you could test in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi Kate, today Google Fonts is making my fan run like crazy; something might have changed in their scripts... Do individual font pages load any better, or same blank page? For example: https://fonts.google.com/specimen/Roboto Files from gstatic.com are essential for a lot of Google sites. Is it possible one of your extensions might be blocking them? Of you haven't already, you could test in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you?
Quote

Question owner

Hi, jscher2000. Thanks for the answer. Unfortunately it didn't help(

Yes. i have similar problem with individual font pages. Safe mode also doesn't help.

Other googles sites work fine. but they also have a warning about "gstatic.com". But only a warning. not an error.

I think that the problem is in "Error: Content Security Policy: Page settings have registered resource loading on inline ("script-src"). A CSP report has been sent."

Hi, jscher2000. Thanks for the answer. Unfortunately it didn't help( Yes. i have similar problem with individual font pages. Safe mode also doesn't help. Other googles sites work fine. but they also have a warning about "gstatic.com". But only a warning. not an error. I think that the problem is in "Error: ''Content Security Policy'': Page settings have registered resource loading on inline ("script-src"). A CSP report has been sent."
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17470 solutions 157899 answers

I also see the CSP errors in the Web Console, but this doesn't affect the page content that shows properly for me although it takes some time to load all the fonts and if I use the scroll bar to scroll the page is white for some time. I see a lot of "Loading fonts" entries in the Web Console if I enable 'Info'.

Maybe this is related to the WebRender or the Compositor in your case.

I also see the CSP errors in the Web Console, but this doesn't affect the page content that shows properly for me although it takes some time to load all the fonts and if I use the scroll bar to scroll the page is white for some time. I see a lot of "Loading fonts" entries in the Web Console if I enable 'Info'. Maybe this is related to the WebRender or the Compositor in your case.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17470 solutions 157899 answers

The Inspector shows 113 .grid-list-tile items (860x16563), so this list is quite big.

The Inspector shows 113 .grid-list-tile items (860x16563), so this list is quite big.
Was this helpful to you?
Quote
lordsamuelx 0 solutions 6 answers

Hi, google fonts problems. How can I solve it? The answers above didn't solve anything for me. I'm on MAC OS 10.14.6 with firefox updated to the latest version. If I switch to windows with firefox all google fonts work.

Hi, google fonts problems. How can I solve it? The answers above didn't solve anything for me. I'm on MAC OS 10.14.6 with firefox updated to the latest version. If I switch to windows with firefox all google fonts work.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8692 solutions 71041 answers

Hi lordsamuelx, is Google Fonts the only site where downloadable fonts don't work?

If you have a more general problem with downloadable fonts not loading, could you check these settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference is bolded and "modified" to false, double-click it to restore the default value of true

(4) In the search box above the list, type or paste use_doc and pause while the list is filtered

(5) If the browser.display.use_document_fonts preference is bolded and "modified" to a value other than 1, right-click it (one button? Ctrl+click) and choose Reset to restore the default value

Hi lordsamuelx, is Google Fonts the only site where downloadable fonts don't work? If you have a more general problem with downloadable fonts not loading, could you check these settings: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''gfx.down''' and pause while the list is filtered (3) If the '''gfx.downloadable_fonts.enabled''' preference is bolded and "modified" to false, double-click it to restore the default value of true (4) In the search box above the list, type or paste '''use_doc''' and pause while the list is filtered (5) If the '''browser.display.use_document_fonts''' preference is bolded and "modified" to a value other than '''1''', right-click it (one button? Ctrl+click) and choose Reset to restore the default value
Was this helpful to you?
Quote
lordsamuelx 0 solutions 6 answers

jscher2000 said

Hi lordsamuelx, is Google Fonts the only site where downloadable fonts don't work? If you have a more general problem with downloadable fonts not loading, could you check these settings: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste gfx.down and pause while the list is filtered (3) If the gfx.downloadable_fonts.enabled preference is bolded and "modified" to false, double-click it to restore the default value of true (4) In the search box above the list, type or paste use_doc and pause while the list is filtered (5) If the browser.display.use_document_fonts preference is bolded and "modified" to a value other than 1, right-click it (one button? Ctrl+click) and choose Reset to restore the default value

Hi, did it all. The gfx.downloadable_fonts.enabled value was set to "true" or set to "false" restarted but nothing happens. browser.display.use_document_fonts the value was "1" and I left it like this. The problem continues I see nothing of google fonts. This is frustrating

''jscher2000 [[#answer-1257528|said]]'' <blockquote> Hi lordsamuelx, is Google Fonts the only site where downloadable fonts don't work? If you have a more general problem with downloadable fonts not loading, could you check these settings: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''gfx.down''' and pause while the list is filtered (3) If the '''gfx.downloadable_fonts.enabled''' preference is bolded and "modified" to false, double-click it to restore the default value of true (4) In the search box above the list, type or paste '''use_doc''' and pause while the list is filtered (5) If the '''browser.display.use_document_fonts''' preference is bolded and "modified" to a value other than '''1''', right-click it (one button? Ctrl+click) and choose Reset to restore the default value </blockquote> Hi, did it all. The gfx.downloadable_fonts.enabled value was set to "true" or set to "false" restarted but nothing happens. browser.display.use_document_fonts the value was "1" and I left it like this. The problem continues I see nothing of google fonts. This is frustrating
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8692 solutions 71041 answers

lordsamuelx said

The gfx.downloadable_fonts.enabled value was set to "true" or set to "false" restarted but nothing happens.

It needs to be set to true.

So you tried the suggestions in the earlier posts:

  • Individual font pages do not load either (Bangers)
  • Firefox's Safe Mode has the same problem

Do you use any external filtering software that could be affecting how Firefox loads pages? For example, security suites that intercept all your browsing (examples: Avast, AVG, Bitdefender, ESET, Kaspersky).

''lordsamuelx [[#answer-1257535|said]]'' <blockquote> The gfx.downloadable_fonts.enabled value was set to "true" or set to "false" restarted but nothing happens. </blockquote> It needs to be set to true. So you tried the suggestions in the earlier posts: * Individual font pages do not load either ([https://fonts.google.com/specimen/Bangers Bangers]) * Firefox's Safe Mode has the same problem Do you use any external filtering software that could be affecting how Firefox loads pages? For example, security suites that intercept all your browsing (examples: Avast, AVG, Bitdefender, ESET, Kaspersky).
Was this helpful to you?
Quote
lordsamuelx 0 solutions 6 answers

The gfx.downloadable_fonts.enabled value was set to "true"

Even the individual page of the font I see nothing. Also tested in safe mode. Also tried to uninstall Firefox and install again.

I don't use any antivirus, I don't use block

Forgive me, while I was writing to you I thought of the only block that I use for some things .... I remembered the "hosts" file. I deleted its extension and now I can see gogle fonts. Thanks for making me think! Firefox has no problem then, I created the problem! It can be closed.

The gfx.downloadable_fonts.enabled value was set to "true" Even the individual page of the font I see nothing. Also tested in safe mode. Also tried to uninstall Firefox and install again. I don't use any antivirus, I don't use block Forgive me, while I was writing to you I thought of the only block that I use for some things .... I remembered the "hosts" file. I deleted its extension and now I can see gogle fonts. Thanks for making me think! Firefox has no problem then, I created the problem! It can be closed.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17470 solutions 157899 answers

Did you check the Web Console and possibly the Network Monitor for error messages about blocked content ?

  • "3-bar" menu button or Tools -> Web Developer
Did you check the Web Console and possibly the Network Monitor for error messages about blocked content ? *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Web_Console *https://developer.mozilla.org/en-US/Tools/Network_Monitor
Was this helpful to you?
Quote
lordsamuelx 0 solutions 6 answers

yes, I had already seen the console. But then again the problem was on the hosts file. I blocked a range of IP including the range of gogle fonts. The problem was solved as I wrote about

yes, I had already seen the console. But then again the problem was on the hosts file. I blocked a range of IP including the range of gogle fonts. The problem was solved as I wrote about
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.