X
Tap here to go to the mobile version of the site.

Support Forum

Power supply fan speed increases

Posted

I launch Firefox and access the website. The destination website is simple, rich, regardless of type. A few seconds after the website is displayed, the number of revolutions of the power supply fan increases and the sound of the fan increases. And although the temperature of the power supply unit does not change greatly, the rotational speed of the fan is nearly doubled. As soon as I close the Firefox window it starts to slow down.

I endure the noise of fans and use Firefox for 20-30 minutes continuously. At this time, even if the user does not operate it, the fan rotation speed maintains the high-speed range just by leaving the window open and leaving. As soon as the window is closed, the speed drops.

This doesn't happen with other web browsers. This happens even if I recreate the profile.

--- Firefox 66.0.5 (This has been confirmed to occur from 66.0.), macOS 10.14.5, Mac Pro 2010

I launch Firefox and access the website. The destination website is simple, rich, regardless of type. A few seconds after the website is displayed, the number of revolutions of the power supply fan increases and the sound of the fan increases. And although the temperature of the power supply unit does not change greatly, the rotational speed of the fan is nearly doubled. As soon as I close the Firefox window it starts to slow down. I endure the noise of fans and use Firefox for 20-30 minutes continuously. At this time, even if the user does not operate it, the fan rotation speed maintains the high-speed range just by leaving the window open and leaving. As soon as the window is closed, the speed drops. This doesn't happen with other web browsers. This happens even if I recreate the profile. --- Firefox 66.0.5 (This has been confirmed to occur from 66.0.), macOS 10.14.5, Mac Pro 2010

Modified by Gonfox

Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

FredMcD
  • Top 10 Contributor
4229 solutions 59020 answers

That sounds like the CPU is working harder than normal on that website. Test: Go to that site. Then go somewhere else. Does the fan slow down after a while?

Please provide a public link (no password) that we can check out. No Personal Information Please !

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

That sounds like the CPU is working harder than normal on that website. Test: Go to that site. Then go somewhere else. Does the fan slow down after a while? Please provide a public link (no password) that we can check out. '''No Personal Information Please ! ''' [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you?
Quote

Question owner

At this time, the usage rate of the CPU and the rotation speed of the CPU fan do not become abnormally high. CPU utilization is 14-20% when problems occur. The problem is the rotational noise of the fan. Even if I intentionally lower the CPU or PCI fan speed, the volume of the fan noise does not change. When I lower the speed of the power supply fan, it becomes quiet.

https://www.google.com It also happens here. I also occur in Safe Mode, of course, delete profiles and configure new.

At this time, the usage rate of the CPU and the rotation speed of the CPU fan do not become abnormally high. CPU utilization is 14-20% when problems occur. The problem is the rotational noise of the fan. Even if I intentionally lower the CPU or PCI fan speed, the volume of the fan noise does not change. When I lower the speed of the power supply fan, it becomes quiet. https://www.google.com It also happens here. I also occur in Safe Mode, of course, delete profiles and configure new.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4229 solutions 59020 answers

How old is the fan? Does the computer or browser have any problem?

How old is the fan? Does the computer or browser have any problem?
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4229 solutions 59020 answers

Buy a can of compressed air and blow out the fan and the air vents.

Buy a can of compressed air and blow out the fan and the air vents.
Was this helpful to you?
Quote

Question owner

Certainly my Mac Pro is 6-7 years old. But this issue is definitely Firefox limited. Other applications do not run away like this. Fans do not run away when I browse the same site with Brave or Safari.

I'm trying a rudimentary hardware reset, such as SMC or PRAM clear. These seem to have no effect. I created a new user account for macOS, and running Firefox on that account would still cause the fans to run away.

Certainly my Mac Pro is 6-7 years old. But this issue is definitely Firefox limited. Other applications do not run away like this. Fans do not run away when I browse the same site with Brave or Safari. I'm trying a rudimentary hardware reset, such as SMC or PRAM clear. These seem to have no effect. I created a new user account for macOS, and running Firefox on that account would still cause the fans to run away.

Modified by Gonfox

Was this helpful to you?
Quote
TyDraniu
  • Top 25 Contributor
310 solutions 1728 answers

Is it a Retina display?

Enter about:config in the URL bar and set gfx.compositor.glcontext.opaque = true.

Is it a Retina display? Enter ''about:config'' in the URL bar and set ''gfx.compositor.glcontext.opaque'' = '''true'''.
Was this helpful to you?
Quote

Question owner

There is no Retina on Mac Pro. I tried the following.

  • Disable hardware acceleration
  • Disable "Stop access to the browser by the accessibility service"
  • Limit memory on about:config

These were not effective either.

There is no Retina on Mac Pro. I tried the following. * Disable hardware acceleration * Disable "Stop access to the browser by the accessibility service" * Limit memory on about:config These were not effective either.
Was this helpful to you?
Quote

Question owner

I can not affirm yet, but after updating to Firefox 67.0, it seems that the runaway of the power supply fan has stopped. I will observe a little more progress.

I can not affirm yet, but after updating to Firefox 67.0, it seems that the runaway of the power supply fan has stopped. I will observe a little more progress.
Was this helpful to you?
Quote

Question owner

I'm disappointed. Immediately after the update I felt as if the runaway had been settled. That was just a coincidence.

I'm disappointed. Immediately after the update I felt as if the runaway had been settled. That was just a coincidence.
Was this helpful to you?
Quote
Jeremy Sanders
  • Top 25 Contributor
12 solutions 142 answers

This sounds like it could potentially be a hardware issue and not a FireFox issue. Granted your Mac Pro is 6-7 years old I suspect that has something to do with it.

This sounds like it could potentially be a hardware issue and not a FireFox issue. Granted your Mac Pro is 6-7 years old I suspect that has something to do with it.
Was this helpful to you?
Quote

Question owner

Well, does it happen by chance only to Firefox?

Even with Final Cut Pro X or Parallels Desktop, which puts a strain on the Mac, this kind of abnormal rotation doesn't happen. They are not a power supply, and the rotational speed of the CPU and the fan of the PC slot increases. There is no abnormal rotation in Firefox of Parallels Desktop guest OS (Windows 10).

Why does Firefox only hit power fans? This is strange.

Well, does it happen by chance only to Firefox? Even with Final Cut Pro X or Parallels Desktop, which puts a strain on the Mac, this kind of abnormal rotation doesn't happen. They are not a power supply, and the rotational speed of the CPU and the fan of the PC slot increases. There is no abnormal rotation in Firefox of Parallels Desktop guest OS (Windows 10). Why does Firefox only hit power fans? This is strange.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17422 solutions 157420 answers
See also: *https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix
Was this helpful to you?
Quote

Question owner

I downgraded to 65.0.2. It isn't a pure 65.0.2 because it is a profile that has been updated once to 67.

I was able to confirm that the runaway of the fan was settled in this condition. After that I used Firefox's refresh function to refresh my profile. There is almost no difference between 65.0.2 in this state and 65.0.2 immediately after downgrade.

And I updated it to 67.0 again. Then, the runaway of the fan started as before. If I return to 65.0.2 again, the rotation of the power supply fan will slow down.

I downgraded to 65.0.2. It isn't a pure 65.0.2 because it is a profile that has been updated once to 67. I was able to confirm that the runaway of the fan was settled in this condition. After that I used Firefox's refresh function to refresh my profile. There is almost no difference between 65.0.2 in this state and 65.0.2 immediately after downgrade. And I updated it to 67.0 again. Then, the runaway of the fan started as before. If I return to 65.0.2 again, the rotation of the power supply fan will slow down.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4229 solutions 59020 answers

I suggest you file a Bug Report here; https://bugzilla.mozilla.org/

See Bugzilla etiquette before commenting in bug reports. https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Use the computer/profile having the problem. Give as much information as you can: what is wrong, what you tried, results . . . . List everything you can remember.

The website will read your user profile. No Personal Information Is Collected.

And post a link to the report here.

I suggest you file a Bug Report here; https://bugzilla.mozilla.org/ See Bugzilla etiquette before commenting in bug reports. https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Use the computer/profile having the problem. Give as much information as you can: what is wrong, what you tried, results . . . . List everything you can remember. The website will read your user profile. '''No Personal Information Is Collected.''' And post a link to the report here.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17422 solutions 157420 answers
See the Firefox Task Manager (about:performance) page. *https://support.mozilla.org/en-US/kb/task-manager-tabs-or-extensions-are-slowing-firefox
Was this helpful to you?
Quote

Question owner

Immediately after Firefox starts up or at the time of initial loading of the Web page, CPU usage rises by about 24-50%, but after a while, it becomes stable at about 1-3%. The Energy Impact itself also remains "low". I don't think that memory usage or CPU usage is a problem.

Immediately after Firefox starts up or at the time of initial loading of the Web page, CPU usage rises by about 24-50%, but after a while, it becomes stable at about 1-3%. The Energy Impact itself also remains "low". I don't think that memory usage or CPU usage is a problem.
Was this helpful to you?
Quote

Question owner

Thank you everyone. I solved this problem with 67.0.1.

Thank you everyone. I solved this problem with 67.0.1.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4229 solutions 59020 answers

That was very good work. Well done.

That was very good work. Well done.
Was this helpful to you?
Quote

Question owner

It started to occur again at 67.0.2. However, it takes less time for the fan to stabilize at a lower speed than before.

But it's really strange. The fan does not rotate as fast as Firefox when I use Final Cut Pro X or Paralles Desktop (Windows 10). When I launch Firefox on virtualized Windows 10, the fan does not rotate as fast as the Mac version. I check the energy impact on the activity monitor. So, for example, Parallels Desktop is 37%. Firefox for Mac is 9%. Firefox has lower energy impact than Parallels.

It started to occur again at 67.0.2. However, it takes less time for the fan to stabilize at a lower speed than before. But it's really strange. The fan does not rotate as fast as Firefox when I use Final Cut Pro X or Paralles Desktop (Windows 10). When I launch Firefox on virtualized Windows 10, the fan does not rotate as fast as the Mac version. I check the energy impact on the activity monitor. So, for example, Parallels Desktop is 37%. Firefox for Mac is 9%. Firefox has lower energy impact than Parallels.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17422 solutions 157420 answers

Maybe this is about the graphics processor (GDU) load and not about the CPU. Firefox 67 may be using WebRenderer and passes more tasks to the GPU and thus you ca get a lower CPU usage.

See also the graphics section on the "Help -> Troubleshooting Information" (about:support) page.

Maybe this is about the graphics processor (GDU) load and not about the CPU. Firefox 67 may be using WebRenderer and passes more tasks to the GPU and thus you ca get a lower CPU usage. See also the graphics section on the "Help -> Troubleshooting Information" (about:support) page.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.