Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some of my information on Firefox is in English and some in another language. Just happened. What do I do to get all English?

  • 4 replies
  • 1 has this problem
  • 4 views
  • Last reply by McCoy

more options

When I do a search on Firefox, the line under where I enter what I am searching for is in a foreign language. Instead of saying All, Shopping, Images, Video, etc., those words are in a foreign language. Example: Alle Afbeeldigen Shopping, Maps, Video, Nieuws. How can I change this?

Chosen solution

jmalcolmburk said

When I do a search on Firefox, the line under where I enter what I am searching for is in a foreign language. Instead of saying All, Shopping, Images, Video, etc., those words are in a foreign language. Example: Alle Afbeeldigen Shopping, Maps, Video, Nieuws. How can I change this?

When you're on that Google page, after you've entered a search request and you see those options in Dutch, click on :

Instellingen => Talen (Languages) and check "English". Then click on the blue box that says "Opslaan". Done.

Read this answer in context 👍 2

All Replies (4)

more options

Chosen Solution

jmalcolmburk said

When I do a search on Firefox, the line under where I enter what I am searching for is in a foreign language. Instead of saying All, Shopping, Images, Video, etc., those words are in a foreign language. Example: Alle Afbeeldigen Shopping, Maps, Video, Nieuws. How can I change this?

When you're on that Google page, after you've entered a search request and you see those options in Dutch, click on :

Instellingen => Talen (Languages) and check "English". Then click on the blue box that says "Opslaan". Done.

more options

Just in case the above doesn't work for you, please go here :

https://www.google.com/preferences?hl=en&fg=1

Scroll down to "Region Settings" and check your region.

Then click "Save" at the bottom of the page.

more options

Thanks. That fixed it.

more options

jmalcolmburk said

Thanks. That fixed it.

My pleasure - glad everything's back to normal  !