X
Tap here to go to the mobile version of the site.

Support Forum

instead of opening a new blank window firefox opens 65 tabs from a couple of years ago

Posted

usually firefox remembers my windows and tabs from the previous session. sometimes instead it will open a very old window from about 2 years ago that has 65 tabs in it. sometimes these are appended before the previous session's tabs. kind of unwieldly. this old window also opens when i choose new window from the file menu. to open a new blank window i have have to tear off a new blank tab.

usually firefox remembers my windows and tabs from the previous session. sometimes instead it will open a very old window from about 2 years ago that has 65 tabs in it. sometimes these are appended before the previous session's tabs. kind of unwieldly. this old window also opens when i choose new window from the file menu. to open a new blank window i have have to tear off a new blank tab.

Chosen solution

I called for more help.

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Type browser.startup.homepage

What is the value? Right-click and select Reset to restore its default value; about:home

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 29.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:59.0) Gecko/20100101 Firefox/59.0

More Information

FredMcD
  • Top 10 Contributor
4396 solutions 61665 answers

You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.


Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

You may have corrupt '''sessionstore''' [v56] '''sessionstore.jsonlz4''' file(s). Delete all '''sessionstore*''' files and the '''sessionstore-backups''' folder. Type '''about:support'''<enter> in the address bar. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' Locate the above file. Then rename or delete it. Restart Firefox. '''Don't delete the files''' if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

Question owner

thanks for your suggestion. however, it didn't help. when i chose new window from the file menu all the tabs (62) showed up again. any other suggestions?

thanks for your suggestion. however, it didn't help. when i chose new window from the file menu all the tabs (62) showed up again. any other suggestions?
FredMcD
  • Top 10 Contributor
4396 solutions 61665 answers

Chosen Solution

I called for more help.

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Type browser.startup.homepage

What is the value? Right-click and select Reset to restore its default value; about:home

I called for more help. Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar. Type '''browser.startup.homepage''' What is the value? Right-click and select '''Reset''' to restore its default value; '''about:home'''

Question owner

it worked! thank you so much. no problems opening a new window now. and my previous session is remembered as well. thanks again.

it worked! thank you so much. no problems opening a new window now. and my previous session is remembered as well. thanks again.
cor-el
  • Top 10 Contributor
  • Moderator
17865 solutions 161655 answers

Helpful Reply

Did you previously checked the home page setting (a new window opens by default the home page(s))?

You can check the home page setting.

Firefox supports multiple home pages separated by '|' (pipe) symbols.

Did you previously checked the home page setting (a new window opens by default the home page(s))? You can check the home page setting. *Options/Preferences -> General -> Startup: Home page *https://support.mozilla.org/en-US/kb/how-to-set-the-home-page Firefox supports multiple home pages separated by '|' (pipe) symbols.
FredMcD
  • Top 10 Contributor
4396 solutions 61665 answers

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.