Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Make Ctrl+D ask for confirmation

  • 3 replies
  • 12 have this problem
  • 105 views
  • Last reply by cor-el

more options

Is there a setting or about:config variable that I can edit to stop it from automatically bookmarking when I press Ctrl-D, or to remap the Ctrl+D key?

The proximity of the D key to the X, C, F and R keys makes it a prime candidate for accidental presses. In fact, it happens mostly when I try to press Ctrl+F because of differences in keyboard layouts between PCs, laptops, etc.

In the past, when I accidentally hit Ctrl+D, I would immediately press Esc to cancel making the bookmark, and this reflex is still strong with me. However, at some point it started adding bookmarks automatically, with the Ctrl+D dialog offering the option "Remove Bookmark" instead of "Cancel". Pressing the ESC key doesn't remove the bookmark.

(reproducible on both windows and Ubuntu)

Is there a setting or about:config variable that I can edit to stop it from automatically bookmarking when I press Ctrl-D, or to remap the Ctrl+D key? The proximity of the D key to the X, C, F and R keys makes it a prime candidate for accidental presses. In fact, it happens mostly when I try to press Ctrl+F because of differences in keyboard layouts between PCs, laptops, etc. In the past, when I accidentally hit Ctrl+D, I would immediately press Esc to cancel making the bookmark, and this reflex is still strong with me. However, at some point it started adding bookmarks automatically, with the Ctrl+D dialog offering the option "Remove Bookmark" instead of "Cancel". Pressing the ESC key doesn't remove the bookmark. (reproducible on both windows and Ubuntu)

Modified by Zom-B

Chosen solution

According to the Keyboard Shortcuts article, you could use the Menu Wizard add-on for remapping the Ctrl+D shortcut. This seems to work, but note that there are little other Ctrl-enabled shortcuts available. Using Alt or some characters instead is an option free to choose, of course.

However I assume you have noticed that when pressing Ctrl+D again, the Edit This Bookmark dialog pops up and you can just click Remove Bookmark. I’m not aware of any preference to change this "auto-addition", but another way of deleting the bookmark right after is pressing Ctrl+D, Alt+R and also described in this question. Personally I would favor that instead of adding an add-on, unless it would provide other useful features.

I do agree that the Ctrl+D shortcut could need a confirmation - or rather, pressing Esc within the predefined number of seconds should not create the bookmark - but vaguely recall a bit of discussion about it in some bug at the time the bookmark star icon was implemented. I could be wrong there though.

Read this answer in context 👍 2

All Replies (3)

more options

Chosen Solution

According to the Keyboard Shortcuts article, you could use the Menu Wizard add-on for remapping the Ctrl+D shortcut. This seems to work, but note that there are little other Ctrl-enabled shortcuts available. Using Alt or some characters instead is an option free to choose, of course.

However I assume you have noticed that when pressing Ctrl+D again, the Edit This Bookmark dialog pops up and you can just click Remove Bookmark. I’m not aware of any preference to change this "auto-addition", but another way of deleting the bookmark right after is pressing Ctrl+D, Alt+R and also described in this question. Personally I would favor that instead of adding an add-on, unless it would provide other useful features.

I do agree that the Ctrl+D shortcut could need a confirmation - or rather, pressing Esc within the predefined number of seconds should not create the bookmark - but vaguely recall a bit of discussion about it in some bug at the time the bookmark star icon was implemented. I could be wrong there though.

more options

I don't like 3rd party plugins in general but if it's the only option, I'll go with it.

Pressing Ctrl-D again doesn't help me much. Sometimes I randomly notice a blue star in the address bar for a random page I'm on, or when I try to find a real bookmark I find over half of my bookmarks are bogus.

I can't find any old discussions/bugs about this, as all my search results are swamped by people complaining that bookmarks are NOT made when they should.

more options

You would have to press Alt+R to remove the bookmark. Note that there is Ctrl+Z in the Bookmarks Manager (Library) to undo bookmark changes (add/edit/delete) provided that you haven't closed Firefox.

  • bug 1219794 - Show the edit bookmark overlay and indicate that a bookmark has been made when clicking the star

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)