Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

search engine keeps going back to yahoo

  • 6 replies
  • 5 have this problem
  • 8272 views
  • Last reply by mand92

more options

I have set my preferences so that when I type something into the URL bar it will use google as my search engine, yet lately it keeps going to yahoo. When I go to preferences: search: default search engine: google and it still goes back to yahoo as the default search engine. I'm not sure what else to do.

Chosen solution

Disable SearchMe from your Extensions. Spigot is the company that makes SearchMe and is considered adware. Probably why your searches get re-directed.

Read this answer in context 👍 0

All Replies (6)

more options

Could be a problem with Spigot Searchme.

Start Firefox in Safe Mode to check if one of the extensions (3-bar button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: 3-bar button/Tools > Add-ons > Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window

See also:

more options

It is on default but I am still having the problem.

more options

Did you check for a Spigot extension in Firefox or Spigot software stored on your computer as either of these is causing this?

more options

I went to extensions and saw searchme but I'm not sure how I can tell if Spigot is the issue?

more options

Chosen Solution

Disable SearchMe from your Extensions. Spigot is the company that makes SearchMe and is considered adware. Probably why your searches get re-directed.

more options

it worked! thanks for all the help!