Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Yahoo's search bar does not work with newest Firefox update.

  • 9 replies
  • 2 have this problem
  • Last reply by dazyblue

more options

I am having trouble with the search bar on Yahoo's main page as of this afternoon. Yahoo is my homepage. When I first start Firefox, usually I can put something in to search on Yahoo, and hit "enter" and it works fine. But if I go back to Yahoo's main page (regardless of whether that is the back button, clicking the home button, or typing it in myself) and type something else in and hit "enter" or click the "Search Web" button . . . nothing happens. It's like the entire search feature is disabled once I revisit the page. Sometimes I don't even get the ability search right from the start.

I have restarted my computer, cleared my browser cache, and turned off hardware acceleration, as suggested for similar problems in other forums. None of those have solved the problem. The only add-on I ever run is Adblock and I have used it constantly, up until today, with no issues. Yahoo works fine in Firefox safe mode and I'm not having any problems with it at all in Safari, so I know there is not a problem with Yahoo's site itself.

I have Firefox 44.0 and am running Mac OS Yosemite 10.10. I prefer Firefox as my browser and Yahoo as my search engine, so please don't give me "fixes" that involve changing those things. I want it to work as it always has.

All Replies (9)

more options

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

more options

Thanks for the reply, but that didn't do anything. I only have the default mode in appearance. I clicked it anyway, and it's still doing the same thing (not working.)

Any other suggestions?

more options

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Restart Firefox. Are there any problems?

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

more options

I tried that already and it didn't fix the problem. The only time it works normally is in "safe" mode.

Yahoo mail isn't working right, either; my inbox disappears whenever I click on "inbox" on the lefthand side after reading a message. Something is definitely screwy between Yahoo and Firefox since the latest Firefox update. I hope they figure out what it is soon and fix it, as this is driving me nuts!

more options

Application Basics

Name: Firefox Version: 44.0 Build ID: 20160123151951 Update Channel: release User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:44.0) Gecko/20100101 Firefox/44.0 Multiprocess Windows: 0/1 (default: false) Safe Mode: false

Crash Reports for the Last 3 Days

All Crash Reports


Name: Adblock Plus Version: 2.7.1 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}


Asynchronous Pan/Zoom: none Device ID: 0x0a26 GPU Accelerated Windows: 1/1 OpenGL (OMTC) Supports Hardware H264 Decoding: No; Vendor ID: 0x8086 WebGL Renderer: Intel Inc. -- Intel HD Graphics 5000 OpenGL Engine windowLayerManagerRemote: true AzureCanvasBackend: skia AzureContentBackend: quartz AzureFallbackCanvasBackend: none AzureSkiaAccelerated: 1

Important Modified Preferences

accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 3 true false browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20160123151951 browser.startup.homepage: browser.startup.homepage_override.buildID: 20160123151951 browser.startup.homepage_override.mstone: 44.0 browser.tabs.drawInTitlebar: false dom.apps.reset-permissions: true dom.mozApps.used: true extensions.lastAppVersion: 44.0 x-western gfx.blacklist.direct2d: 3 gfx.crash-guard.glcontext.appVersion: 44.0 gfx.crash-guard.glcontext.deviceID: 0x0a26 gfx.crash-guard.status.glcontext: 2 media.gmp-gmpopenh264.abi: x86_64-gcc3-u-i386-x86_64 media.gmp-gmpopenh264.lastUpdate: 1451516058 media.gmp-gmpopenh264.version: 1.5.3 media.gmp-manager.buildID: 20160123151951 media.gmp-manager.lastCheck: 1454466193 43 network.auth.allow-subresource-auth: 2 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1454110039 places.history.enabled: false places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true print.print_bgcolor: false print.print_bgimages: false print.print_colorspace: print.print_command: print.print_downloadfonts: false print.print_duplex: 1515870810 print.print_evenpages: true print.print_in_color: true print.print_margin_bottom: 0.5 print.print_margin_left: 0.5 print.print_margin_right: 0.5 print.print_margin_top: 0.5 print.print_oddpages: true print.print_orientation: 0 print.print_page_delay: 50 print.print_paper_data: 0 print.print_paper_height: 11.00 print.print_paper_name: print.print_paper_size_type: 1 print.print_paper_size_unit: 0 print.print_paper_width: 8.50 print.print_plex_name: print.print_resolution: 1515870810 print.print_resolution_name: print.print_reversed: false print.print_scaling: 1.00 print.print_shrink_to_fit: true print.print_to_file: false print.print_unwriteable_margin_bottom: 56 print.print_unwriteable_margin_left: 25 print.print_unwriteable_margin_right: 25 print.print_unwriteable_margin_top: 25 privacy.clearOnShutdown.cookies: false privacy.clearOnShutdown.sessions: false privacy.cpd.cookies: false privacy.cpd.sessions: false privacy.donottrackheader.enabled: true privacy.sanitize.didShutdownSanitize: true privacy.sanitize.migrateClearSavedPwdsOnExit: true privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.sanitizeInProgress: ["cache","history","formdata","downloads"] privacy.sanitize.sanitizeOnShutdown: true privacy.sanitize.timeSpan: 0 storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1452816758

Important Locked Preferences


Incremental GC: true


Activated: false Prevent Accessibility: 0

Library Versions

NSPR Expected minimum version: 4.11 Version in use: 4.11

NSS Expected minimum version: 3.21 Basic ECC Version in use: 3.21 Basic ECC

NSSSMIME Expected minimum version: 3.21 Basic ECC Version in use: 3.21 Basic ECC

NSSSSL Expected minimum version: 3.21 Basic ECC Version in use: 3.21 Basic ECC

NSSUTIL Expected minimum version: 3.21 Version in use: 3.21

Experimental Features

more options

You said you cleared the browser cache, did you clear the cookies?

Did all this start after updating to v44?

more options

I did clear the cookies and that did not fix the problem. It is ongoing.

I believe the problem started occurring immediately prior to the update and then I installed the update to see if that would fix the issue, which of course it did not. I reasoned that apps on my smartphone stop working properly when a new system update is available, and perhaps Firefox was doing the same thing, though that's never happened before. Clearly that was not the problem.

Any other suggestions?

more options

Are we talking about the computer, or a smartphone (also a computer)? I've called the big guys to help you. Good luck.

more options

Sorry if I confused you with the smartphone reference. The problem is occurring only on my computer, which is a Macbook Air running OS Yosemite 10.10.