X
Tap here to go to the mobile version of the site.

Support Forum

Trying a link through a page and the link wont work unless I disable addons and go in safe mode

Posted

When I log onto a site, there is a tab that I can click which should take me to my FB login. It doesn't do anything at all when I click on it unless I disable my addons and go into safe mode. I tried to disable the addons one by one but nothing worked. I cannot figure out what is causing the problem. I have also refreshed my FF starting from scratch again and still the problem persists. This is the address that I go to .... www.slotomania.com and I try clicking on the blue facebook button in the center of the page. This started happening about 5 days ago and I am at my wits end trying to figure it out. Can you help me please. Thank you =) ps... I have not added any addons in a long dang time and everything else is working perfectly.

When I log onto a site, there is a tab that I can click which should take me to my FB login. It doesn't do anything at all when I click on it unless I disable my addons and go into safe mode. I tried to disable the addons one by one but nothing worked. I cannot figure out what is causing the problem. I have also refreshed my FF starting from scratch again and still the problem persists. This is the address that I go to .... www.slotomania.com and I try clicking on the blue facebook button in the center of the page. This started happening about 5 days ago and I am at my wits end trying to figure it out. Can you help me please. Thank you =) ps... I have not added any addons in a long dang time and everything else is working perfectly.

Chosen solution

Since you are using automatic private browsing mode --

Important Modified Preferences
...
browser.privatebrowsing.autostart: true

-- this may well be caused by the new Tracking Protection feature in private windows in Firefox 42.

When anti-tracking is activated, a new shield icon should appear on the left end of the address bar. You can use that icon to make a temporary exception for the site. Or you can turn off the anti-tracking feature as a test.

This article has more information on where to find that setting on the Options page for private windows: What happened to Tracking Protection?.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NPWLPG
  • Shockwave Flash 19.0 r0
  • 5.1.40728.0
  • iTunes Detector Plug-in

Application

  • Firefox 42.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
  • Support URL: https://support.mozilla.org/1/firefox/42.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.11 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Classic Theme Restorer 1.4.2 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Google™ Translator Lite 0.1.9 (jid1-f3mYMbCpz2AZYl@jetpack)
  • Thumbnail Zoom Plus 3.7 (thumbnailZoom@dadler.github.com)
  • WOT 20151113 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 640
  • adapterDescription2:
  • adapterDeviceID: 0x0fc0
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 4095
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: B ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 2-4-2015
  • driverDate2:
  • driverVersion: 9.18.13.4520
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 640 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4307 solutions 60484 answers

Use this link to check that your plugins are up-to-date. If any are listed as unknown or research, do not worry about them.


Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Restart Firefox. Are there any problems?

'''[https://www.mozilla.org/en-US/plugincheck/ Use this link to check that your plugins are up-to-date.]''' If any are listed as unknown or research, do not worry about them. ----------- Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Restart Firefox. Are there any problems?

Helpful Reply

I did what you said Fred, and thank you for your help but the problem is still there. The only update I had was for adobe reader which I did first and then I went under the options like you said and unchecked the Use Hardward Acceleration. I then restarted and checked right away. Still the same.

Any other ideas?

I did what you said Fred, and thank you for your help but the problem is still there. The only update I had was for adobe reader which I did first and then I went under the options like you said and unchecked the Use Hardward Acceleration. I then restarted and checked right away. Still the same. Any other ideas?

Question owner

Help please .... still having this problem. It seems to be something that is running in the background of FF. This does not happen on ANY other browser that I use, just FF. I have tried disabling each add on one at a time as well as disabling all the extensions one at a time. The ONLY time I can click on the link and get the pop up is if I go in under safe mode.

I just do NOT understand this and it is completely frustrating!!! Please help fix my problem.

Help please .... still having this problem. It seems to be something that is running in the background of FF. This does not happen on ANY other browser that I use, just FF. I have tried disabling each add on one at a time as well as disabling all the extensions one at a time. The ONLY time I can click on the link and get the pop up is if I go in under safe mode. I just do NOT understand this and it is completely frustrating!!! Please help fix my problem.
cor-el
  • Top 10 Contributor
  • Moderator
17682 solutions 159968 answers

Are you using the default theme or a custom theme?

That is not a normal link, but a JavaScript onclick event is attached to the link that runs FBlogin(); If nothing happens if you click the link then something is blocking this JavaScript.

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Do you see any JavaScript error messages in the Web Console (Firefox menu button or Tools > Web Developer)?

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

Are you using the default theme or a custom theme? That is not a normal link, but a JavaScript onclick event is attached to the link that runs FBlogin(); If nothing happens if you click the link then something is blocking this JavaScript. You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Do you see any JavaScript error messages in the Web Console (Firefox menu button or Tools > Web Developer)? *https://developer.mozilla.org/Tools/Web_Console You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences
FredMcD
  • Top 10 Contributor
4307 solutions 60484 answers

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.


What theme are you using? Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac:<Command>) <Shift> A)

On the left side of the page, select Appearance.

'''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode%20Safe%20Mode Safe Mode]''' is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else. -------------- Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Then in the reply box at the bottom of this page, do a right click in the box and select '''Paste.''' This will show us your system details. '''No Personal Information Is Collected.''' ------------------- What theme are you using? Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac:<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.'''

Question owner

In reply to FredMcD ..... I added an image of the appearance that I am using. I also disabled this at one point and used Default but it did not make a difference.

Application Basics


Name: Firefox Version: 42.0 Build ID: 20151029151421 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0 Multiprocess Windows: 0/2 (default: false) Safe Mode: false

Crash Reports for the Last 3 Days


All Crash Reports Extensions


Name: Adblock Plus Version: 2.6.11 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Classic Theme Restorer Version: 1.4.3 Enabled: true ID: ClassicThemeRestorer@ArisT2Noia4dev

Name: Google™ Translator Lite Version: 0.1.9 Enabled: true ID: jid1-f3mYMbCpz2AZYl@jetpack

Name: Thumbnail Zoom Plus Version: 3.7 Enabled: true ID: thumbnailZoom@dadler.github.com

Name: Turn Off the Lights Version: 3.1.0.27 Enabled: true ID: stefanvandamme@stefanvd.net

Name: WOT Version: 20151113 Enabled: true ID: {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}

Graphics


Adapter Description: NVIDIA GeForce GT 640 Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Adapter RAM: 4095 Asynchronous Pan/Zoom: none ClearType Parameters: Gamma: 2200 Pixel Structure: B ClearType Level: 100 Enhanced Contrast: 50 Device ID: 0x0fc0 DirectWrite Enabled: false (6.2.9200.17461) Driver Date: 2-4-2015 Driver Version: 9.18.13.4520 GPU #2 Active: false GPU Accelerated Windows: 0/2 Basic (OMTC) Subsys ID: 00000000 Supports Hardware H264 Decoding: false Vendor ID: 0x10de WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 640 Direct3D11 vs_5_0 ps_5_0) windowLayerManagerRemote: true AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Important Modified Preferences


browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 3 browser.download.folderList: 2 browser.download.importedFromSqlite: true browser.download.useDownloadDir: false browser.places.smartBookmarksVersion: 7 browser.privatebrowsing.autostart: true browser.startup.homepage: http://www.twcc.com/ browser.startup.homepage_override.buildID: 20151029151421 browser.startup.homepage_override.mstone: 42.0 browser.tabs.drawInTitlebar: false browser.tabs.warnOnClose: false dom.apps.reset-permissions: true dom.mozApps.used: true extensions.lastAppVersion: 42.0 gfx.direct2d.disabled: true gfx.direct3d.last_used_feature_level_idx: 0 gfx.driver-init.appVersion: 42.0 gfx.driver-init.deviceID: 0x0fc0 gfx.driver-init.driverVersion: 9.18.13.4520 gfx.driver-init.feature-d2d: true gfx.driver-init.feature-d3d11: true gfx.driver-init.status: 2 layers.acceleration.disabled: true media.gmp-eme-adobe.abi: x86-msvc media.gmp-eme-adobe.lastUpdate: 1447704125 media.gmp-eme-adobe.version: 15 media.gmp-gmpopenh264.abi: x86-msvc media.gmp-gmpopenh264.enabled: true media.gmp-gmpopenh264.lastUpdate: 1447903058 media.gmp-gmpopenh264.version: 1.5.1 media.gmp-manager.buildID: 20151029151421 media.gmp-manager.lastCheck: 1447903057 media.hardware-video-decoding.failed: false network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1447713835 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.flash: 1 plugin.state.npctrl: 1 plugin.state.npezffpi: 1 plugin.state.npintelwebapiipt: 1 plugin.state.npintelwebapiupdater: 1 plugin.state.npitunes: 1 plugin.state.npnv3dv: 1 plugin.state.npnv3dvstreaming: 1 plugin.state.nppdf: 1 plugin.state.npwlpg: 1 privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1447713835

Important Locked Preferences


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.10 Version in use: 4.10.10

NSS Expected minimum version: 3.19.4 Basic ECC Version in use: 3.19.4 Basic ECC

NSSSMIME Expected minimum version: 3.19.4 Basic ECC Version in use: 3.19.4 Basic ECC

NSSSSL Expected minimum version: 3.19.4 Basic ECC Version in use: 3.19.4 Basic ECC

NSSUTIL Expected minimum version: 3.19.4 Version in use: 3.19.4

Experimental Features


In reply to FredMcD ..... I added an image of the appearance that I am using. I also disabled this at one point and used Default but it did not make a difference. Application Basics ------------------ Name: Firefox Version: 42.0 Build ID: 20151029151421 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0 Multiprocess Windows: 0/2 (default: false) Safe Mode: false Crash Reports for the Last 3 Days --------------------------------- All Crash Reports Extensions -------------------------------- Name: Adblock Plus Version: 2.6.11 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} Name: Classic Theme Restorer Version: 1.4.3 Enabled: true ID: ClassicThemeRestorer@ArisT2Noia4dev Name: Google™ Translator Lite Version: 0.1.9 Enabled: true ID: jid1-f3mYMbCpz2AZYl@jetpack Name: Thumbnail Zoom Plus Version: 3.7 Enabled: true ID: thumbnailZoom@dadler.github.com Name: Turn Off the Lights Version: 3.1.0.27 Enabled: true ID: stefanvandamme@stefanvd.net Name: WOT Version: 20151113 Enabled: true ID: {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7} Graphics -------- Adapter Description: NVIDIA GeForce GT 640 Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Adapter RAM: 4095 Asynchronous Pan/Zoom: none ClearType Parameters: Gamma: 2200 Pixel Structure: B ClearType Level: 100 Enhanced Contrast: 50 Device ID: 0x0fc0 DirectWrite Enabled: false (6.2.9200.17461) Driver Date: 2-4-2015 Driver Version: 9.18.13.4520 GPU #2 Active: false GPU Accelerated Windows: 0/2 Basic (OMTC) Subsys ID: 00000000 Supports Hardware H264 Decoding: false Vendor ID: 0x10de WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 640 Direct3D11 vs_5_0 ps_5_0) windowLayerManagerRemote: true AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0 Important Modified Preferences ------------------------------ browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 3 browser.download.folderList: 2 browser.download.importedFromSqlite: true browser.download.useDownloadDir: false browser.places.smartBookmarksVersion: 7 browser.privatebrowsing.autostart: true browser.startup.homepage: http://www.twcc.com/ browser.startup.homepage_override.buildID: 20151029151421 browser.startup.homepage_override.mstone: 42.0 browser.tabs.drawInTitlebar: false browser.tabs.warnOnClose: false dom.apps.reset-permissions: true dom.mozApps.used: true extensions.lastAppVersion: 42.0 gfx.direct2d.disabled: true gfx.direct3d.last_used_feature_level_idx: 0 gfx.driver-init.appVersion: 42.0 gfx.driver-init.deviceID: 0x0fc0 gfx.driver-init.driverVersion: 9.18.13.4520 gfx.driver-init.feature-d2d: true gfx.driver-init.feature-d3d11: true gfx.driver-init.status: 2 layers.acceleration.disabled: true media.gmp-eme-adobe.abi: x86-msvc media.gmp-eme-adobe.lastUpdate: 1447704125 media.gmp-eme-adobe.version: 15 media.gmp-gmpopenh264.abi: x86-msvc media.gmp-gmpopenh264.enabled: true media.gmp-gmpopenh264.lastUpdate: 1447903058 media.gmp-gmpopenh264.version: 1.5.1 media.gmp-manager.buildID: 20151029151421 media.gmp-manager.lastCheck: 1447903057 media.hardware-video-decoding.failed: false network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1447713835 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.flash: 1 plugin.state.npctrl: 1 plugin.state.npezffpi: 1 plugin.state.npintelwebapiipt: 1 plugin.state.npintelwebapiupdater: 1 plugin.state.npitunes: 1 plugin.state.npnv3dv: 1 plugin.state.npnv3dvstreaming: 1 plugin.state.nppdf: 1 plugin.state.npwlpg: 1 privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1447713835 Important Locked Preferences ---------------------------- JavaScript ---------- Incremental GC: true Accessibility ------------- Activated: false Prevent Accessibility: 0 Library Versions ---------------- NSPR Expected minimum version: 4.10.10 Version in use: 4.10.10 NSS Expected minimum version: 3.19.4 Basic ECC Version in use: 3.19.4 Basic ECC NSSSMIME Expected minimum version: 3.19.4 Basic ECC Version in use: 3.19.4 Basic ECC NSSSSL Expected minimum version: 3.19.4 Basic ECC Version in use: 3.19.4 Basic ECC NSSUTIL Expected minimum version: 3.19.4 Version in use: 3.19.4 Experimental Features ---------------------
FredMcD
  • Top 10 Contributor
4307 solutions 60484 answers

Helpful Reply

As a test, switch to the default theme.

As a test, switch to the default theme.

Question owner

Cor_el .... I did not do anything with preferences yet, but this is what I got when I did the console. Please also see what I had pasted in for FredMcD

Cor_el .... I did not do anything with preferences yet, but this is what I got when I did the console. Please also see what I had pasted in for FredMcD

Question owner

Hi FredMcD ... I disabled to the default theme and it did nothing. I had disabled and restarted each and every add on as well as extensions until I had everything disabled and still even after that I had the same problem. The only time the problem does NOT happen is when I am in safe mode. Here is a snippet of the default test but it really shows you nothing. Thank you for all of your help with this =)

Hi FredMcD ... I disabled to the default theme and it did nothing. I had disabled and restarted each and every add on as well as extensions until I had everything disabled and still even after that I had the same problem. The only time the problem does NOT happen is when I am in safe mode. Here is a snippet of the default test but it really shows you nothing. Thank you for all of your help with this =)
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Chosen Solution

Since you are using automatic private browsing mode --

Important Modified Preferences
...
browser.privatebrowsing.autostart: true

-- this may well be caused by the new Tracking Protection feature in private windows in Firefox 42.

When anti-tracking is activated, a new shield icon should appear on the left end of the address bar. You can use that icon to make a temporary exception for the site. Or you can turn off the anti-tracking feature as a test.

This article has more information on where to find that setting on the Options page for private windows: What happened to Tracking Protection?.

Since you are using automatic private browsing mode -- <blockquote> Important Modified Preferences<br> ...<br> browser.privatebrowsing.autostart: true </blockquote> -- this may well be caused by the new Tracking Protection feature in private windows in Firefox 42. When anti-tracking is activated, a new shield icon should appear on the left end of the address bar. You can use that icon to make a temporary exception for the site. Or you can turn off the anti-tracking feature as a test. This article has more information on where to find that setting on the Options page for private windows: [[Tracking Protection in Private Browsing]].
cor-el
  • Top 10 Contributor
  • Moderator
17682 solutions 159968 answers

What do you see when you right-click the button and click Inspect Element to open the Inspector?

Is there a link with an 'ev' button appended?

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

What do you see when you right-click the button and click Inspect Element to open the Inspector? *https://developer.mozilla.org/Tools/Page_Inspector Is there a link with an 'ev' button appended? Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10

Question owner

jscher2000 YOU ARE A GENIUS!!! Seriously was losing my mind, I knew it had to be something running behind the scenes when it only happened in FF and not another browser.

As you suggested, I clicked on the icon next to the name in the toolbar, searched the drop down and clicked on DISABLE PROTECTION FOR THIS SITE ... now it runs perfectly as it did before.

Case solved ... thank you to each of you helping me try to sort through this. I really do appreciate it greatly.

jscher2000 YOU ARE A GENIUS!!! Seriously was losing my mind, I knew it had to be something running behind the scenes when it only happened in FF and not another browser. As you suggested, I clicked on the icon next to the name in the toolbar, searched the drop down and clicked on '''''DISABLE PROTECTION FOR THIS SITE''''' ... now it runs perfectly as it did before. Case solved ... thank you to each of you helping me try to sort through this. I really do appreciate it greatly.