X
Tap here to go to the mobile version of the site.

Support Forum

Only one site is having issues displaying text but it does not happen with IE.

Posted

The text is not displaying on one website only and only in one part of the website and it seems to only be one type of text.

http://wol.jw.org/en/wol/h/r1/lp-e

http://wol.jw.org/en/wol/b/r1/lp-e/nwt/E/2013/45/14

It is the Bible and the Bible's text is the only part that is not displaying correctly. I uninstalled and reinstalled.

FF 40 Windows 7 SP1 64Bit

IE displays the same site and pages correctly.

The text is not displaying on one website only and only in one part of the website and it seems to only be one type of text. http://wol.jw.org/en/wol/h/r1/lp-e http://wol.jw.org/en/wol/b/r1/lp-e/nwt/E/2013/45/14 It is the Bible and the Bible's text is the only part that is not displaying correctly. I uninstalled and reinstalled. FF 40 Windows 7 SP1 64Bit IE displays the same site and pages correctly.
Attached screenshots

Chosen solution

I'm out of ideas, sorry.

Well, this AM it was still an issue. I did not reboot my computer or do any downloads for FF, nothing. But I opened another FF window and my home page is set to the Daily Text which I had already done this AM and the Text had been 1/2 as it has been. Suddenly out of nowhere the text is fine.

So I will mark this thread resolved and I have no idea would could have resolved it.

Thanks for all your hard work and for all I know the Organization knew of the issue and changed something this AM between the time I first logged on and opened FF until now.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.12
  • npdivxplayerplugin
  • DivX Web Player version 1.5.0.52
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • PDF-XChange Viewer Netscape Gecko Plugin
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0
  • Unity Player 4.3.1f1
  • VLC media player Web Plugin
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

More Information

Helpful Reply

A friend that has FF 40 says his is fine.

A friend that has FF 40 says his is fine.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Helpful Reply

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' ------------------- Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

Thanks for getting back to me. I went through the list and tried all fixes but nothing has worked.

Should I keep USE HARDWARE ACCELERATION unchecked at this point since unchecking did not seem to help? I looked at the site in safe mode and out of safe mode after a FF restart and it is still the same problem.

Thanks for getting back to me. I went through the list and tried all fixes but nothing has worked. Should I keep USE HARDWARE ACCELERATION unchecked at this point since unchecking did not seem to help? I looked at the site in safe mode and out of safe mode after a FF restart and it is still the same problem.
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157837 answers

You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))

If you have made changes to Advanced font size settings like increasing the minimum/default font size then try the Default font size setting "16" and the Minimum font size setting "none" in case the current setting is causing problems.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly.

You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems. *<b>View > Zoom > Reset</b> (Ctrl/Command+0 (zero)) *http://kb.mozillazine.org/Zoom_text_of_web_pages If you have made changes to Advanced font size settings like increasing the minimum/default font size then try the Default font size setting "16" and the Minimum font size setting "none" in case the current setting is causing problems. *Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none) Make sure that you allow pages to choose their own fonts. *Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly.

Question owner

Thanks for your reply.

I did do a reset for View/Zoom and did check font sizes and it is 16 and none and then the advanced does have an X for "Allow pages to choose their own fonts, instead of my selections above".

The problem is still occurring.

Thanks for your reply. I did do a reset for View/Zoom and did check font sizes and it is 16 and none and then the advanced does have an X for "Allow pages to choose their own fonts, instead of my selections above". The problem is still occurring.
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157837 answers

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Question owner

You mean like the links above? These pages on this site are the only pages it occurs on. It is the Bible but the Bible from the ONLINE LIBRARY only. The other Bible from the site is fine. Also, it is the Daily Text from the ONLINE LIBRARY and not the Daily Text from the other area of the site.

http://wol.jw.org/en/wol/h/r1/lp-e http://wol.jw.org/en/wol/b/r1/lp-e/nwt/E/2013/45/1

Even publications on the ONLINE LIBRARY are fine. Just the Bible and of course the scripture from the Bible on the Daily Text.

No other site is effected and I have been on FF 40 about a week and on many sites.

You mean like the links above? These pages on this site are the only pages it occurs on. It is the Bible but the Bible from the ONLINE LIBRARY only. The other Bible from the site is fine. Also, it is the Daily Text from the ONLINE LIBRARY and not the Daily Text from the other area of the site. http://wol.jw.org/en/wol/h/r1/lp-e http://wol.jw.org/en/wol/b/r1/lp-e/nwt/E/2013/45/1 Even publications on the ONLINE LIBRARY are fine. Just the Bible and of course the scripture from the Bible on the Daily Text. No other site is effected and I have been on FF 40 about a week and on many sites.

Modified by LuvFF2

Question owner

Hi~

Has this one stumped you? lol I am just checking in to see if there is anything else I can try.

Thanks!

Hi~ Has this one stumped you? lol I am just checking in to see if there is anything else I can try. Thanks!
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157837 answers

Sorry , I seem to have missed your reply.

The text at the top of the welcome page is in a downloaded woff font (WtClearText) as you can see in my attached screenshot.

Does Firefox use this font as well in your case?

You can right-click and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Sorry , I seem to have missed your reply. The text at the top of the welcome page is in a downloaded woff font (WtClearText) as you can see in my attached screenshot. *http://wol.jw.org/en/wol/h/r1/lp-e Does Firefox use this font as well in your case? You can right-click and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer) with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. *https://developer.mozilla.org/Tools/Page_Inspector Make sure that you allow pages to choose their own fonts. *Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" You can check the <b>gfx.downloadable_fonts.enabled</b> pref on the <b>about:config</b> page and make sure that it is set to true (if necessary double-click the line to toggle its value). You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Question owner

I have uploaded the Inspect Element for you if you do not mind. I am not really very good at interpreting what comes up so I thought maybe you could take a look.

X (Actually a check mark) is there for "Allow pages to choose their own fonts, instead of my selections above".

TRUE is set for gfx.downloadable_fonts.enabled.

Thanks for getting back to me. Let me know if there is something else we can look at.

Also, if you need me to send more of the Inspect Element information it does scroll and is fairly lengthy as I am sure you are aware.

I have uploaded the Inspect Element for you if you do not mind. I am not really very good at interpreting what comes up so I thought maybe you could take a look. X (Actually a check mark) is there for "Allow pages to choose their own fonts, instead of my selections above". TRUE is set for '''gfx.downloadable_fonts.enabled'''. Thanks for getting back to me. Let me know if there is something else we can look at. Also, if you need me to send more of the Inspect Element information it does scroll and is fairly lengthy as I am sure you are aware.

Modified by LuvFF2

Question owner

I took 2 more pictures. I think it shows it all but if not I will take a 3rd as I think the bottom of the 2nd image might be cut off.

I took 2 more pictures. I think it shows it all but if not I will take a 3rd as I think the bottom of the 2nd image might be cut off.
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

On the right side, you'll see some little tabs/buttons: Rules, Computed, Fonts, etc. Click Fonts and check whether Firefox is using the font specified by the website and downloaded or is substituting a font from your system. I have attached a screen shot of what I see.

On the right side, you'll see some little tabs/buttons: Rules, Computed, Fonts, etc. Click Fonts and check whether Firefox is using the font specified by the website and downloaded or is substituting a font from your system. I have attached a screen shot of what I see.

Question owner

I notice my Abc font example is halved just like the font on my Online Library. Your Abc font is whole.

I have 2 pictures for you and moved the font information in the box for you to see all it states.

What is this telling you? Does this need to be cleared somehow or recoded? Maybe in the box BELOW?

I notice my Abc font example is halved just like the font on my Online Library. Your Abc font is whole. I have 2 pictures for you and moved the font information in the box for you to see all it states. What is this telling you? Does this need to be cleared somehow or recoded? Maybe in the box BELOW?

Modified by LuvFF2

jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

I don't know why Firefox is not showing the whole characters for just this one font.

I don't know why Firefox is not showing the whole characters for just this one font.

Question owner

I enlarged the box so you could check the coding.

I enlarged the box so you could check the coding.

Modified by LuvFF2

Question owner

Oh. Is looking at all the coding in the box help?

I know my friend has FF 40 and he says his Online Library is working.

Do we escalate this? I know I don't go around changing any settings so I can't think of anything I could have done with the download from the previous version to 40.

Oh. Is looking at all the coding in the box help? I know my friend has FF 40 and he says his Online Library is working. Do we escalate this? I know I don't go around changing any settings so I can't think of anything I could have done with the download from the previous version to 40.
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157837 answers

You can try to disable OMTC and toggle this pref to false on the about:config page.

  • layers.offmainthreadcomposition.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can try to disable OMTC and toggle this pref to false on the <b>about:config</b> page. *<b>layers.offmainthreadcomposition.enabled</b> = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Question owner

WOW - Had do I change just THAT line to False. I hit my spacebar or clicked on it I forget now, changed the whole line of information to FALSE, panicked and got it back to TRIE but should they all be true now? How do I change JUST THAT LINE to FALSE?

WOW - Had do I change just THAT line to False. I hit my spacebar or clicked on it I forget now, changed the whole line of information to FALSE, panicked and got it back to TRIE but should they all be true now? How do I change JUST THAT LINE to FALSE?

Question owner

OK, I got it. I was hitting the value tab and putting all value column in order.

Whew. OK. FALSE on layers.offmainthreadcomposition.enabled

OK, I got it. I was hitting the value tab and putting all value column in order. Whew. OK. FALSE on '''layers.offmainthreadcomposition.enabled'''

Question owner

It didn't work.  : (

This is a weird one.

Do you want me to toggle it back to TRUE?

It didn't work. : ( This is a weird one. Do you want me to toggle it back to TRUE?

Modified by LuvFF2