Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps crashing apon startup and unable to send crash report

  • 5 replies
  • 3 have this problem
  • 13 views
  • Last reply by cor-el

more options

Last night I was browsing the web and ended up having 300+ tabs opened, FIrefox started to slow tremendously and stopped responding a couple of times. Was given the option to close Firefox from the popup window and choose to close Firefox, unfortunately when I tried to open Firefox again it crashed and gave me the crash reporter and when I tried to submit the report the report it encountered a problem and is unable to send the report. I've run Firefox in safe mode and is working fine but when I try to restart with add-ons disabled its still crashes and unable to send report.

Chosen solution

If you can start Firefox in Safe Mode by holding down the Shift/Options key then you can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

Read this answer in context 👍 0

All Replies (5)

more options

Try to start Firefox with the about:blank page by creating a copy of the current Firefox desktop shortcut and add a space and -url "about:blank" to the target field.

Try to delete the sessionstore.js file in the Firefox profile folder to prevent restoring the crashed session.

The "AppData" folder in Windows Vista and later Window 7+ versions and the "Application Data" folder in XP/Win2K are hidden folders.

more options

It still crashes unfortunately.

more options

Chosen Solution

If you can start Firefox in Safe Mode by holding down the Shift/Options key then you can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

more options

Disabling hardware acceleration seems to fix the issue, thank you. Why would this be the cause of the problem?

more options

You're welcome.

That is quite likely if disabling hardware acceleration did the crashes stop. It is possible that one of the tabs (likely the last one you opened and that got restored automatically) was causing the crash.

You can set the browser.sessionstore.max_resumed_crashes pref to 0 on the about:config page to get the about:sessionrestore page immediately with the first start after a crash has occurred or the Task Manager was used to close Firefox.