Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube videos will not play on Firefox without refreshing page

  • 1 reply
  • 1 has this problem
  • 1 view
  • Last reply by FredMcD

more options

When I try to play a video after a delay of 10-20 seconds I get the "An error has occurred, please try again later. Learn More. If I hit F5 or Reload Current Page on the browser it will typically start the video. Videos play fine with Chrome.

I have Firefox 37.0.2 and Shockwave Flash 17.0.0.169 installed

When I try to play a video after a delay of 10-20 seconds I get the "An error has occurred, please try again later. Learn More. If I hit F5 or Reload Current Page on the browser it will typically start the video. Videos play fine with Chrome. I have Firefox 37.0.2 and Shockwave Flash 17.0.0.169 installed

All Replies (1)

more options

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.