X
Tap here to go to the mobile version of the site.

Support Forum

Firefox freezes temporarily on certain websites and computer hangs

Posted

When loading certain websites, Firefox freezes for 10 to 30 seconds. When this occurs, the entire operating system is unresponsive. One website it almost always happens on is the Comcast TV schedule site I use: http://xfinitytv.comcast.net/tv-listings It happens with some regularity on facebook.com as well. Once the problem has occurred, it does not recur until the next session.

When loading certain websites, Firefox freezes for 10 to 30 seconds. When this occurs, the entire operating system is unresponsive. One website it almost always happens on is the Comcast TV schedule site I use: http://xfinitytv.comcast.net/tv-listings It happens with some regularity on facebook.com as well. Once the problem has occurred, it does not recur until the next session.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Amazon MP3 Downloader Plugin 1.0.17
  • Bitdefender QuickScan Web Netscape Plugin
  • Citrix Online App Detector Plugin
  • Garmin Communicator Plug-In 4.1.0.0
  • GEPlugin
  • Version 5.38.6.0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • LogMeIn Rescue Technician Console
  • CANON iMAGE GATEWAY Mycamera Plugin
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.3
  • Winamp Application Detector

Application

  • Firefox 34.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
  • Support URL: https://support.mozilla.org/1/firefox/34.0.5/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.6 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add to Search Bar 2.8 (add-to-searchbox@maltekraus.de)
  • AddThis 3.6.5 ({3e0e7d2a-070f-4a47-b019-91fe5385ba79})
  • Bitdefender QuickScan 0.9.9.142 ({e001c731-5e37-4538-a5cb-8168736a2360})
  • Bookmark Favicon Changer 1.74 (bookmarkfaviconchanger@sonthakit)
  • ChatZilla 0.9.91.1 ({59c81df5-4b7a-477b-912d-4e0fdf64e5f2})
  • Cutyfox URL Shortener (bit.ly, is.gd, goo.gl) 1.4.1 (cutyfox@apps.metzweb.net)
  • Dictionnaire français «Classique & Réforme 1990» 4.3 (fr-classique-reforme1990@dictionaries.addons.mozilla.org)
  • FireFTP 2.0.21 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f})
  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • IMDb ratings for watchever 0.0.7 (jid1-FpyZ8qozEHjs2A@jetpack)
  • LogMeIn, Inc. Rescue Technician Console 7.3.0.1445 (TechnicianConsole@logmeinrescue.com)
  • Show Parent Folder 2.1 (showParentFolder@alice)
  • Simple Timer 2.0.2 (simpletimer@grbradt.org)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Update Scanner 3.2.0 ({c07d1a49-9894-49ff-a594-38960ede8fb9})
  • Xmarks 4.3.5 (foxmarks@kei.com)
  • Classic Theme Restorer 1.2.8.2 (ClassicThemeRestorer@ArisT2Noia4dev) (Inactive)
  • Favicon Picker 3 0.5 ({446c03e0-2c35-11db-a98b-0800200c9a67}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 4200
  • adapterDescription2:
  • adapterDeviceID: 0x9710
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterSubsysID: 043b1028
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 1800 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 7-3-2012
  • driverDate2:
  • driverVersion: 8.970.100.3000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4200 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 3
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141126041045
  • browser.startup.homepage: https://accounts.google.com/ServiceLogin?service=mail&passive=true&rm=false&continue=https://mail.google.com/mail/?zx%3Dr6jlcv7p8cvj%26shva%3D1&ss=1&scc=1&ltmpl=default&ltmplcache=2&emr=1#inbox
  • browser.startup.homepage_override.buildID: 20141126041045
  • browser.startup.homepage_override.mstone: 34.0.5
  • browser.tabs.drawInTitlebar: False
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 34.0.5
  • font.internaluseonly.changed: True
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • layers.acceleration.disabled: True
  • media.gmp-gmpopenh264.lastUpdate: 1413816181
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1421252555
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1421247500
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1317854593
  • plugin.disable_full_page_plugin_for_types: audio/x-mpeg,audio/mpeg,application/pdf,audio/x-mpegurl
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1419716438

Misc

  • User JS: No
  • Accessibility: No

Question owner

I never use the kind of antivirus program that controls access to the internet. Just Ad-Aware to recognize malware. No automated internet security, just my wits. No Windows firewall, just the hardware one in the router.

I never use the kind of antivirus program that controls access to the internet. Just Ad-Aware to recognize malware. No automated internet security, just my wits. No Windows firewall, just the hardware one in the router.
FredMcD
  • Top 10 Contributor
4274 solutions 59934 answers

Helpful Reply

Some Firefox programs have problems when there is no firewall.

Some Firefox programs have problems when there is '''no''' firewall.
charonn0 0 solutions 14 answers

I followed the above link to http://xfinitytv.comcast.net/tv-listings?cmpid=xf_dash_tvl# and was able to trigger the freeze. I had Sysinternals Process Monitor running at the time, would the logfile be of use?

I followed the above link to http://xfinitytv.comcast.net/tv-listings?cmpid=xf_dash_tvl# and was able to trigger the freeze. I had Sysinternals Process Monitor running at the time, would the logfile be of use?
FredMcD
  • Top 10 Contributor
4274 solutions 59934 answers

If it is not too long.

If it is not too long.
charonn0 0 solutions 14 answers

Here is the Process Monitor log (PML file) with non-firefox processed filtered out: https://www.dropbox.com/s/mcuur6za5e30ke2/FFLockup_Filtered.zip?dl=0

Here is the Process Monitor log (PML file) with non-firefox processed filtered out: https://www.dropbox.com/s/mcuur6za5e30ke2/FFLockup_Filtered.zip?dl=0
FredMcD
  • Top 10 Contributor
4274 solutions 59934 answers

File received.

File received.
FredMcD
  • Top 10 Contributor
4274 solutions 59934 answers

I can't read the file, so I've called the big guys to help you. Good luck.

I can't read the file, so I've called the big guys to help you. Good luck.

Question owner

Thanks to both of you.

Thanks to both of you.

Question owner

FYI, all, this site, which I rarely visit, just froze the system for about 20 seconds: http://www.thecompanystore.com/

FYI, all, this site, which I rarely visit, just froze the system for about 20 seconds: http://www.thecompanystore.com/
FredMcD
  • Top 10 Contributor
4274 solutions 59934 answers

Nice dog, but no issues for me. I don't remember, have you tried to Start Firefox in Safe Mode {web Link} by holding down the <Shift (Mac Options) > key, and then starting Firefox. Is the problem still there?

Nice dog, but no issues for me. I don't remember, have you tried to Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift ''(Mac Options)'' >''' key, and then starting Firefox. Is the problem still there?

Question owner

Yes, I tried that a couple times. The results are in a couple of my posts on the first page. Thanks.

Yes, I tried that a couple times. The results are in a couple of my posts on the first page. Thanks.
charonn0 0 solutions 14 answers

The problem seems to go away if I disable downloadable fonts. (about:config -> gfx.downloadable_fonts.enabled=False.

The problem seems to go away if I disable downloadable fonts. (about:config -> '''gfx.downloadable_fonts.enabled=False'''.
jscher2000
  • Top 10 Contributor
8799 solutions 71976 answers

Hi charonn0, yes, if you have a ginormous font collection, it was reported in the past that the first page you visit during a session that uses a custom downloadable font -- more and more sites these days are doing that -- will lock up Firefox for a time while Firefox assimilates information about all the fonts on your system. Unfortunately, I'm not aware of any better workaround for this, other than never exiting out of Firefox, which really isn't that practical...

Earlier threads:

One of the bugs referenced in the older thread was fixed in Firefox 31. Presumably you are running a version newer than that.

Hi charonn0, yes, if you have a ginormous font collection, it was reported in the past that the first page you visit during a session that uses a custom downloadable font -- more and more sites these days are doing that -- will lock up Firefox for a time while Firefox assimilates information about all the fonts on your system. Unfortunately, I'm not aware of any better workaround for this, other than never exiting out of Firefox, which really isn't that practical... Earlier threads: * [https://support.mozilla.org/questions/983932 Firefox causes desktop to freeze] (Firefox 26) * [https://support.mozilla.org/questions/957111 Firefox hangs on Websites (example: g2play.net)] (Firefox 20.0.1) One of the bugs referenced in the older thread was fixed in Firefox 31. Presumably you are running a version newer than that.
charonn0 0 solutions 14 answers

Using FF 36.0.4 on Win7x64 with 240 fonts installed.

Using FF 36.0.4 on Win7x64 with 240 fonts installed.
jscher2000
  • Top 10 Contributor
8799 solutions 71976 answers

Hi charonn0, 240 fonts is not so many. Your issue most likely is different than those old threads. Never mind!

Hi charonn0, 240 fonts is not so many. Your issue most likely is different than those old threads. Never mind!
Wizzlbang 0 solutions 31 answers

I started getting this exact problem very recently, after downloading a long list of delayed windows updates, not sure if that has anything to do with it but it started happening like right after. Pretty much exactly as OP described, happens on high content websites like tumblr and deviantart, only once per boot though

Have any of the solutions posted worked for anyone?

I started getting this exact problem very recently, after downloading a long list of delayed windows updates, not sure if that has anything to do with it but it started happening like right after. Pretty much exactly as OP described, happens on high content websites like tumblr and deviantart, only once per boot though Have any of the solutions posted worked for anyone?
jscher2000
  • Top 10 Contributor
8799 solutions 71976 answers

Hi Wizzlbang, do you notice any association with use of Flash?

As a test, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

When you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

Feel free to ignore that if you aren't looking to play media on the site.

Also, try disabling the protected mode feature of the Flash player plugin. It has security benefits, but seems to have compatibility issues on some systems. There is a hidden setting for this:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

Hi Wizzlbang, do you notice any association with use of Flash? As a test, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it. To set "Ask to Activate", open the Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". When you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. Feel free to ignore that if you aren't looking to play media on the site. Also, try disabling the protected mode feature of the Flash player plugin. It has security benefits, but seems to have compatibility issues on some systems. There is a hidden setting for this: (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste '''flash''' and pause while the list is filtered (C) Double-click the '''dom.ipc.plugins.flash.disable-protected-mode''' preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.
Wizzlbang 0 solutions 31 answers

don't think it's flash related since flash doesn't activate on the deviantart front page

don't think it's flash related since flash doesn't activate on the deviantart front page