Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Background Tabs Still Load

  • 6 replies
  • 2 have this problem
  • 19 views
  • Last reply by tk_det

more options

Under Settings > Tabs, I have "Don't load tabs until selected" checked and "When I open a link in a new tab, switch to it immediately" unchecked. Yet, despite this, rarely does a tab not load until selected, and only most of the time does a new tab load in the background without focusing.

An example of the latter, by the way, is that when I open a link from an email out of Outlook or a PDF file, basically any external file medium, even if a window is already open (and so it appears as a new tab instead of a new window), the tab always comes into focus.

Both issues occur regardless of whether I use CTRL+Left Click or Right-Click "Open in New Tab". (Although in PDF files and Outlook 2013, the latter method is impossible, the former option is only possible in PDF files, not in Outlook.)

Thanks.

Under Settings > Tabs, I have "Don't load tabs until selected" checked and "When I open a link in a new tab, switch to it immediately" unchecked. Yet, despite this, rarely does a tab not load until selected, and only most of the time does a new tab load in the background without focusing. An example of the latter, by the way, is that when I open a link from an email out of Outlook or a PDF file, basically any external file medium, even if a window is already open (and so it appears as a new tab instead of a new window), the tab always comes into focus. Both issues occur regardless of whether I use CTRL+Left Click or Right-Click "Open in New Tab". (Although in PDF files and Outlook 2013, the latter method is impossible, the former option is only possible in PDF files, not in Outlook.) Thanks.

Chosen solution

Links that you open from a web page or bookmark/history item should always open immediately and not when you go to that tab in case the link is opened in the background.

The "Don't load tabs until selected" setting only applies to when you start Firefox and automatically restore tabs (Show my windows and tabs from last time) and not for when Firefox is already running.


There are three prefs, accessible via the about:config page, to control the focus if you click a link.

  • browser.tabs.loadInBackground (normal links)
  • browser.tabs.loadDivertedInBackground (javascript)
  • browser.tabs.loadBookmarksInBackground (bookmarks and searchbar)
  • http://kb.mozillazine.org/about:config

When you click a link in an external application then the regular tab settings do not apply.

You can override how external links are opened via the browser.link.open_newwindow.override.external pref. The meaning of the value of the browser.link.open_newwindow.override.external is the same as of browser.link.open_newwindow

Read this answer in context 👍 1

All Replies (6)

more options

This behavior is likely caused by an extension.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Thank you. I just did that (started in safe mode and disabled all themes), yet everything I described above still occurs.

more options

Hello? I need some help... :|

more options

Chosen Solution

Links that you open from a web page or bookmark/history item should always open immediately and not when you go to that tab in case the link is opened in the background.

The "Don't load tabs until selected" setting only applies to when you start Firefox and automatically restore tabs (Show my windows and tabs from last time) and not for when Firefox is already running.


There are three prefs, accessible via the about:config page, to control the focus if you click a link.

  • browser.tabs.loadInBackground (normal links)
  • browser.tabs.loadDivertedInBackground (javascript)
  • browser.tabs.loadBookmarksInBackground (bookmarks and searchbar)
  • http://kb.mozillazine.org/about:config

When you click a link in an external application then the regular tab settings do not apply.

You can override how external links are opened via the browser.link.open_newwindow.override.external pref. The meaning of the value of the browser.link.open_newwindow.override.external is the same as of browser.link.open_newwindow

more options

Sorry for the late response. I've been very busy lately.

And okay, thank you. :D I wish FF had the ability to not load ANY tab until you focus it for the first time, but at least there are some other ways to get at least closer to that type of feature.

Thanks very much! ^_^

more options

I have this problem too but only when opening links from inside a hotmail message. Links from other sited (detroit news) with command left click open the new link in a background tab like it is supposed to.