Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

flash player

  • 5 replies
  • 1 has this problem
  • 43 views
  • Last reply by James

more options

Hi, i am using debian linux system and by default its browser is iceweasel which works very well except that it doesn't have a flash player plugin.

i've tried every means but can't solve it.

1. apt-get update apt-get install flashplayer-nonfree it said no this candidate.

can you give me a source to download? i use your default source.

2. download from adobe.com/flash site. download and unzip the folder and cp the libflashplayer.so to mozilla/plugins and lib/iceweasel, restart iceweasel, still doesn't work.

can you help solve it?or let me know where can i find the answers. i've try baidu and cubietech forum. no answer. they told me check https://wiki.debian.org/FlashPlayer/ which doesn't include the correct answer.

i know its core is firefox. i am writing to you to check if you could help solve it. thanks.

thanks, Steve

All Replies (5)

more options

We don't provide iceweasel support here. However, try installing the latest version of Firefox and we'd love to help. Install Firefox on Linux

more options

Mozilla/5.0 (X11; Linux armv7l; rv:17.0) Gecko/20130626 Firefox/17.0 Iceweasel/17.0.7

What are you running this Iceweasel on? as it has armv7 in useragent.

more options

Hi Thanks. My iceweasel 17.0.7. my computer is based a China-made cubietruck which is based on ARM corex-7 which is armhf.

do you know how to solve the flashplayer issue?

more options

@Tyler, when i clicked the download link, it displayed a firefox for android download button which couldn't to be changed to debian. i am not using android.

more options

http://www.adobe.com/products/flashplayer/tech-specs.html Linux 2.33GHz or faster x86-compatible processor, or Intel Atom 1.6GHz or faster processor for netbooks