Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cannot access Hotmail with Firefox on my PC, but can access with other browsers.

  • 4 replies
  • 1 has this problem
  • 12 views
  • Paskiausią atsakymą parašė cor-el

more options

Until yesterday, I could access Hotmail via Firefox (version 70.0.1) on my PC. After signing out, I couldn't sign back in to my other Hotmail account or even the first account. This is what happened & continues to happen: When attempting to access Hotmail via hotmail.com or outlook.com (the same launching page to Hotmail), I'm directed to the sign-in page, then the password page. After correctly entering that info, I ought to be directed to my Hotmail Inbox. Instead, I get directed back to the Hotmail launching page. If I try to access Hotmail again via hotmail.com or outlook.com again, I get stuck in that page; I can't even get to the sign-in page.

Interestingly, I don't experience this problem at all using the other browsers on my PC -- Chrome, Internet Explorer, and Edge. I also don't experience it using the Firefox app on my Android phone. It occurs only when I use Firefox on my PC. Does anyone know how to resolve this problem?

All Replies (4)

more options

if you use a bookmark to access a specific page then instead navigate to this page starting with the main page or the sign in page in case there is a problem with this bookmark.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

One more thing. I've cleared the cache numerous times, but the problem persists.

more options

Disabling "Enhanced Tracking Protection" resolved the problem! (at least for now) Hopefully, disabling that function won't create significant new/different problems. Thanks for your help.

more options

You can click the shield icon and only disable Content Blocking on the Hotmail (outlook.com) website. Note the in Firefox 70 the shield is permanently present unlike in previous Firefox versions where it was only shown when blockable content is present.