Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mulongo oyo etiyamaki na archive. Tuna motuna mosusu soki osengeli na lisalisi

How to keep Ask.com from overriding my preference for Google in the search box? Removing does NOT work.

  • 9 biyano
  • 110 eza na bankokoso oyo
  • 6 views
  • Eyano yasuka ya maquesquifo

more options

In the upper-right corner of the Firefox browser is a search box. This search box allows you to search using your choice of search engine (Google, Yahoo, Wikipedia, etc). This feature allows you to highlight text, right-click on it, and choose to search the web for the highlighted text using the search engine that the user prefers.

I always set the search engine to Google. That's what I want it set on. The problem is that every 5th time or so that I use the feature, Ask.com overrides my preference and establishes itself as the search engine of choice. I can (and do) manually switch it back to Google, but it is extremely frustrating to have to do so.

Solutions tried:

1) I have clicked on the drop-down menu for the search box, clicked "manage search engines," and then manually removed ask.com from the choices (many times). This does NOT work. Even though ask.com is no longer listed when I remove it (and for a number of hours afterward), ask.com nonetheless soon reappears on the list and goes back to overriding my Google preference.

2) I have gone into the control panel and manually deleted everything with ask.com in its description

3) I have done file searches and deleted all files/folders/etc that have ask.com in them

Unfortunately, none of this works. It's as if there's a hidden virus program that reinstalls ask.com back into my list of search engines and makes it the default search engine for the search box.

Please help. Here's what I want to know:

1) How do I stop Ask from doing this????

2) Isn't this illegal? Shouldn't Ask be shut down for this? (I assume Ask is responsible, since they're the ones profiting from it.)

Solution eye eponami

The two Ask entries are indeed added by the Ask Toolbar. If you still have it installed, then remove it.

You can try deleting the two lines by right-clicking the line, choose "reset". If that doesn't work then the Ask Toolbar entries may be located in your prefs.js file and in that case, close Firefox, locate your profile, make a backup copy of prefs.js then right click the file, select "Edit", locate any/all Ask lines and remove them. Restart Firefox to see if this fixed it.

Tanga eyano oyo ndenge esengeli 👍 4

All Replies (9)

more options

I have now tried this:

xxxxxxxxxxxxxxxxxxxxxxxxxxxx

Enter about:config in the Location bar and reset (right-click, press Reset) the following entries:

   browser.search.defaultenginename
   browser.search.defaulturl
   keyword.URL
   keyword.enabled

If Status is default or Reset is grayed out, the value is set to default.

xxxxxxxxxxxxxxxxxxxxxxxxxxx

I have corrected those 4 corrupted values.

HOWEVER, there are 2 more lines that appear quite suspicious:

extensions.asktb.ff-original-keyword-url

extensions.asktb.ff-keyword-uri-default

Those 2 lines are suspicious because they contain "asktb" which probably stands for "Ask Tool Bar."

Can those 2 lines be deleted? (I can't figure out how to delete them.)

Thanks

Ezalaki modifié na Bubstubbler

more options

Solution eye oponami

The two Ask entries are indeed added by the Ask Toolbar. If you still have it installed, then remove it.

You can try deleting the two lines by right-clicking the line, choose "reset". If that doesn't work then the Ask Toolbar entries may be located in your prefs.js file and in that case, close Firefox, locate your profile, make a backup copy of prefs.js then right click the file, select "Edit", locate any/all Ask lines and remove them. Restart Firefox to see if this fixed it.

more options

Many thanks :)

more options

I tried this--there were about 10 Ask.com lines and I deleted them, but it did not get rid of the problem. When I rebooted, Ask.com was the default again. Any other suggestions?

more options

I went back and checked my prefs.js and the deletions were not saved--all the ask lines were back in place--in fact, there are more than 30 of them. I tried deleting them again, but even though I clicked "save" the lines came back after reboot. It's worse now: Ask.com has also now installed a toolbar that I don't want. Ugh, unless this can be solved I'm going to have to leave Firefox.

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

@cor-el --

thanks, but sorry, your response is too obscure for a non-techie like me. Can you explain to a non-programmer?

(I too am about to leave firefox for good if Ask doesn't stop hijacking like this. )

Ezalaki modifié na jackcaffey

more options

This only started happening with the Firefox version, which I absolutely hate. I could've just used google chrome if I wanted this style. I'm trying the manage search engines as described. The past post didn't work and eventually reverted to all these other engines.

more options

I have the same problem. I do everything found on this help answers. I uninstall all ASK or SPEEDBIT software, and the only thing works for me was, erase the prefs.js file. If you reach this level do the following (VISTA solution): 1.- Type in run windows (start button on previous version), %APPDATA% 2.- Looking in the Roaming folder the following \Roaming\Mozilla\Firefox\Profiles\ here you must found the folder with the pref.js file (nnf8aygc.default in my case), delete the pref.js file. 3.- DONE!! well, this option reset all your firefox preferences to default, but belive me, if you reach this point is the only way to delete te ASK search engine an restore the google search engine as default.