Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Location bar settings are Not rememberd when I close FF

  • 4 replies
  • 7 have this problem
  • 6 views
  • Last reply by cor-el

more options

Pfff okay So I set my location bar settings to > Nothing: If selected, the Location bar will not display results that match what you type.

then I close firefox, reopen and voila...It shows history and bookmars. Now funny thing is when i set the location bar to bookmarks, it Does Remember that.

So....What????

I dont want the locationbar to show my bookmarks,

Also, If I set Firefox To not remember any history, that works.

So why are my locationbar settings not working.

Pfff okay So I set my location bar settings to > Nothing: If selected, the Location bar will not display results that match what you type. then I close firefox, reopen and voila...It shows history and bookmars. Now funny thing is when i set the location bar to bookmarks, it Does Remember that. So....What???? I dont want the locationbar to show my bookmarks, Also, If I set Firefox To not remember any history, that works. So why are my locationbar settings not working.

Chosen solution

Privacy and computer cleanup programs can interfere with this (Norton, McAfee). If installed, adjust settings as necessary.

It sounds like the user.js file in your profile folder may be overriding preferences.

Please do the following:

  • Click the Firefox button at the top left, then click the Help menu and select Troubleshooting information from the submenu. If you don't have a Firefox button, click the Help menu at the top and select Troubleshooting information from the menu.
  • At the top of the page, you should see 'Show Folder.' Your profile folder will now be open.
  • At the top of the Firefox window, click on the Firefox button (File menu in Windows XP) and then click Exit
  • Locate the user.jsfile and open it with a text editor such as Notepad
  • Clear the contents of it and save the file.

If the above method fails to get that preference to save, you will need to Reset Firefox:

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to the Troubleshooting Information window in the Help menu.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

Privacy and computer cleanup programs can interfere with this (Norton, McAfee). If installed, adjust settings as necessary.

It sounds like the user.js file in your profile folder may be overriding preferences.

Please do the following:

  • Click the Firefox button at the top left, then click the Help menu and select Troubleshooting information from the submenu. If you don't have a Firefox button, click the Help menu at the top and select Troubleshooting information from the menu.
  • At the top of the page, you should see 'Show Folder.' Your profile folder will now be open.
  • At the top of the Firefox window, click on the Firefox button (File menu in Windows XP) and then click Exit
  • Locate the user.jsfile and open it with a text editor such as Notepad
  • Clear the contents of it and save the file.

If the above method fails to get that preference to save, you will need to Reset Firefox:

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to the Troubleshooting Information window in the Help menu.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

If you have visited a site that you have bookmarked then it becomes a history item and will thus show if you have set the location bar to show history results.

more options

Firefox4life78,

you were spot on with it being caused by "computer cleanup programs can interfere with this"

Some days before the issue I had Installed Advanced System Care, Deleted it the same day because...It would not allow me to isolate my browser from the cleanup, CCleaner does allow you to do that, which I still use.

I located the User.js file like you suggested, and found an entry there something like

user_pref("browser.locationbar.hist.bookm enabled", true)

I just deleted that line and kept the rest,

and sure enough it worked, The location bar now remembers my setting to not show Nothing.


Thanks Alot

more options

Did you create this user.js file yourself because this file doesn't exist by default?

The user.js file is read every time Firefox is started and prefs set in user.js will override settings from the previous session saved in prefs.js.
So prefs that are set via user.js can't be changed permanently and changes made in Firefox only last for the current session.