Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

The address bar doesn't change the URL during a 301 redirection.

  • 2 件の返信
  • 35 人がこの問題に困っています
  • 26 回表示
  • 最後の返信者: xbb

more options

For instance in Firefox, type in "amazon.com" and that address remains in the address bar when you arrive at the amazon site. Try this in another browser (IE) and the address changes to "http://www.amazon.com". It does the same thing for any web site when you type in an address without the www. in the URL. How can I enable Firefox to display the complete redirected URL?

I'm trying to test my 301 redirect for my website from domainname.com to www.domainname.com. The address bar show the redirected address in Safari, IE, OmniWeb... but not so in Firefox.

For instance in Firefox, type in "amazon.com" and that address remains in the address bar when you arrive at the amazon site. Try this in another browser (IE) and the address changes to "http://www.amazon.com". It does the same thing for any web site when you type in an address without the www. in the URL. How can I enable Firefox to display the complete redirected URL? I'm trying to test my 301 redirect for my website from domainname.com to www.domainname.com. The address bar show the redirected address in Safari, IE, OmniWeb... but not so in Firefox.

すべての返信 (2)

more options

This is how it worked for me: After disabling all my add-ons that problem was gone. I gradually enabled all the add-ons again to see which one was causing the problem

more options

Disabled AwesomeBar HD 14, problem gone.