設定情報のバックアップ

Mozilla Firefox は、あなたのブックマークやパスワード、拡張機能など、すべての個人設定を Firefox のプログラムとは別の プロファイルフォルダ に格納しています。この記事では、プロファイルを保存、復元、または新しい場所やコンピュータに移動する方法を説明します。

プロファイルフォルダの場所

Firefox ウィンドウ上部の Firefox ボタンをクリックして ヘルプ メニューメニューバー上 ヘルプ メニューFirefox ウィンドウ上部の ヘルプ メニューをクリックし、トラブルシューティング情報 を選択します。トラブルシューティング情報のタブが開きます。メニューボタン New Fx Menu をクリックし、ヘルプ Help-29 ボタンをクリック、トラブルシューティング情報 を選択します。トラブルシューティング情報のタブが開きます。

  • アプリケーション基本情報 セクションの下の フォルダを表示Finder で表示ディレクトリを開く ボタンをクリックします。プロファイルのファイルフォルダが含まれるウィンドウウインドウ が開きます。
  • 補足: Firefox を使用してプロファイルフォルダが開けないときは、Firefox を開かずにプロファイルフォルダを見つける 手順に従ってください。

    プロファイルをバックアップする

    プロファイルをバックアップするには、まず開いている Firefox を終了してください。次に、プロファイルフォルダを別の場所にコピーします。

    1. Firefox ウィンドウ上部の Firefox ボタンをクリックし、終了Firefox ウィンドウ上部の ファイル メニューをクリックし、終了メニューバー上の Firefox メニューをクリックし、Firefox を終了Firefox ウィンドウ上部の ファイル メニューをクリックし、終了 を選択します。

      メニューボタン New Fx Menu をクリックし、終了終了 Close 29 をクリックします。

    2. 上記の説明どおりにプロファイルフォルダへ移動してください。
    3. あなたのプロファイルフォルダの一つ上の階層へ移動してください。次の場所になります: %APPDATA%\Mozilla\Firefox\Profiles\~/Library/Application Support/Firefox/Profiles/~/.mozilla/firefox/
    4. プロファイルフォルダを右クリック Ctrl キーを押しながらクリックし、コピー を選択します。
    5. 保存先の場所 (USB メモリや空の CD-RW ディスクなど) を右クリックCtrl キーを押しながらクリックし、貼り付けアイテムをペーストしてください。

    プロファイルをリストアする

    1. Firefox ウィンドウ上部の Firefox ボタンをクリックし、終了Firefox ウィンドウ上部の ファイル メニューをクリックし、終了メニューバー上の Firefox メニューをクリックし、Firefox を終了Firefox ウィンドウ上部の ファイル メニューをクリックし、終了 を選択します。

      メニューボタン New Fx Menu をクリックし、終了終了 Close 29 をクリックします。

    2. 既存のプロファイルフォルダと保存したプロファイルフォルダの名前が同じ場合は、単にそれらのフォルダを置き換えて Firefox を開始するだけです。
      重要: プロファイルフォルダの名前は、8 文字のランダムな文字列を含めて完全に一致していなければなりません。名前が一致していないか、別の場所に復元するときは、下記の手順に従ってください。

    別の場所にリストアする

    プロファイルフォルダの名前が既存のフォルダと一致しないか、別の場所にプロファイルを移動、復元したいときは、次のようにします:

    1. Firefox を完全に終了してください。
    2. 目的の場所に Firefox のプロファイルマネージャを使用してフォルダを作成 し、プロファイルマネージャを終了します。
      注記: Firefox を新しい新規 コンピュータにインストールしたばかりのときは、新しい新規 プロファイルを作成する代わりに、最初の Firefox 実行時に自動的に作成される既定デフォルト のプロファイルを使用できます。
    3. プロファイルを保存したドライブ、または保存媒体 (USB メモリなど) に移動します。
    4. プロファイルフォルダ (xxxxxxxx.default のバックアップフォルダ) を開きます。
    5. プロファイルフォルダのバックアップから mimeTypes.rdf ファイル、prefs.js ファイル、bookmarkbackups フォルダなどの 内容 全部を選択してコピーしてください。
    6. 新しい新規 プロファイルフォルダへ移動して開きます。Firefox は閉じておいてください。
    7. プロファイルフォルダのバックアップから新しい新規 プロファイルフォルダに内容を貼り付けペーストしてください。同名のファイルは上書きしてください。
    8. Firefox を開始します。


    この記事を共有する: http://mzl.la/1xKrFsk

    この記事は役に立ちましたか? しばらくお待ちください...

    この記事の貢献者: marsf, dskmori, delihiros, yassan138。あなたも手助けしませんか?- 貢献するにはこちらから