Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How I can I force Firefox to open Quicktime .MOV in movie player?

  • 18 risposte
  • 4 hanno questo problema
  • 7489 visualizzazioni
  • Ultima risposta di DarrenDriven

more options

I have a security camera that records video clips in .mov format. I use Firefox to access the camera's server, which lists the movie files available for download. Each time I select a link, a popup window asks me if I want to Open with "The KMPlayer (default)" or download, and the "Do this automatically for files like this from now on." box is grayed out.

I spent 30 minutes researching this and have tried editing the .mov line in Firefox's applications settings and tried an add-on, but neither made any difference.

I am reviewing 20-30 files each morning and it is very annoying to click OK every time I want to watch the video, when it seems that Firefox should automatically open the video player on its own.

Soluzione scelta

Oh... I didn't notice this in your screen shot before, but it says Content-Disposition: attachment, which I think always triggers the box.

How about another add-on to try to work around that? https://addons.mozilla.org/firefox/addon/inlinedisposition/

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (18)

more options

Usually QuickTime will play MOV in the browser. However, if the server is not sending one of the content types recognized by Firefox, you my get a more generic suggestion in the Open/Save/Cancel dialog.

You might be able to view the content type header using the Web Console (Ctrl+Shift+k). If you have that open before clicking the link to the particular file, then click it, that URL should appear in the console. If you click the URL, Firefox will display the Request and Response headers. What you want to find is the Content-Type header under Response Headers. What does it say?

more options

Hmmm... nothing appears in the console. I played around with it and made sure that all of the buttons (Net, CSS, etc) were depressed, but still it remains blank.

Could it be because the link to each .mov file has a target of "_blank"? So it's really opening a new browser window for a split second, then that window vanishes and the "What should Firefox do with this file" dialog box appears.

more options
more options

I tried the add-on.... but not sure what I need to do in order for that to make any difference. It asks for the URL, the old content type and the new content type.

Well, for the URL I entered just the IP address of the camera server, but I don't have any idea what I need to enter into the old and new content type areas. video/quicktime is an option in the dropdown menus... but I tried putting that in both the old and new content type settings and it didn't make any difference when I clicked on the .mov video file link.

more options

Screen shot... not sure if this help or not.

Tried using a slash to cover all websites, and tried converting to a new type video/mov... still doesn't change anything.

Modificato da DarrenDriven il

more options

Darn it, I just accidentally clicked the Mark as Solved in the email... it is not solved.

Solution still needed.

more options

What is the content type that the server sends for this file?

You can use the Live Http Headers extension to check the server response (this might be easier than using the Network tab in the Web Console, Firefox/Tools > Web Developer)

more options

To try to force the URL to be requested in the same tab, you could try dragging and dropping the link on the address bar.

Or perhaps you can read the content type header in the Browser Console? You can open that one using Ctrl+Shift+j and it is a separate window. I don't always see all the URLs listed there.

more options

Copying and pasting the link into the current window's address bar did the trick. Clicked on the link in the console and here is the information that was provided:

more options

The application/octet-stream content type is a generic MIME type that will Firefox always ask to save the file. So you need to use the extension to change that content type to a MIME type that the QuickTime plugin or program supports.

You can see supported MIME types on the about:plugins page.

more options

And/or, if you have access to the server, you may be able to add the content type so Firefox knows how to handle the content without needing an add-on. If it's a proprietary solution, that might not be possible.

more options

We are definitely getting closer!

I used the add-on to convert octet-stream to quicktime and now I get a revised dialog box, as show below. It correctly identifies the filetype as quicktime, it also ungrayed the "do this automatically" box, which is now checked... I had such high hopes!

But... each time I click on a link, the dialog box pops up -- even though it is checked to automatically open KMPlayer. This makes no sense.

more options

Try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

more options

I can't change anything on the server.


OK, so I followed these instructions:

1. Type about:config into the address bar.

2. Find the preference browser.download.pluginOverrideTypes and, if it is present, right-click on it and select reset.

3. Find the preference plugin.disable_full_page_plugin_for_types and, if it is present, right-click on it and select reset.

4. Open the profile folder. (The profile folder is hidden by default in Windows 7/Vista/XP/2000 and Linux; read this for help finding it).

5. Completely close your Mozilla browser.

6. Delete (or rename) the file mimeTypes.rdf.


It didn't change Firefox's behavior, though. I still get the same popup dialog box with the checkmark to automatically do this behavior checked.

Modificato da DarrenDriven il

more options

If you return to the Options dialog, Applications panel -- this is reset to default when you delete or rename mimeTypes.rdf, can you check/adjust the setting for "QuickTime Movie"?

(That is based on what I see on the about:plugins page for "video/quicktime")

more options

Yes, it was reset to "use Quicktime plug-in in Firefox", so I changed it back to "Use KMPlayer".

But this still had no effect. I still get the same dialog box asking me how to handle the file, and it still says Use KMPlayer (default) and has the checkbox checked.

more options

Soluzione scelta

Oh... I didn't notice this in your screen shot before, but it says Content-Disposition: attachment, which I think always triggers the box.

How about another add-on to try to work around that? https://addons.mozilla.org/firefox/addon/inlinedisposition/

more options

That was the very first add-on that I tried and it didn't fix it... but in combination with the Live Http Headers extension and resetting everything, this is now working!

Thank you guys!