Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

I am trying to download add-on F1. It says that I have FF 2.0 but I have FF 4.0.

  • 2 risposte
  • 2 hanno questo problema
  • 14 visualizzazioni
  • Ultima risposta di j-me2011

more options

I have upgraded Firefox to 4.0. I have done this several times and it says that it is upgraded, but when I go to do certain things , like download add-on such as F1, I get a message saying that it is not available for Firefox 2.0! I don't think I have ever even had 2.0. ??????????????

Soluzione scelta

This is typically caused when an add-on changes the user agent string (identifies the version of Firefox). To rectify this you can reset your user agent string.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference general.useragent.override, right-click (or control-click) on it and select Reset, this will set the user agent string back to the default in Firefox 4

There are other user agent string settings that may have been modified, but these are no longer used in Firefox 4. You can reset them if you want, for details see https://support.mozilla.com/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (2)

more options

Soluzione scelta

This is typically caused when an add-on changes the user agent string (identifies the version of Firefox). To rectify this you can reset your user agent string.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference general.useragent.override, right-click (or control-click) on it and select Reset, this will set the user agent string back to the default in Firefox 4

There are other user agent string settings that may have been modified, but these are no longer used in Firefox 4. You can reset them if you want, for details see https://support.mozilla.com/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser

more options

That worked! Thank you so much!