Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How to stop Firefox from closing multiple tabs when I only want to close single ones?

  • 3 risposte
  • 1 ha questo problema
  • 4 visualizzazioni
  • Ultima risposta di McCoy

more options

When closing tabs by clicking it's own "close cross/button" I often get a popup sayin I'm about to close x many tabs. If I don't click the popup firefox closes also tabs that I haven't clicked to close (because I want them to remain open). If I don't clikck the popup, the tabs that get closed seem to be ones that I've opened through a tab that I do want to close.

As you can guess, this is highly frustrating. I have loads of tabs open at any given time and I'm using Tree Style Tabs to keep them a bit more organized. I haven't found anyone else with this problem so could it be causing this behaviour?

Soluzione scelta

You would get this pop-up if you are trying to close the window. Make sure you click the close X on the tab and not the close X in the top right corner that will close the window. If this still happens when you click the close X on the tab then check for issues caused by extensions.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Leggere questa risposta nel contesto 👍 0

Tutte le risposte (3)

more options

Soluzione scelta

You would get this pop-up if you are trying to close the window. Make sure you click the close X on the tab and not the close X in the top right corner that will close the window. If this still happens when you click the close X on the tab then check for issues caused by extensions.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

As I mentioned the issue was multiple tabs getting closed by clicking one tab's own close button.

It looks like the Tree Style Tabs extension was causing my issue, because removing it solved the problem.

Thank you for your help anyway :)

more options

Lasse Hurttila said

It looks like the Tree Style Tabs extension was causing my issue, because removing it solved the problem.

Thank you for your help anyway :)

Hello Lasse Hurttila,

As cor-el suggested Safe Mode to see if one of the extensions might be the culprit (which it was); would you be so kind as to mark cor-el's post as Chosen Solution ? You can do so by clicking on the "Solved the problem" button to the right of cor-el's post.

Thank you in advance !