Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How to start FireFox Quantum in fullscreen (kiosk) mode?

  • 7 risposte
  • 158 hanno questo problema
  • 68432 visualizzazioni
  • Ultima risposta di music01

more options

How to start FireFox Quantum in fullscreen (kiosk) mode?

Soluzione scelta

I don't think this is possible.

Leggere questa risposta nel contesto 👍 2

Tutte le risposte (7)

more options
more options

Thank you for your help. This is not what I need because the webpage is not visible. I need a way to start Firefox in fullscreen mode (kiosk mode), like if you press the F11 key (no pulldown menus, no title bar, ...).

Modificato da music01 il

more options

Soluzione scelta

I don't think this is possible.

more options

Hallo it is posible. Linux: https://forum.ubuntuusers.de/topic/kiok-modus-firefox-quantum/

You make in ~/.mozilla/firefox/PROFIL.default/chrome/userChrome.css with content:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */ ,#fullscr-toggler { display:none!important; }

or in Windows in C:\Users\user\AppData\Roaming\Mozilla\Firefox\Profiles\yourProfile.default\chrome\userChrome.css

The new directory chrome must manuell created. By your self. The , bevor fullscr-toogler must removed and left side.

Modificato da Knarf68 il

more options

^: That is something different and is about to prevent showing the toolbars if you hover the mouse to the top of the page in Full Screen mode (F11).

The OP wants to start Firefox in Full Screen mode.

The kiosk extensions aren't compatible with Firefox 58+ (WebExtension).

more options

Knarf68 said

Hallo it is posible. Linux: https://forum.ubuntuusers.de/topic/kiok-modus-firefox-quantum/ You make in ~/.mozilla/firefox/PROFIL.default/chrome/userChrome.css with content: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */ ,#fullscr-toggler { display:none!important; } or in Windows in C:\Users\user\AppData\Roaming\Mozilla\Firefox\Profiles\yourProfile.default\chrome\userChrome.css The new directory chrome must manuell created. By your self. The , bevor fullscr-toogler must removed and left side.

Thanks!

more options

Thank you for your answer.

As user "cor-el" wrote, this only prevents that (in full screen mode by pressing the F11 key) the FireFox menu appears if you move the mouse to the top of the page.

FireFox however starts in normal mode and not in full screen (kiosk) mode, you still have to press the F11 key.