X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox won't open profiles on my server

Inserita

I keep three profiles on my Network Attached Server (ReadyNAS Ultra 4), where they get backed up every night. Firefox v32 opens fine on my older Ubuntu 12.04LTS box and my even older WinXP box.

My newer Ubuntu 14.04LTS machine came with Firefox v35 (if I recall correctly). It wouldn't open my profiles. I upgraded to v37. It still will not open any of the three profiles on the server. FF will start only if I use a locally-stored profile. I can open them on a VMWare virtual WindowsXP machine on this box (again, v32), but not natively in Ubuntu. I get the message:

Firefox cannot use the profile "Private" because it is in use.

I don't know if this is a bug with v35+ or something peculiar about my install of Ubuntu 14.04. Chrome works fine, and I have no other problems with the files on the server. If it were a permissions issue, I don't think it would work on my 12.04 box.

Please help. I'd like to use Firefox again someday.

I keep three profiles on my Network Attached Server (ReadyNAS Ultra 4), where they get backed up every night. Firefox v32 opens fine on my older Ubuntu 12.04LTS box and my even older WinXP box. My newer Ubuntu 14.04LTS machine came with Firefox v35 (if I recall correctly). It wouldn't open my profiles. I upgraded to v37. It still will not open any of the three profiles on the server. FF will start only if I use a locally-stored profile. I can open them on a VMWare virtual WindowsXP machine on this box (again, v32), but not natively in Ubuntu. I get the message: Firefox cannot use the profile "Private" because it is in use. I don't know if this is a bug with v35+ or something peculiar about my install of Ubuntu 14.04. Chrome works fine, and I have no other problems with the files on the server. If it were a permissions issue, I don't think it would work on my 12.04 box. Please help. I'd like to use Firefox again someday.

Dettagli aggiuntivi sul sistema

Applicazione

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.94 Safari/537.36

Ulteriori informazioni

FredMcD
  • Top 10 Contributor
4398 soluzioni 61724 risposte

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.

Risposta utile

FredMcD said

I've called the big guys to help you. Good luck.

Any idea when these "big guys" might respond?

''FredMcD [[#answer-722880|said]]'' <blockquote> I've called the big guys to help you. Good luck. </blockquote> Any idea when these "big guys" might respond?
FredMcD
  • Top 10 Contributor
4398 soluzioni 61724 risposte

Risposta utile

When they can. With a new version, we and they get busy helping out.

When they can. With a new version, we and they get busy helping out.

Utente che ha posto la domanda

I've asked this question a couple of times before over the past year, on a couple of different forums. It's never gotten answered. I really can't believe I'm the only person running Firefox profiles on a server. (Well, I guess I'm not, any more.)

I've asked this question a couple of times before over the past year, on a couple of different forums. It's never gotten answered. I really can't believe I'm the only person running Firefox profiles on a server. (Well, I guess I'm not, any more.)
christ1
  • Top 25 Contributor
2224 soluzioni 16259 risposte
http://kb.mozillazine.org/Profile_in_use
FredMcD
  • Top 10 Contributor
4398 soluzioni 61724 risposte
'''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save'''

Utente che ha posto la domanda

christ1 said

http://kb.mozillazine.org/Profile_in_use

I've tried all that before (and I just did again). I deleted the profile name, re-created it, rebooted, tried to open it and got the same error. I checked the profiles.ini file; everything is okay. I deleted the existing .parentlock file (although I've heard that's not used by FF to determine profile in use anymore), and there is no lock file.

As soon as I select my profile and click OK, a .parentlock file is created in the profile directory, and the message recurs.

It's as if it creates the .parentlock file, THEN checks to see if that file is there, then generates the error message when it finds it. I'm not suggesting that's what's happening, but that is the appearance.

''christ1 [[#answer-724219|said]]'' <blockquote> http://kb.mozillazine.org/Profile_in_use </blockquote> I've tried all that before (and I just did again). I deleted the profile name, re-created it, rebooted, tried to open it and got the same error. I checked the profiles.ini file; everything is okay. I deleted the existing .parentlock file (although I've heard that's not used by FF to determine profile in use anymore), and there is no lock file. As soon as I select my profile and click OK, a .parentlock file is created in the profile directory, and the message recurs. It's as if it creates the .parentlock file, THEN checks to see if that file is there, then generates the error message when it finds it. I'm not suggesting that's what's happening, but that is the appearance.

Utente che ha posto la domanda

Also, I tried creating a brand-new profile on the server, rather than using my existing profiles. Same thing.

Also, I tried creating a brand-new profile on the server, rather than using my existing profiles. Same thing.

Utente che ha posto la domanda

Any chance Mozilla will ever address this?

Any chance Mozilla will ever address this?
cor-el
  • Top 10 Contributor
  • Moderator
17876 soluzioni 161748 risposte

Did you check the permissions to make sure that nothing is wrong?

Does Firefox otherwise has a problem with accessing this server if you use a local profile?

Did you check the permissions to make sure that nothing is wrong? Does Firefox otherwise has a problem with accessing this server if you use a local profile?

Utente che ha posto la domanda

It's not permissions: FF v32 opens the profiles just fine. And yes, FF v37 can open HTML files on the server with no issues.

It's not permissions: FF v32 opens the profiles just fine. And yes, FF v37 can open HTML files on the server with no issues.